none
Unable to create a new project in the web interface - I was in the process of configuring Project and TFS integration RRS feed

  • Question

  • Hey everyone,

    Our company was already using TFS, and we decided that Project Server 2010 would be the best option to help us manage our projects and to keep tasks in sync with TFS.

    I was able to finally (after a few days... this is pretty much my first time working with Sharepoint and Project Server) get everything installed and working. We have TFS SP1, Sharepoint 2010 SP1, Project Server SP1, and the TFS Project integration pack installed.

    I was in the process of using Visual Studio Command Prompt to link the Project Server to the TFS Server. I was able to Register the PWA, Associate a Project Collection with the Registered PWA, and I specified the mappings.

    I ran into some permission based errors getting that to work, but I finally figured out the cause of those issues and everything completed successfully. The next part of integrating TFS with Project Server was to map a Team Project to an Enterprise Project. We already have a number of Team Projects in TFS, but I didn't have any Enterprise Projects in Project Server 2010.

    This leads me to where I'm currently stuck. When I log into the web interface of my PWA site either as my main AD account, or the FarmAdmin account used when creating Project Server 2010, and I click on New -> Basic Project Plan, I'm presented with a screen that only has a Cancel button and a Save button (but the Save button is greyed out and there's no options available for me to choose on that page). Please see this image:

    I've tried logging in via my main AD account and the FarmAdmin account and I see the same thing. Both accounts are Administrators in my PWA site.

    Interestingly enough, I can actually create projects using Project Professional on my Desktop. But for some reason, I can't create them via the web interface. I'm thinking this is a permission issue of some sort. Anyone have any ideas or thoughts about what I can check?

    Saturday, October 29, 2011 10:04 PM

All replies

  • Perhaps there are no Project Detail Pages associated with the Basic project type.  To check:
    Server Settings > Enterprise Project Types.  Click on Basic.  scroll down to see if there are any PDPs selected.
    Reid McTaggart Partner DeltaBahn LLC
    Monday, November 14, 2011 4:20 PM
  • Along the lines of what Reid is saying, if there IS in fact a PDP associated check to see if it actually has the Project Fields web part inserted into it. I had a similar thing once where I accidentally removed the project fields webpart from the New Project PDP that was listed for the Basic Project Enterprise Project Type.
    Brian Kennemer – DeltaBahn Senior Architect
    Blog | Twitter | LinkedIn
    Monday, November 14, 2011 5:23 PM
    Moderator