Hyper-V "Failed to import a virtual machine"


  • This feels very much like a repeat of other questions, but I've been through the forums and can't find an answer.

    We have two Hyper-V servers: one is Windows Server 2008 R2 with Hyper-v installed (not core, the full server installation) the second is Hyper-V server 2008-R2.

    I created a Virtual machine on server 1 (call it VMH1) to upgrade our Dynamics SL installation, so it has SQL Server on it as well. Using the Hyper-V Manager, I shut down the VM and exported the VM. That took about 20 minutes and finished with no errors. I then copied the export files to VMH2, the Hyper-V Server (which took about an hour) and ran the import there. Got the "Import file format error" which seems to have happened frequently with the 2008 RTM version, but everyone agrees was fixed with 2008 R2. The .exp files don't have server names in them.

    So, I created a brand-new VM running Windows Server 2008 on VMH1, joined it to the domain, etc, then shut it down and exported it, moved it to VMH2, and imported it successfully. So, there doesn't appear to be anything wrong with the fundamental export-import procedure, I just can't export our actual production VM server to the other VMH.

    An additional complication is that since VMH2 is core, there's no GUI, so I am running the Hyper-V manager on VMH1. Can't find any error messages or anyplace where the errors would be written on either server.

    What do I do?

    Monday, August 05, 2013 6:37 PM

All replies

  • If your Server (the Hyper-V one) was upgraded from the original 2008, you might have some configurations that are no longer compatible with that particular VM.

    You should also be able to import the VM bask to the same Hyper-V Server without error (it just creates a duplicate, so rename one in the GUI to keep them straight).

    I bring this up as it may point out a different error.

    Also, the version of the remote RSAT tools needs to match the version of the Hyper-V server.  2008 to 2008, R2 to R2, R2 SP1 to R2 SP1, etc.  Things do change and incompatibilities with the remote tools do happen, and have over the past releases.

    Brian Ehlert
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Monday, August 05, 2013 8:47 PM
  • No, neither host server was upgraded; they were both set up with the OS they are now running (with various Windows updates applied.)  So far as I know, you can't upgrade them in place; I wouldn't have even tried.

    So they're 2008 R2. But one is Windows Server 2008 R2 with Hyper-V running on it, the other is Hyper-V server 2008 R2.

    Monday, August 05, 2013 9:24 PM
  • You can use Windows event log viewer from the Windows server to connect to your Hyper-V server and search any errors related to Hyper-V.

    Another approach is to copy the VHD file from your server 1 to the server 2 and create a new VM on the server 2 and attach the copied VHD to the new VM.  

    Tuesday, August 06, 2013 8:37 PM
  • I don't doubt there's a way we can get around it. But I'd kind of like to know what the problem is. Is it that we can't migrate VMs between Windows Server with Hyper-V and Hyper-V Server? is it that there are too many snapshots? (I saw a forum post someplace that suggested that as the source of a different problem.)

    Or, do we just take the classic "gosh, I dunno, it ought to work" response made famous by folks like Symantec?

    Networks are not static things, and especially with virtualization: one of the big selling points is the ability to shift VMs from one hardware platform to another as demands change. If there are severe restrictions to the way that works, by design or in practice, it doesn't seem unrealistic of me to want to understand them before I get too much further down the road.

    Wednesday, August 07, 2013 12:11 AM
  • If you have snapshots, the error could be rooted in the configuration of some of the snapshots.

    I have seen that in the past. But if you are,doing an export, it should resolve that.

    if the snapshots were taken when the VMs were running, the migration used to be

    there should be deeper detail in the hyper-v event logs.blocked until the saved memory states were deleted.

    Brian Ehlert
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Wednesday, August 07, 2013 12:26 AM
  • Hi,

    Just checking in to see if the suggestions were helpful. Please let us know if you would like further assistance.

    If you have any feedback on our support, please click here .

    Cataleya Li
    TechNet Community Support

    Thursday, August 08, 2013 2:56 AM
  • Is there ANYTHING here that was helpful? perhaps if I were more technically sophisticated,

    "if the snapshots were taken when the VMs were running, the migration used to be there should be deeper detail in the hyper-v event logs"

    would have solved things for me.

    I guess my expectations were out of line: when I read "Go to the  TechNet Managed Forums, where you are guaranteed a response within 2 business days." I assumed that meant I would get a *useful* response.

    I've been through the hyper-v event logs on both the host servers, and there's absolutely no information, aside from a restatement of the "Import file format error" message that popped up when I tried to run the import.
    • Edited by KCTS 9 Thursday, August 08, 2013 3:45 PM
    Thursday, August 08, 2013 3:36 PM
  • The forums are supported by volunteers, not staffed by MSFT support.

    If you have critical support issues that you need resolved immediately, this is not the place.  You need to call MSFT customer support.  (and pony up a credit card).

    Can you please restate your current situation?

    I see that my last reply got a bit muddled while typing on my phone.  It should have read:

    "if the snapshots were taken when the VMs were running, the migration used to be blocked until the saved memory states were deleted."

    Is there more detail around the "import file format error"?

    Since you are running 2008 R2 (or newer) try this:

    Create a snapshot of your production VM.  Select that snapshot.  Export that snapshot.  Then copy the entire snapshot folder (structure intact) to the other Hyper-V Server and try to import it.

    This can resolve a number of various things that could have happened in the life of the VM.  And simply jumping to this, would give you results faster than the interrogation.

    Brian Ehlert
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, August 08, 2013 4:01 PM
  • Yes, I understand that the forums are supported by volunteers, which makes is curious that Microsoft "guarantees" a response.

    Tried creating exporting a snapshot of the production VM. The snapshot was made from VM while it was running, a few days ago. Hyper-V-VMMS event log said:

    'KCTSACCT4' failed to perform the operation. The virtual machine is not in a valid state to perform the operation. (Virtual machine ID 7BCBBA90-BFFE-4DB8-9D7F-813D0FFC973E)

    I saw in another forum something about Hyper-v not liking it when a VM has the cd-rom captured. In this case it didn't, but the server does have an ISO disk image mapped as a drive letter (D:)  So, I shut down the production server, and un-mounted the D: drive, and generated a snapshot. Tried exporting the snapshot this morning, got the identical error.

    Monday, August 12, 2013 4:42 PM