locked
some of SharePoint Preupgrade check items are failed RRS feed

  • Question

  • Hi,

    My 2007 server is a standalone server. OS is 32 bit windows server 2003 R2. MOSS 2007 build version 12.0.0.6520. SQL Server 2005 with version  9.00.4035.00. After preupgrade check run i find three failed. They are

    1) OSPrerequisite

    2) ServerConfigErrors

    3) UnsupportedSQLServerVersion

    What should I do to resolve this. Since My sql server is on 32 bit computer is it eligible to migrate?

    Thanks,


    -Gautham

    Monday, June 11, 2012 4:37 PM

Answers

  • Yeah, you don't need to worry about #1 and #3.  #2 is telling you that there are files referenced in your content that are not installed.  Such things could be a custom feature, or a template, etc.  When you build your new SP 2010 servers, you will need to add those features or else a site that is using it may not render properly. 

    Check the .htm page that is generated from running preupgradecheck for more details on that error.

    Monday, June 11, 2012 7:10 PM

All replies

  • This means that you can't do an in-place upgrade since your MOSS OS is 32-bit and your SQL server needs to also be 64-bit.

    The only way you can migrate is to do the Database Attach method.

    Monday, June 11, 2012 5:12 PM
  • Hi Tyrone,

    Thanks for quick reply. Is it my server ready for database attach method OR still I need to fix those errors. Am I ready to go for database attach migration??

    Thanks,


    -Gautham

    Monday, June 11, 2012 6:39 PM
  • Yeah, you don't need to worry about #1 and #3.  #2 is telling you that there are files referenced in your content that are not installed.  Such things could be a custom feature, or a template, etc.  When you build your new SP 2010 servers, you will need to add those features or else a site that is using it may not render properly. 

    Check the .htm page that is generated from running preupgradecheck for more details on that error.

    Monday, June 11, 2012 7:10 PM
  • Hello Gautham,

    SharePoint 2010 needs a 64-bit infrastructure, which means that you need to have a 64-bit Computer with 64-bit Operating System.

    What is your current system configuration?

    You can refer the official requirements at this Technet article:

    http://technet.microsoft.com/en-us/library/cc262485%28office.14%29.aspx


    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, June 12, 2012 4:12 AM