locked
Error while running New-SPConfigurationDatabase PS RRS feed

  • Question

  • After I run the New -SPConfigurationDatabase PS through SharePoint 2010 Management Shell, I typed Databasename and servername , after which it prompted for UserID and password, I typed the domain service account & password. After which it gives a error:
    "Requested registry access is not allowed"

    This service account is added as an administrator to the WFE server and aslo this has dbcreator & sysadmin privileges on database instance....
    Any help is much apreciated....

    Thanks and Regards,
    Charan V
    Friday, January 22, 2010 9:50 PM

Answers

  • Are you running the Management Shell as Administrator? If not, can you try running it as Administrator and execute the command?
    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Saturday, January 23, 2010 12:40 AM

All replies

  • Are you running the Management Shell as Administrator? If not, can you try running it as Administrator and execute the command?
    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Saturday, January 23, 2010 12:40 AM
  • Chakkaradeep,

    yes, even when being logged in with an administrator account and having set the user account control to the lowest level, it IS necessary on my machine to explicitly run the command "As Administrator".

    Monday, May 31, 2010 1:25 PM
  • This is a long shot, but do you happen to have any anti-virus or similar software that could be blocking registry access?   If you logged in as a local admin and running "as administrator" you should have full permissions on the local registry.

    I believe the error is occuring when SharePoint is trying to update the connection string in the registry. 

    HKEY Local Machine\Software\Microsoft\Shared Tools\Web Server Extensions\14.0\Secure\ConfigDB

    The key is dsn.

    I don't ever recommend changing permissions on the registry, however, you could take a look on the WFE and see if that path is created and who has permissions on it.

    Tuesday, June 1, 2010 3:53 PM
  • You need to use a domain-account. Your domain may be MYDOMAIN and the user you would like to use for installation be MYDOMAIN\WSSAdmin. MYDOMAIN\WSSAdmin needs to have the above mentioned access rights to the SQL Server. You can check this, when accessing the SQL-Server via RDP with MYDOMAIN\WSSAdmin and being able to open the SQL Server Management Studio, accessing the master db with Windows Authentication.

    Add MYDOMAIN\WSSAdmin to the lokal Administrators group on the server you would like to install SP2010 to.

    Login as MYDOMAIN\WSSAdmin on the server you would like to install SP2010 to and start the SP2010-installation.

    Now you should be able to successfully run New-SPConfigurationDatabase.

    Peter

    Wednesday, June 2, 2010 10:14 AM
  • Hi Peter, you're right: all is better when using Domain accounts.

    However, I am trying to set up a Workgroup environment without AD, as the demo laptop doesn't have enough RAM, and I know many people who are trying to do so as well. Hence, no Domain accounts can be used.

    Wednesday, June 2, 2010 4:55 PM
  • Thanks Peter, that's an accurate suggestion and one I could implement as I am putting WServer 2008 on another machine, so I could set-up the DC. However what I'm trying to accomplish with this system is a standalone development-only environment like this. 
    Thursday, June 3, 2010 2:28 AM
  • Hi All... did we get an answer to the original question?

    I have the same problem trying to set up an SP Farm on a local virtual cloud server and I do not have any domain possibilities.

    Thanks in advance :)

    HankC

    Tuesday, October 4, 2011 8:19 AM
    1. If the SharePoint configuration DB is already created, delete it.
    2. Right-click SharePoint 2010 Management Shell
    3. Select "Run as administrator"

    This did it for me.

    Friday, December 14, 2012 3:57 AM