none
DPM2010 don't delete Shadow Copys, nor manually with pruneshadowcopiesDpm2010.ps1 RRS feed

  • Question

  • Hello, my Fileserver have an amount of 2TB that DPM protects over several protection groups. The rentention time is 5 Days. But the protection group says 19-20 days. latest 16.11.2010, last 3.12.2010.

     

    So now I get many errors like to small disk space or can not backup to tape ....

     

    How can I delete the recovery Points manual?

    Tuesday, December 7, 2010 7:09 AM

All replies

  • Hi schrippe!

    Every night the script pruneshadowcoipesdpm2010.ps1 runs on your DPM server. The script will verify the retention time on your different protection groups and adjust those replica and recoverypoint volumes with the correct data.

    Sometimes when a DPM server gets heavily loaded the script will fail to run or preform its tasks.

    To resolve your problem, try to reboot your DPM server and directley after run the PruneShadowCopiesDpm2010.ps1 script again from the DPM PowerShell console.

     

    BR

    Robert Hedblom

     



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Tuesday, December 7, 2010 9:38 AM
    Moderator
  • Hello,

     

    Now I restartet my DPM Server and direct after boot I started prune... .ps1. But these protection groups even says now 20-21 recovery points.

    Tuesday, December 7, 2010 3:37 PM
  • Hi,

    How often do you have replica/recvoery points scheduled? You could have the retention set to 5 days but be taking 4 RP's a day giving you 20 RPs?

    J

    Wednesday, December 8, 2010 4:49 PM
  • Hello,

     

    5 Days RT every 24 hours.

    Must I delete the PG? Now I have 23 R-Points.

    Wednesday, December 8, 2010 6:39 PM
  • I just deleted these Protection Group and reassign a new with same settings. now it works today!  I will wait and see.

     

    Another issue: Can I get a timeline of all my scheduled Backups? I lost the overview. (I don't know why DPM does an detailled inventory on Tape every 4 am.

     

    Thursday, December 9, 2010 6:49 AM
  • You can go to Monitoring, Jobs,Group By-Type, Filter names- Today's jobs

    That will so you what's sceduled to run today.

    If you want a text overview of your PG's I posted a script which I use to document my PG's http://gallery.technet.microsoft.com/scriptcenter/en-us/1c9c61ce-688f-4ef0-8d9b-cd93cd703c45

    Hope it helps.

    J

    Thursday, December 9, 2010 8:46 AM
  • My problem persists. Now any other PG growing there RecoveryPoints to more than 5 (RT is 5 days, backup only 1 times a day). Is it possible to move the Prune... job to another daytime?
    Monday, December 13, 2010 6:44 AM
  • I am having a similar issue. When I run the PruneShadowCopiesDpm2010.ps1 it is bring up errors. This worked well for me in 2007 before migrating to 2010.
    Tuesday, December 14, 2010 8:32 AM
  • I can run the script manually. I gives me completely  to output. No errors or progress informations.
    Tuesday, December 14, 2010 8:40 AM
  • Is it  possible that some of these RP are from a previous PG? Have you moved servers from one PG to another?

    Tuesday, December 14, 2010 8:45 AM
  • maybe ?!

    No, I do not moved servers from one PG to another. (I think); I just tested many things.

    Tuesday, December 14, 2010 8:59 AM
  • The only reason I ask is I've been looking a disk allocation from my DPM setup and after reading http://blogs.technet.com/b/dpm/archive/2010/11/03/protect-unprotect-protect-unprotect-understanding-how-dpm-2010-retention-works.aspx I produced a script to check out out disk allocation (http://gallery.technet.microsoft.com/scriptcenter/en-us/7e9f4926-000b-4c9f-bbe9-8f4b4ac7187f) and I've noticed I seem to have some duplication of volumes and assumed it was due to moving protected servers from one PG to another (with different retention policies)

     

    Tuesday, December 14, 2010 9:19 AM
  • Hi,

    It looks like I've been having the same issue with PG's. I have PG's set to only 7 days but keeping them for much longer and choking my disk storage.

    Rebooting the server, running pruneshadowcopiesDpm2010.ps1 which returns no errors, checking the event log and then manually deleting recovery points with powershell to give my backup disk enough space.

    Get-ProductionServer YOURDPMSERVER | Where-Object { $_.AreRecoveryPointsPresent -eq $True -and $_.name -eq "YOURPROTECTEDSERVER.COMPANY.COM"} | Get-Datasource | Get-RecoveryPoint | Where-Object {$_.DataLocation -eq "Disk" -and $_.RepresentedPointInTime -lt "17 December 2010 00:00:00"} | Remove-RecoveryPoint -ForceDeletion -confirm:$True

    I'm looking at the pruneshadowcopiesDpm2010.ps1 script and if you set the verbose level to continue you might get more information about what the script thinks is going on. So try this.

    $VerbosePreference = "Continue"
    pruneshadowcopiesDpm2010.ps1
    
    

    I'm waiting for mine to finish but I'm hopfull that it will point us in the right direction.

    Kind Regards,

    John

    • Edited by John Grenfell Wednesday, January 5, 2011 9:32 AM Added line to remove recoverpoints
    Wednesday, January 5, 2011 9:27 AM
  • where is the logfile?

     

    how do you manually delete older RP?

    Wednesday, January 5, 2011 10:09 AM
  • Manually run ... 
    $VerbosePreference = "Continue"
    pruneshadowcopiesDpm2010.ps1
    

    from the DPM Management Shell, it would also be wise the adjust the the height screen buffer size (under properties, layout) as there is a lot of output! I'm just looking at creating anohter version of the script to help be work which RP's it's working on.

    I use the code below to find RP .. just change YOURDPMSERVER, YOURPROTECTEDSERVER.COMPANY.COM and the date "17 December 2010 00:00:00" to the time period your looking for ie 7 days ago.

    Get-ProductionServer YOURDPMSERVER | Where-Object { $_.AreRecoveryPointsPresent -eq $True -and $_.name -eq "YOURPROTECTEDSERVER.COMPANY.COM"} | Get-Datasource | Get-RecoveryPoint | Where-Object {$_.DataLocation -eq "Disk" -and $_.RepresentedPointInTime -lt "17 December 2010 00:00:00"}
    
    Once you think your listing the correct RP's add  the extra code below to remove them, obviuosly you do that at your own risk ;o)
    | Remove-RecoveryPoint -ForceDeletion -confirm:$True
    
    J
    Wednesday, January 5, 2011 10:15 AM
  • Hi to all

    I had the same problem, expired recovery points wouldn't prune, neither on midnight neither If I ran script manually.

    After troubleshooting and googling, couldn't find anything that works, I finally decided to check prune script.

    After running with verbose mode on, I found that script displays servername. Now, we have server with name longer than 15 characters (NETBIOS issue), actually 16 characters.I know this is stupid, but it cannot be changed now.

    So I edited script, and changed the line where scripts queries system for servername (hostname) and changed it manually to my server name shortened to 15 characters.

    Example:

    dpmserverstorage (16 chars)

    changed to

    dpmserverstorag (15 chars) and now manual running of pruneshadowcopiesdpm2010.ps1 deleted all expired recovery points.

     


    Tonza
    Sunday, January 30, 2011 3:51 PM