locked
problems with old exchange server sending email to new RRS feed

  • Question

  • hi there,

    I am in the process of migrating from our exchange 2000 server to exchange 2007 (sp3).

    I have built the exchange 2007 server and created a test mailbox on that server. I can send email from the new (2007) server to a mailbox on the old (2000) server, however when I try to send an email from a mailbox on the old server to the test mailbox (on the new server) it fails with an error message from our ISP. i.e. it appears to be trying to send the message out rather than to the new exchange 2007 server. Looking at the SMTP logs confirms this.

    I can see that there is a routing group connector setup on 2000 but I guess the server isn't using it.

    Can anyone suggest what I can do to troubleshoot this further?

    Cheers for any assistance,

    Al

    Thursday, August 4, 2011 8:45 PM

Answers

  • hi there,

    I am in the process of migrating from our exchange 2000 server to exchange 2007 (sp3).

    I have built the exchange 2007 server and created a test mailbox on that server. I can send email from the new (2007) server to a mailbox on the old (2000) server, however when I try to send an email from a mailbox on the old server to the test mailbox (on the new server) it fails with an error message from our ISP. i.e. it appears to be trying to send the message out rather than to the new exchange 2007 server. Looking at the SMTP logs confirms this.

    I can see that there is a routing group connector setup on 2000 but I guess the server isn't using it.

    Can anyone suggest what I can do to troubleshoot this further?

    Cheers for any assistance,

    Al


    Hi Al,
    What you need to do is to remove the Smarthost setting that you seem to have on your "Default SMTP Virtual Server" on your Exchange 2000 Server (Delivery | Advanced Tab).

    In order to send your external emails thru a Smarthost, create a SMTP Connector on your Exchange 2000 Server or create a Send Connector in Exchange 2010 with a SmartHost setting.


    Martina Miskovic
    • Proposed as answer by Martina_Miskovic Friday, August 5, 2011 7:48 AM
    • Marked as answer by Manu_77 Friday, August 5, 2011 1:53 PM
    Friday, August 5, 2011 7:48 AM

All replies

  • Hello,

    You need to look at the routing group configuration. Please try the following links, detailed explanation of the connectivity between legacy exchange and exchange 2007.

    http://itprosecure.com/blogs/exchange_2007_administration/archive/2009/01/19/exchange-2007-understanding-the-routing-group-connector-between-an-exchange-2003-and-exchange-2007-messaging-environment.aspx

    You can use Get-RoutingGroupConnector to check the configuration of routing group connector.

    -V
    Friday, August 5, 2011 7:16 AM
  • Hi,

    Any update on the issue?
    I would suggest check with your ISP, if they have made any changes on your MX Record.

    As v-beta suggested, check the RGC and make sure you have the proper connector between the server.


    Gulab | MCITP: Exchange 2010-2007 | MCITP: Lync Server 2010 | MCITP: Windows Server 2008 | Skype: Gulab.Mallah | Blog: www.ExchangeRanger.Blogspot.com
    Friday, August 5, 2011 7:32 AM
  • hi there,

    I am in the process of migrating from our exchange 2000 server to exchange 2007 (sp3).

    I have built the exchange 2007 server and created a test mailbox on that server. I can send email from the new (2007) server to a mailbox on the old (2000) server, however when I try to send an email from a mailbox on the old server to the test mailbox (on the new server) it fails with an error message from our ISP. i.e. it appears to be trying to send the message out rather than to the new exchange 2007 server. Looking at the SMTP logs confirms this.

    I can see that there is a routing group connector setup on 2000 but I guess the server isn't using it.

    Can anyone suggest what I can do to troubleshoot this further?

    Cheers for any assistance,

    Al


    Hi Al,
    What you need to do is to remove the Smarthost setting that you seem to have on your "Default SMTP Virtual Server" on your Exchange 2000 Server (Delivery | Advanced Tab).

    In order to send your external emails thru a Smarthost, create a SMTP Connector on your Exchange 2000 Server or create a Send Connector in Exchange 2010 with a SmartHost setting.


    Martina Miskovic
    • Proposed as answer by Martina_Miskovic Friday, August 5, 2011 7:48 AM
    • Marked as answer by Manu_77 Friday, August 5, 2011 1:53 PM
    Friday, August 5, 2011 7:48 AM
  • Thanks for all the responses.

    Martina - there is a smart host specified in the SMTP server so this sounds promising. I will make the changes you recommended and get back to you.

     

    -Al

    Friday, August 5, 2011 8:28 AM
  • Thanks again. Changing the smart host fixed the problem emailing from the 2000 to the 2007 server... but I now have another problem.

    Users on the exchange 2007 server are not receiving external email. At present our firewall passes external email to the exchange 2000 server. For whatever reason these are not then forwarded to the exchange 2007 server. Can you help with this also?

    Once again thanks!

    Al

    Friday, August 5, 2011 10:19 AM
  • Ok, I am glad emailrouting between the servers is now working.
    About your other problem, please create a new tread and mark this one as answered.


    Martina Miskovic
    Friday, August 5, 2011 10:22 AM
  • hi Martina,

    I worked around the problem by changing the firewall to route inbound email via the new server.

    Thanks again.

    Al

    Friday, August 5, 2011 1:53 PM
  • Thanks for the update Al,
    I am glad that all seems to work for you now!!
    Martina Miskovic
    Friday, August 5, 2011 1:56 PM