none
DPM Disk Allocation RRS feed

  • Question

  • hi,

    While create Protection group in DPM we select the seval exchange database for backup , my question is how DPM is  allocate space in LUN how recovery point replica vaolume size takes. how to identify which partiton is belongs to which database if multiple database scenario. we are taken 13 database in single Tape as well as 3 TB LUN.

    need details.

    Thanks in advance.

     

     


    Thanks Siva Aadhi-CIT. MCITP
    Saturday, January 7, 2012 8:25 AM

Answers

  • Hi Siva,

    If replica or recovery point volume for some of your Exchange DB are full, then DPM will try to autogrow it once but if it does fail right after due to volume space then this action will need to be done manually.

    First find out which DBs you are getting this error from. Then you will need to check if the error is for Replica or Recovery Point.

    Once you  have that information you then modify the disk allocation for that (those) Databases and expand the depleted volume.

    This should take care of the problem as long as the volume was expanded large enough to hold the needed data.

    To manually expand a volume, go to DPM 2010 Administrator Console -> Protection tab, highlight the affected DB and on the right hand side clik on Modify Disk Allocation...


    Thanks, Wilson Souza - MSFT This posting is provided "AS IS" with no warranties, and confers no rights
    Sunday, February 5, 2012 8:12 AM

All replies

  • Here is the breakdown

    http://technet.microsoft.com/en-us/library/ff399599.aspx

    For partition location (mountpoint) you can use the PowerShell script below.

    Get-ProtectionGroup (&hostname) | ? { $_.friendlyname -eq '<protection_group_name'}
    $ds = Get-Datasource $pg
    $ds | ft name, protectableobjectloadpath -auto
    


    The Recovery Point path for each DB is the same as replica. Just replace the replica part of the path to Diffarea


    Thanks, Wilson Souza - MSFT This posting is provided "AS IS" with no warranties, and confers no rights
    Saturday, January 7, 2012 9:44 AM
  • Hi Wilson,

    Thanks for your valuable link and it saved a lot of time.

    Here we got strucked with one more problem with the same disk allocation,

    we created a protection group for proctecting exchange databases in DAG mode through  short term backup in disk.

    At the time of creation of protection group we have allocated 3 TB for storage pool and we are using SAN storage. now we came accross to some warning messages like the disk threshold exceeded for some 4 database all the remaining are working fine. 

    We created a new LUN of 3 TB and concatenated the same  to the old SAN disk, and in the management disk tab its displaying like

    Total disk space - 6 TB

    allocated disk space -3 TB (Which is old LUN)

     Unallocated disk space -3 TB(New LUN created)

    It's not allocating the remaining unused space automatically,Is there any small configuration setting we have to do?

    If so,guide me to close this problem.

    Thanks in Advance.

     

     


    Thanks Siva Aadhi-CIT. MCITP
    Saturday, February 4, 2012 2:33 PM
  • Hi Siva,

    If replica or recovery point volume for some of your Exchange DB are full, then DPM will try to autogrow it once but if it does fail right after due to volume space then this action will need to be done manually.

    First find out which DBs you are getting this error from. Then you will need to check if the error is for Replica or Recovery Point.

    Once you  have that information you then modify the disk allocation for that (those) Databases and expand the depleted volume.

    This should take care of the problem as long as the volume was expanded large enough to hold the needed data.

    To manually expand a volume, go to DPM 2010 Administrator Console -> Protection tab, highlight the affected DB and on the right hand side clik on Modify Disk Allocation...


    Thanks, Wilson Souza - MSFT This posting is provided "AS IS" with no warranties, and confers no rights
    Sunday, February 5, 2012 8:12 AM