RDS 2012 Remote App Active Window not coming to the front


  • We are working with RDS 2012 and publishing a remote App.  The App has many windows that open within it and a few windows into their session the active window stops coming to the front.  Since this window opens behind the old window the user thinks the app locks up.  If they click off to the side and then open the Remote App window back the windows does come to the front, but this cannot be a solution.

    We have tried changing the HKCU\Control Panel\Desktop\ForegroundFlashCount to 3

    and the HKCU\Control Panel\Desktop\ForegroundLockTimeout  to 0

    Anybody else encountered this?

    Wednesday, June 19, 2013 9:49 PM

All replies

  • Hi,

    I don't think the changing of the above key will take effect on the specific remoteapp.This issue is caused by 3rd party application.So conferring with your application vendor will be an more efficient way.

    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedbackhere.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, June 20, 2013 9:17 AM
  • Thanks Clarence for you reply.  When I run the app from the 2012 machine directly I have no issues with a window not coming to the fore.  Only when I'm running it via remote app do I experience this.  Do you still think the application vendor can assist with this?
    Monday, July 08, 2013 8:39 PM
  • Having the exact same issue described above. Contacted the 3rd party vendor and this does seem to be a Remote Desktop Services issue. I have also ran the app natively off the server with no issues. The issue only appears when running a Remote App. Our Remote App Server is 2012, clients are all Win7.
    Tuesday, December 10, 2013 7:28 PM
  • These sorts of issues usually are caused by applications managing windows in ways RemoteApp doesn't know how to deal with properly (in other words, it's probably a RemoteApp bug). There are sometimes hotfixes to correct cases such as this, so it would pay to keep machines patched and to use the newest version of the RDP client available, but I can't guarantee it'll fix the particular issue you're observing. That said, there was a similar bug fixed in RDP 8.1, so once that's re-released for Windows 7 it would pay to give it a try.

    Also, is the application you're having trouble with publicly available? If so, what is it?

    Friday, December 13, 2013 10:59 PM
  • I have the same issue, and my application is Dynamics AX 2012, a Microsoft product.  This is a giant pain in the butt and I'd love to hear what anyone has done to figure out how to stop it.  The clients constantly think their session is locked up and force close it.
    Tuesday, August 25, 2015 12:21 PM
  • did you come right with this issue yet, same issue on dynamics 2012.
    Wednesday, November 11, 2015 2:28 PM
  • We are having the same problem with Microsoft AX 2012 on fully updated Winddows 2012R2 RDS Servers and Windows 7 clients. I hope a fix will come soon...

    Jesper M. Christensen - Blog:

    • Proposed as answer by renegadeZA Tuesday, December 01, 2015 3:00 PM
    • Unproposed as answer by renegadeZA Tuesday, December 01, 2015 3:00 PM
    Tuesday, December 01, 2015 1:33 PM
  • Are there any progress in this regard? We're experiencing the same issues with Ax 2009 and Ms Office...
    • Edited by Gilrim Tuesday, September 13, 2016 1:23 PM
    Tuesday, September 13, 2016 1:12 PM
  • Hi All,

    I am experiencing the same issue,   we have it on RDS and Citrix (we are looking to replace citrix) we dont get the issue on citrix. 

    Also don't have the issue when RDP'd to the server, Or if the application is installed locally on PC.  All servers are upto date and desktop pc is upto date and range from win 7 - win 10.Any helkp would be appreciated as they are talkijng about canclling the project.  

    Monday, September 26, 2016 2:09 PM
  • I found your thread, and noticed it remained unanswered, I believe I found the fix for this.

    There is a hotfix available for Windows Server 2008-2012R2 that appears to address this.

    • Edited by Ryan Ybarra Wednesday, May 17, 2017 3:38 PM
    Wednesday, May 17, 2017 3:29 PM