locked
Shared 2010 Calendar Color Categories not appearing in Outlook 2007 RRS feed

  • Question

  • I have a SBS 2003 (exchange 2007) environment wih a mixed Outlook use between 2007 and 2010. One 2010 Outlook client has shared a calendar to several 2007 users and they swear that when they received the email invite to view this shared 2010 calendar, the color categories list in their Outlook changed to match the shared calendar without any interaction from the users. A new hire was given the same invite to view this shared calendar, she accepted, the calendar is visible however, the color categories are not appearing.

    I've tried setting an appointment in the 2010 Outlook shared calendar with all the color categories in the list, then going to the client's 2007 Outlook and updating the color categories in her mailbox but nothing changes.

    I've read about 20-30 blogs, tech form and MS tech answers on this subject and I get conflicting solutions. One states that you can't transfer the master color category list, you have to change it on each Outlook client while others state the use of an appointment and upgrading the categories from the properties in the client's mailbox (which didn't work) or using a third party add-in to manage a "Master Color Category list" (which costs money). I would like a straight answer to my question, which is, "why can't the Outlook 2007 client see the color categories in the 2010 shared calendar?" and "How to I fix this?".

    This questions has been asked in so many different ways that I'm not sure if someone will help me without having to call MS support and pay for it. This has got to have a simple solution that I don't need to pay for it, yes?

    Anyone, please help me.....

    Thursday, April 5, 2012 8:54 PM

Answers

  • Hey mate i had the same issue and was dumb founded till i came up with a solution that worked for me, and possibly someone out there looking for the same solution. Half the info i looked up was all bullshit and took me months to come up with a fix as im busy with other priorities.

    still busy so ill be quick...and not gonna get too technical just gonna lay it all out in steps

    1. create a mail account in exchange eg. scheduling@mail.com.au

    2. log into the account through outlook and share the calendars you set up.

    3. go to the exchange management console on the 'server ' right click the created scheduling@mail.com.au mailbox > manage full access permissions> and start adding the users who need access. (only thing that worked for me)

    4. close and reopen outlook on the users computer and then you should see the colour co-ordinated catergories that you assigned for scheduling that they can all access and book appointments in a easy colour co-ordinated layout.

    if it dosent show up try - *on the users computer* start >run>cmd>gpupdate/force
    this will force the update on some computer that didnt show up with the effect. only had this problem with 1 user and this fixed it :)



    hopefully this idea helps you! as it did me cause no geek out there never gave me this easy fix option, instead right properties and blah blah blah technical crap that dosent work, wankers!

    thanks :) 

    P.S this worked between 2010 and 2007 microsoft outlook


    • Edited by Mazza86 Thursday, July 19, 2012 3:45 AM
    • Marked as answer by Tony Chen CHN Tuesday, July 24, 2012 8:12 AM
    Thursday, July 19, 2012 3:35 AM

All replies

  • Is the color categories in shared calendar visible in OWA?

    In theory, Outlook 2007/2010 would sync the Master Category List (MCL) on the client each other. I have confirmed it on my test environment just now (Exchange 2007, Outlook 2010/2007) – Outlook 2010 Client share and invite an account in Outlook 2007 to view his calendar, all of the customized color category is visible.

    However, if somebody changes the permission of shared calendar or sets the delegate access, the sync process would stop working unexpected. In this time, I recommend that you check the calendar permission, cancel any delegate setting for the user and restart Outlook to see if the color categories would be shared again.

    In addition, please also try create a new outlook profile follow the article to test: http://support.microsoft.com/kb/829918

    Hope my experience may help you.

    Tony Chen

    TechNet Community Support

    Monday, April 9, 2012 6:48 AM
  • Tony,

    Thanks for the response. I creating a new outlook profile for the client (renamed the ost file and followed kb829918 as suggested) and that did not work. I checked the properties of the shared calendar and here are the permissions: Editor. The client can create and read with folders visible. Under edit items, the client can edit own and all. Under delete items the client can delete all.

    I am going to check tomorrow with the original owner of the shared calendar to see if he changed any permissions after he sent her the invitation. I am hoping from the permissions listed above that there is something wrong that I can correct and that will display the master color catagory list. I will update this tomorrow.

    Thanks.

    Wednesday, April 11, 2012 8:48 PM
  • Any update?
    Just wanted to say hi and check if there is anything that I can do for you on this thread.

    Tony Chen

    TechNet Community Support

    Friday, April 20, 2012 2:57 AM
  • I checked shared calendar permissions and they are set the same as the other users and the user having the issue does not have any delegates in her Outlook. The new mail profile didn't resolve the issue (as I stated before). I did check the the calendar originator and he hasn't changed any settings on his calendars.

    One question I have is there a limit to how many people you can share a calendar with?

    Friday, April 20, 2012 1:34 PM
  • Hey mate i had the same issue and was dumb founded till i came up with a solution that worked for me, and possibly someone out there looking for the same solution. Half the info i looked up was all bullshit and took me months to come up with a fix as im busy with other priorities.

    still busy so ill be quick...and not gonna get too technical just gonna lay it all out in steps

    1. create a mail account in exchange eg. scheduling@mail.com.au

    2. log into the account through outlook and share the calendars you set up.

    3. go to the exchange management console on the 'server ' right click the created scheduling@mail.com.au mailbox > manage full access permissions> and start adding the users who need access. (only thing that worked for me)

    4. close and reopen outlook on the users computer and then you should see the colour co-ordinated catergories that you assigned for scheduling that they can all access and book appointments in a easy colour co-ordinated layout.

    if it dosent show up try - *on the users computer* start >run>cmd>gpupdate/force
    this will force the update on some computer that didnt show up with the effect. only had this problem with 1 user and this fixed it :)



    hopefully this idea helps you! as it did me cause no geek out there never gave me this easy fix option, instead right properties and blah blah blah technical crap that dosent work, wankers!

    thanks :) 

    P.S this worked between 2010 and 2007 microsoft outlook


    • Edited by Mazza86 Thursday, July 19, 2012 3:45 AM
    • Marked as answer by Tony Chen CHN Tuesday, July 24, 2012 8:12 AM
    Thursday, July 19, 2012 3:35 AM
  • Although giving full rights to the calendar does work but I wouldn't recommend it.   I had a simliar issue as well and what I found out is that users had to have at least "Reviewer" rights to the default calendar within the users account.  The reason why I say default calendar was because I had sub-calendars within the same account that were shared and needed access to the custom categories.  Once I changed it to reviewer, the categories came across no problem.

    Details on my problem is here if interested... 

     
    • Proposed as answer by vidwhal Tuesday, January 5, 2016 2:51 AM
    Thursday, August 9, 2012 7:52 PM
  • The master category list holds the colors, the list is stored in the default calendar of the mailbox. So, no matter which folder of that mailbox you share, others also need permissions on your default calendar in order to see your colors.

    Michael Bauer - MVP Outlook
    Category Manager - Easily share your categories

    Sunday, March 31, 2013 8:50 PM
  • Thanks for all your replies and I'll keep them for furure reference.

    I resolved this by re-imaging the laptop. Not sure what was the problem but maybe the original Office 2007 install got corrupted somehow and was causing the problem? With a fresh image, the problem disappeared.

    Since this was resolved, I have had two other image installs that had office 2007 corruption. So, I re-did the image and deleted the old one. I haven't had another image installed that had any issues with office since I remade the image.

    Thanks again for all your help.

    Monday, April 1, 2013 2:50 PM
  • I just ran into this same issue. What we found is if you go under file > account settings > account settings > change > and uncheck the "Use Cached Exchange Mode" it solves the problem!
    Tuesday, January 21, 2014 1:31 AM
  • THIS! is what has solved the prob for me. Thanks!
    Tuesday, January 5, 2016 2:51 AM