none
Auto Horizontal scroll in Explorer list view: has this ever been addressed (and why not)? RRS feed

  • Question

  • Original post in 2009:

    https://social.technet.microsoft.com/Forums/windows/en-US/94f1ad37-9110-4273-a473-ed02e36af386/is-there-a-way-to-disable-explorer-automatic-row-scrolling-in-list-view?forum=w7itproui

    Example: You have a folder open with pictures in it. The Explorer window for said window is in List view mode, and at least 2 rows are visible. The file you want to open is in the 2nd row. When you click the file, it automatically scrolls the list so that the file you selected is in the left-most row, rendering any double-click on the 2nd or subsequent rows ineffective. Instead of opening the file, it selects the file, immediately scrolls it's row back, selects the new file that has scrolled into that row in the same position and scrolls it back as well. 
    Is it possible to institute a small delay on the automatic scrolling to allow for double-clicking or disable the behavior entirely?

    Sorry if this has been covered before, I couldn't find any relevant info through searching.

    There is a lengthy discussion, including feedback from Robinson Zhang that the discussion would be forwarded to development. But no changes. 

    The auto scroll without a delay is terrible--it makes dragging/dropping into subfolders a nightmare, because the window is always scrolling to the left as soon as the icon enters the window. An extremely poor feature which desperately needs to be addressed.

    Wednesday, May 24, 2017 4:59 PM

All replies

  • Hi,

    I am not sure the exact behavior. A screenshot will be very useful to understand the exact symptom.

    If you mean when you click one folder, the scroll bar will adjust the appearance location to entirely show the folder. This is an expect behavior which is by design. As I know, there is not a measure to custom the scroll bar speed or disable the behavior.
    If you want to dragging/dropping into subfolders more conveniently, we could use the “Ctrl+X” as a workaround. If you want to choose multiple files, we could keep pressing “Ctrl”.

    Best regards,
    Joy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, May 25, 2017 9:50 AM
    Moderator