locked
Windows 8 and IE10 not accepting Proxy Settings via Group Policy RRS feed

  • Question

  • We have recently introduced a couple of Windows 8 computers in our network, and we are having issues applying the Internet Explorer Proxy Server settings.

    We use a Microsoft TMG 2010 server as our proxy server for accessing the internet.  We have been using a GPO with the following settings to automatically configure our Windows 7 computers running IE9 with the appropriate Proxy settings:

    User Configuration\Policies\Windows Settings\Internet Explorer Maintenance\Connection/Proxy Settings

    • “Enable Proxy Settings” : Checked
    • “Address of proxy” : server.domain.local
    • “Port” : 8080
    • “Use the same proxy server for all addresses” : Checked
    • “Exceptions” : Here we have a list of several internal or partner sites that should not be proxied.

    This GPO has worked beautifully for our Windows XP and Windows 7 users with IE 7, 8 and 9.  Now with Windows 8 and IE10, this no longer works.  I’ve therefore added a Windows Server 2012 Domain Controller to the network, and using GPMC on that new DC, I created a new GPO with the following settings:

    User Configuration\Preferences\Control Panel Settings\Internet Settings\Internet Explorer 10

    Now, seeing as these are preferences, it’s a little different.  But, I’ve “checked off” the option “Use a proxy server for your LAN” as well as “Bypass proxy server for local addresses”.  Then I click on “Advanced” and setup all my proxy settings the way I would like them, including the proxy server name, port and exceptions list.

    When this new group policy gets applied to my Windows 8 PC, the only setting that gets applied is the “Use a proxy server for your LAN”.  It does not configure the name or port of the proxy server nor does it configure the exceptions list.  If I go back to the GPMC, and edit the new GPO, the settings are all there.  However, if I just view the settings from the main GPMC screen (without opening the GPO itself),  I don’t see all of those settings (again, only the one “Use a proxy server…”)

    What am I missing???

    Thursday, December 20, 2012 6:45 PM

Answers

All replies

  • Hello,

    There is no Internet Explorer Maintenance CSE in Windows 8 anymore.

    There is a list of replacements from Microsoft:

    http://technet.microsoft.com/en-us/library/hh846772.aspx

    Anyway, you can do the most things with GPP.

    BTW:

    If you use GPPs you need to be aware of the F5-F8 keys:

    http://blogs.technet.com/b/grouppolicy/archive/2008/10/13/red-green-gp-preferences-doesn-t-work-even-though-the-policy-applied-and-after-gpupdate-force.aspx


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!


    • Edited by Matthias Wolf Thursday, December 20, 2012 6:49 PM
    • Marked as answer by Marc Proulx Thursday, December 20, 2012 7:37 PM
    Thursday, December 20, 2012 6:47 PM
  • Thank you Matthias for that link explaining the F5-F8 keys.  That is exactly what my issue was!!  Thanks again.
    Thursday, December 20, 2012 7:37 PM
  • I am in a 2008 Domain to which I have joined my first Windows 8 computer. Under one of the user OUs I've created a TEST Windows8 OU and dropped my user account in there. Linked and Configured User Config GPO using RSAT on my Windows 8 machine and set IE 10 settings via Preferences; Have set it to Enforced.

    I have understood the sugnificance of the function keys and green vs dotted-red lines. Some of my Internet Settings now apply (ie: Home Page) The proxy settings however do not get applied.

    The Automatically detect settings box is Unchecked and highlighted green. In the LAN Settings I have "Use a proxy server ..." and " Bypass proxy" Checked and underlined green. In the Advanced I have all 4 protocols filled in as well as Exceptions separated by semicolons.

    Monday, April 1, 2013 10:06 PM
  • SOLOVED! I was missing a few settings. All my IE10 policies now apply. Advise to anyone having similar issues: triple check the green and dotted-red lines.
    Tuesday, April 2, 2013 3:25 PM
  • Hello !!!

    Can you help me with this issue? My GPO are working with IE 9 on Windows 7, i did the update to IE10 and the GPO are not working, i was checking in other comnputers and the issues is with the computer with IE10 on Windows 7, I dont have any windows 8 or windows 2012

    Any idea? in the GPO the "internet explorer maintenance polycy procession " is Enabled and also is ckeck "Allow processing across a slow network connection" and "Process even if the GP objects have not changed"

    The GPO is for the proxy settings and exceptions

    Thanks for your help


    Tuesday, April 2, 2013 6:55 PM
  • Can you help me with this issue? My GPO are working with IE 9 on Windows 7, i did the update to IE10 and the GPO are not working

    If you have IE 10 installed, IEM won't work anymore.


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!

    Tuesday, April 2, 2013 8:47 PM
  • Thank you!! do i have other option?

    I was reading about IEAK 10 and i did a test, but i have to install in all the computers and i have almost 5000 computers, I am doing changes in the IE frecuently each month, so the GPO is the Best option for me.

    Tuesday, April 2, 2013 10:41 PM
  • so the GPO is the Best option for me.

    You can do almost every IE configuration with Group Policy Preferences Internet Settings.

    Otherwise you need to get the registry keys and use Group Policy Preferences Registry.


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!

    Wednesday, April 3, 2013 9:15 AM
  • Marc, I am experiencing the near exact situation at a client of mine.   I've been messing with the Preferences all day, but I cannot seem to get the IE Proxy fields to apply, though other settings from the same IE10 Preference section do.  

    This is a longshot, but I would love to see a screenshot of your configuration for this tab:

    Thursday, May 16, 2013 8:55 PM
  • Hi Sven;

    I haven't attached the print screen as it looks exactly like yours.  One thing that I have noticed, is that if you try to configure other IE Preferences in the same policy, the PROXY settings don't seem to work.  I would recommend that you create a separate "Internet Settings" for the proxy server configurations.

    Hope this helps.

    Thursday, May 16, 2013 9:16 PM
  • I was already using a segregated policy for just IE settings, but I suppose I could try to segregate it even more.   I'll post back and let you know if that works.  

    I spent all day yesterday going through the existing policies, and Denying any other policy that might also try to configure IE settings... there were several.  But alas, still no Proxy though other preferences do apply.  

    For others in this thread, I am also getting the 'Internet Explorer branding failed' warning when examining a Group Policy Results wizard for my test Windows 8 VM.   I don't know if this is the direct reason the Preferences are failing, or just something else that doesn't work yet.  

    Any other comments would be appreciated!



    Friday, May 17, 2013 11:43 AM
  • Ok, after a few hours of frustration and testing, I have got this working.   Here's what I did:

    I denied all other policies that tried to set any IE settings via GPO to my test Windows 8 VM.   I am still getting an error in the Group Policy Logging that the "Internet Explorer branding failed - the specified procedure cannot be found" but that is not related to this issue.  

    I created a new policy for IE10 Preferences using my Windows 2012 DC.  I discovered that it's very important that you set the Proxy settings in this order:  

    In the LAN Settings on the Connections Tab, check the Proxy server field, and then add your proxy server.   You can't seem to enter an address in this field unless it's a new policy.  Do this first!   Then you can modify add'l Preferences as needed, ensuring the fields you want enforced are underlined in green.

    In the instance where you can't enter an address in the Proxy server field, don't waste your time thinking that the fields on the Advanced option will take effect for the GPO... because they won't.  Start over with a new Preference policy.  

    • Proposed as answer by hukel Monday, September 16, 2013 6:14 PM
    Monday, May 20, 2013 3:26 PM

  • In the instance where you can't enter an address in the Proxy server field, don't waste your time thinking that the fields on the Advanced option will take effect for the GPO... because they won't.  Start over with a new Preference policy.  

    Sven - are you suggesting (and I've got a couple of hours of frustration on this myself) that you simply CANNOT change the fields that appear after clicking the Advanced button?  i.e.  the "Exceptions" list?

    That is what I'm beginning to believe.

    If this is true...is it possible to create another GPO with ONLY the Exceptions that will hopefully, not override the proxy value?

    Thanks!

    Monday, June 10, 2013 9:16 PM
  • Correct.  I found that once your Preference is in the 'state' where you can't enter an address in the Proxy field, any of the Advanced fields will not take effect.  You'll need to start over!   Sorry for the late reply.
    Wednesday, June 12, 2013 5:35 PM
  • Am 10.06.2013 23:16, schrieb LewTech:
    > Sven - are you suggesting (and I've got a couple of hours of
    > frustration on this myself) that you simply CANNOT change the fields
    > that appear after clicking the *Advanced *button?
     
    Yes. It is a known bug in the UI. Start over again ;-)
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Wednesday, June 12, 2013 9:51 PM
  • HI Guys,

    THERE IS A BUG IN SERVER 2012 GP for IE10 and WIN7

    See http://community.spiceworks.com/topic/342202-ie-10-group-policy-help-needed-i-think-i-ve-found-a-bug

    and don't touch that advanced button or you'll regret it!!

    Monday, June 17, 2013 2:48 PM
  • Am 10.06.2013 23:16, schrieb LewTech:
    > Sven - are you suggesting (and I've got a couple of hours of
    > frustration on this myself) that you simply CANNOT change the fields
    > that appear after clicking the *Advanced *button?
     
    Yes. It is a known bug in the UI. Start over again ;-)
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!

    At first I thought that by "start-over" we had to create a completely new GPO, however, and maybe this will save someone else some time...it's only a matter of deleting that particular Internet Explorer Preference object...then adding a new one.

    Just to be clear. At the present time there is no way to add exceptions in the "Do not use proxy server for...." list?  I may still experiment, but if I configure one Preference Object with the proxy ONLY, then add another preference object with the list of Exceptions, is there a chance that they'll successfully merge?

    Thanks, PW

    Thursday, June 27, 2013 2:43 PM
  • Did you ever find out if the proxy exceptions successfully merge?
    Monday, September 9, 2013 3:03 PM
  • I have discovered that exceptions ARE applying just fine in my environment when the IE box is greyed out and that appears to be acceptable functionality per Microsoft support. It has been some time since I have talked with MS Support and it feels like their support has gone downhill. I had to tell them that IE10 could be managed with Windows 8 and still apply the policy to IE10 on a 2008 R2 client. They suggested IEAK only and then came back and said gpp preferences was ok.

    Another issue I found was with the way "the use the same proxy server for all protocol" works.

    Asish Sinha has checked with the Escalation Engineers and we are aware of this behavior and the registry will be created for each protocol in IE 10 when the "use the same proxy server for all protocol" is checked when done through Group Policy Preference file, but there are no functionality loss with this change. It is just that the registry will look different in IE10 than that of IE9 but the functionality will be the same. There is no KB article for that but an internal document which talks about this behavior in IE 10.

    You can view the same in registry in the below location:

    HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings ->Proxy server

    You will see separate but same proxy settings for HTTP, Secure and FTP in IE10.

    Socks is a legacy protocol that is still available, currently there are no applications that use it and it should not have any impact on the functionality of other protocols.

    Monday, September 16, 2013 8:50 PM
  • how?   I´can´t even make the option "IE10 "  appear in  Internet Setting under preferences

    I just get options for IE 5 & 6 , 7 & 8

    I´m working with same installation,   Windows 2008 r2   with IE 10 installed

    How can I create a set of policies that actually applies to IE 10 (windows 7 clients)????

     
    Tuesday, October 1, 2013 2:54 PM
  • Do some search... Basically, edit the XML and change the hidden iexplore.exe version filter to "99.0.0.0".

    Martin

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))

    Restore the forum design - my user defined Cascading Style Sheet!

    Wednesday, October 2, 2013 9:38 AM
  • Work arround:

    1. On the tab Connections, click LAN settings.
    2. Check to enable the Use a proxy server... option.
    3. Click"Advanced...
    4. Fill in Exceptions and click OK.
    5. Press F5.
    6. Fill in Address: and Port: en press F5.
    7. Check Bypass proxy... and click OK.

    When you try to change the exceptions, you have to remake a new Internet Explorer 10 item under Control Panel Settings/Internet Settings.

    Greetings


    May the source be with you!
    Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you.

    • Proposed as answer by ccatlett1984_ Thursday, December 19, 2013 6:52 PM
    Friday, December 6, 2013 8:41 AM
  • What about, for example:

    if a laptop gets an IP that is outside their office network, there should be no proxy, if they got the segment inside their office, then the appropriate proxy applies.

    Any suggestions?

    Thanks,

    PJ 

    Wednesday, December 11, 2013 5:55 AM
  • What about, for example:

    if a laptop gets an IP that is outside their office network, there should be no proxy, if they got the segment inside their office, then the appropriate proxy applies.

    Any suggestions?

    Thanks,

    PJ 

    PJ,

    for that purpose you would use a proxy pac file inside your network. if IE can't find a proxy outside your network it goes DIRECT by default. it's really quite simple - configure dhcp or dns to point clients to your proxy server, which based on your preference provides proxy.pac or wpad.dat containing the required info. it would look something like this:

    proxy.pac

    . function FindProxyForURL(url, host)

    {

    if (isInNet(myIpAddress(), "10.10.10.0", "255.255.255.0")

    return "PROXY [Proxy Address]:[Port]";

    else

    return "DIRECT";

    }

    then configure IE to either use auto config or auto-script. there are heaps of templates and step-by-step how-to's out there, TechNet should always be your first address.

    Friday, January 10, 2014 3:52 PM
  • I face the same issue, it works first time and when I edit or update some changes, the proxy server disappears.

    Create a new with proxy server and exception, click apply

    Works fine for me.

    Thanks

    Alagar

    Monday, January 20, 2014 8:22 AM
  • We have a mix of IE8 up to IE11 and has added 2012 DC's.

    I have a GP that set up the proxy using the old IE Maintenance.

    What I want to know is what IEAK should I download and to use that will work on IE8 9 10 and 11.


    • Edited by jwanner Wednesday, January 29, 2014 3:07 PM
    Wednesday, January 29, 2014 3:06 PM
  • Thank You!, Exactly what I needed. This resolved my issue.

    Wednesday, February 5, 2014 7:00 PM
  • I found how to make this work

    Create your GPO for IE 10.

    GO to the connections settings tab, click advanced, type in your proxy address and port number only in the HTTP section.  Add any exceptions to the bottom in the box (This must be done before you exit this portion).

    Click okay, you will see in the proxy settings are it will list the proxy address as HTTP=IP Address of your porxy.

    Simply remocve the HTTP= portion and leave only the IP address.

    Click the check box "Do not use Proxy for internel host", click okay. click apply.

    Go back under the connection and advanced (do not make any changes or click Okay) and you will see the settings have taken and remain.

    I tested this on my workstations and it works fine now but you have to follow the above procedure exactly (if fill in more than one are aunder advanced for either HTTP, FTP, Secure,Socks it will break, simply remove all by one IP address and you can edit it again)

    Hope this helps everyone.

    • Proposed as answer by jcjunior2 Tuesday, April 1, 2014 9:30 PM
    Tuesday, April 1, 2014 9:28 PM
  • I found how to make this work

    Create your GPO for IE 10.

    GO to the connections settings tab, click advanced, type in your proxy address and port number only in the HTTP section.  Add any exceptions to the bottom in the box (This must be done before you exit this portion).

    Click okay, you will see in the proxy settings are it will list the proxy address as HTTP=IP Address of your porxy.

    Simply remocve the HTTP= portion and leave only the IP address.

    Click the check box "Do not use Proxy for internel host", click okay. click apply.

    Go back under the connection and advanced (do not make any changes or click Okay) and you will see the settings have taken and remain.

    I tested this on my workstations and it works fine now but you have to follow the above procedure exactly (if fill in more than one are aunder advanced for either HTTP, FTP, Secure,Socks it will break, simply remove all by one IP address and you can edit it again)

    Hope this helps everyone.

    Hi jcjunior2,

    Do you have a link for GPO IE 10? How to install it GPO IE 10?

    I have a same issue. I am using windows server 2008 32 bit.

    Thanks

    Friday, July 25, 2014 9:25 AM
  • Hi All, - (Revised Answer by myself)<o:p></o:p>

    I banged my head against the keyboard on this one for some time trying to get this group policy to apply.  I did every thing that was suggested, learning about the F6 and F7 keys to Green underline and Red underline the options required and not required.  I even gave in and used the registry settings and it still did not work.  It turned out that I had 2 issues.  The first one is obvious and the second not so obvious, this is how it is setup:

    I have a 2012 R2 Standard DC with Windows 8.1 clients/workstations and IE 11.  As you are aware you must make sure that the following are underlined in green:

    Automatically detect settings - (but not ticked)<o:p></o:p>

    Use proxy server for your LAN<o:p></o:p>

    Bypass Proxy for local address<o:p></o:p>

    Next I made sure that the following had red dotted lines:

    Address<o:p></o:p>

    This still didn't work, so I went through my 'Do Not use proxy servers for addresses beginning with' removed all of these and then re-added one by one until the problem materialized.  The first issue was when using wildcards I had added an entry with the following:

    http://domain.subdomain.com/*

    Then caused my proxy fields not to be applied, I re-added this just with:<o:p></o:p>

    http://domain.subdomain.com/

    <o:p>This next one is IMPORTANT.</o:p>

    I had these entries in a Word document of which I had copied and pasted from the entry box for 'Do Not use proxy servers for addresses beginning with'.  As shown in the screen shot above provided by SVEN_BURGER I had very similar entries:

    http://domain.subdomain.com/;10.*.*.*;172.27.*.*;http://172.27.*.*

    Each time I copied and pasted the line (+ more) above the proxy field on the Windows 8.1 client be blank after using 'gpupdate /force' I then noticed that in my Word document the whole string was being seen as 1 URL due to the http part at the beginning, so I changed my entry to look like this:

    10.*.*.*;172.27.*.*;http://172.27.*.*;http://domain.subdomain.com/

    I again noticed that this section:

    http://172.27.*.*;http://domain.subdomain.com/

    Was being seen as one URL in my Word document.  To resolve this I had to add the URL's individually and apply and OK these before going back in and making the next entry.  So I ended up adding them all individually after separating the URL's in my Word document.

    I hope this helps.

    Tuesday, March 17, 2015 8:21 AM
  • Hi

    I found this thread yesterday as I have been tearing my hair out simply getting the proxy setting to apply to IE11 machines.

    We have mixture of IE9 and IE11 machines. The IE machines are configured using the IE maintenance GP and works perfect. I realised that we could not control later than IE9 with this policy so created a Windows 8.1 machine and installed the remote server admin tools.

    So I now can create a policy for IE 10 and above using the GPP and all I want to do is tick the box to use a proxy server, specify it and bypass for local address, I do not even click into advanced. The boxes are underlined green but the setting will just not appear on the clients.

    I read on another site with someone having the same issue and basically said it flat out will not work and had to use a registry preference but what I read on this it appears some people have got it working.

    I have tried all the order combinations that people have suggested but no matter what it will not work.

    Any other ideas?

    Many thanks

    Saturday, June 6, 2015 8:45 AM
  • > getting the proxy setting to apply to IE11 machines.
     
    Edit the xml.
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Monday, June 8, 2015 10:21 AM
  • Thanks for the response, the XML looks fine, all the setting are in there.

    I have however found out what the bigger issue is.

    It appears that nothing we configure in Control Panel Settings comes down onto the clients. If I run a gpresult I can see that settings we have configured in the Windows Settings section apply but nothing within the Control Panel settings section hence why nothing we configured in Internet Settings works.

    Is there any obvious issue why these particular settings would not be applying onto the clients?

    Tuesday, June 9, 2015 12:08 PM
  • > Thanks for the response, the XML looks fine, all the setting are in there.
     
    Enabled or disabled? And what's in the hidden filterfile for iexplore.exe?
     
    > Is there any obvious issue why these particular settings would not be
    > applying onto the clients?
     
    You know about those red and green lines?
     
    To simplify things, you might post the XML :)
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Tuesday, June 9, 2015 1:29 PM
  • any luck with this GPP?
    Thursday, August 27, 2015 8:39 PM