none
How to turn off hyperlink formatting in Excel 2016 RRS feed

  • Question

  • I often have a need to manage Excel 2016 spreadsheets that contain hundreds of email addresses and other hyperlinks. However, I do not want the formatting of those to change when I paste them into the spreadsheet and I do not want them to be clickable links. I'm finding that with Excel 2016 not only does it always make them clickable hyperlinks, often times it also changes the font, the color and the point size as well.

    Going to Preferences-->AutoCorrect and unchecking "Replace internet and network paths with hyperlinks" seems like it should fix the problem but it does not. I've gone through the other preferences but can't seem to find what I'm looking for.

    What do I have to set to get Excel to stop formatting email address and other hyperlinks? I want them to paste into the spreadsheet as plain text matching the default font and font size that is set for the spreadsheet I'm working on.

    Thursday, February 8, 2018 7:40 PM

All replies

  • Hi,

    What is the build number of your Office?
    Have you encountered this issue for a long time? Or does it happens recently?
    Have you installed any Office updates recently?

    Recently, we have received reports about different issues in version 16.9. 

    • If this is the version you are using, please try to reverse it back to the version before 16.0. Please refer to this support article: https://support.office.com/en-us/article/how-to-go-back-to-office-2016-for-mac-15-xx-versions-from-16-xx-e88ed6c8-6fb4-40a1-9540-529000d3d20f?omkt=en-US&ui=en-US&rs=en-US&ad=US

    • If this is not the version you are using, then, does this issue happens to Word or PowerPoint? Please provide a screenshot about this issue to help analyze it.

    Please post back your results.

    Best Regards,

    Aaron Zhang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    • Edited by Aaron .Zhang Monday, February 12, 2018 1:25 AM
    • Proposed as answer by Aaron .Zhang Tuesday, February 13, 2018 1:50 AM
    Friday, February 9, 2018 2:13 PM
  • I'm running version 16.9 so that may be part of the issue. The strange thing is now I'm having a difficult time replicating it, it seems to sometimes do what I want and sometimes not. When it's not doing what I want I can use the paste special option which works but is a few more keystrokes. I'll wait for the next update and see if things improve. Thank you.
    Tuesday, February 13, 2018 4:04 PM
  • Hi,

    I understand your depression. Good news is: Microsoft has released a newer version of Office for Mac, on 2/13/2018, Version number: 16.10.0(18021001). You can give it a try. Reference: Latest updates for Mac

    Any updates on your side, feel free to let us know.

    Best Regards,

    Aaron Zhang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, February 14, 2018 1:12 PM
  • Hi,

    It has been a while since your last reply, any update on your side, please feel free to let us know.

    Best Regards,

    Aaron Zhang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, February 16, 2018 1:26 AM