SharePoint Site Displays Old Cached Data, Not Changes RRS feed

  • Question

  • I have an issue where my WSS 3.0 site is displaying "old" content well after changes have been made, even over one week.  For example, I change the picture that is displayed on a page, even deleting the old image file from the server, yet workstations on my network are still seeing the old image and not the new image.  I found some success in forcing a reload (CTRL + F5), but that does not work every time, and even then it is not an effective solution.

    It is not just images that have this issue but regular content as well.  This is a major issue because people are not seeing the important changes to calendars, etc.

    Is there a setting in WSS 3.0 Central Administration that will force it so that nothing is cached?
    • Edited by JackRS Wednesday, October 29, 2008 6:32 PM
    Wednesday, October 29, 2008 6:31 PM

All replies

  • Is caching enabled on your server? Disabling it may solve your problem!

    Wednesday, October 29, 2008 9:08 PM
  • I don't see the settings described in that TechNet document, but the explanation might be that it appears to be for MOSS 2007 whereas I am running Windows SharePoint Services 3.0?
    Thursday, October 30, 2008 1:41 PM
  • Are you caching through IIS? When you open your site in IIS, go to the "HTTP Headers" tab and see if there is a line that starts with "cache-control" in the Custom HTTP Headers textbox.
    Thursday, October 30, 2008 4:06 PM
  • The line was not there, but I have added it.  I also checked the box to "Enable content expiration" and set it to "Expire immediately", but I am not sure that it made any difference as I tested it once again from a different computer and I am still seeing the old image that I have overwritten with a new image.

    Additionally, I assumed that the "Custom HTTP Headers" would insert the "Cache-Control" data into all of my pages in my IIS site, but viewing the source, I do not see the phrase "Cache-Control" anywhere.  Should I be seeing it since I have added it?
    Thursday, October 30, 2008 6:44 PM