locked
3rd party software installation problem associated with vbscript.dll RRS feed

  • Question

  •  I have a new Dell precision laptop running VISTA Ultimate. I am attempting installing a 3rd party VISTA certified 32 bit application, but am having difficulties.  The software vendor suspects that the VBScript for the install is being problematic becasue the Vbscript.dll is unregistered.  The vendor recommended bypassing the script by doing a silent install from the command line, but this didn't work either.  The vendor then suggested registering the vbscript.dll.  When attempting to do this I recieve the following error code.

    "The module C:\windows\system32\vbscript.dll was loaded but the call to DllRegisterServer failed with 0x80004005.  For more information about this problem search online using the error code as a search term. "

     

    I did this but the code returns problems on many topics and I saw few on application istallation.  Can anyone explain what this error with the DllRegisterServer is and how this problem be resolved.

     

    I tried all of the above logged on as an administrator.    

     

     

    Saturday, April 21, 2007 3:40 PM

All replies


  • The problem was that, for some reason, the 32-bit version of VBScript.dll wasn’t registered on your machine. I don’t know if that’s by design (a security feature) or a bug in this beta build of Vista. The solution:

    Start Menu -> All Programs -> Accessories -> Right Click on Command Prompt -> Run As Administrator.
    Type “cd C:\Windows\SysWOW64″
    Type regsvr32 vbscript.dll
    If you don’t do Run as Administrator, the regsvr32 will fail. Also, be careful to run the command in SysWOW64, not System32! System32 on a 64-bit system actually contains the 64-bit system libraries. The 32-bit versions are in (where else?) SysWOW64. Makes perfect sense, right? (From an engineering standpoint it probably does, but it’s going to be a source of confusion for a lot of people, no doubt).

    Monday, April 30, 2007 12:20 AM
  • Hi - I'm having the same problem and tried the listed solution, but there is no directory C:\windows\SysWOW64.  I was in c:\windows\system32 directory and listed the contents just to be sure I didn't misspell the directory name, but again, there is no directory "SysWOW64" listed.  Can you advise please?  Thanks for your help.
    Sunday, May 27, 2007 12:28 AM
  • just run the command from the c:\windows\system32 directory.  it works
    Thursday, May 31, 2007 6:30 AM
  • It does not work on my version of Vistsa which is running om a Dell E521 with AMD chipset

     

    I get the nmessage "The module "vbscript.dll" was loaded but the call to DllRegisterServer failed with error code 0x80004005" whereever I run it from

     

    I have also tried dowloading teh lates VBscript engine only to be told the version on my mmachine is later than the one being downloaded

     

    Anybody else help here.

    Saturday, June 9, 2007 9:46 AM
  • Google Desktop and Google Update appear to use the vbscript.dll and cause this conflict. Try removing them if they are installed and see if it fixes the problem.
    Monday, June 11, 2007 3:54 PM
  • Had the same problem. Use the same inmstruction, but go to c:windows\system and try the same command. It worked for me. Good Luck!
    Friday, June 22, 2007 1:54 PM
  • I tried this and it didn't work for me either.  I  did do it at the c:/windows/system32 prompt and when I typed in the systemwow64 I keep getting syntax is incorrect.  Please Help!
    Saturday, June 23, 2007 3:48 PM
  • Hey

     

    I had the same problems with installing Quick Time and the ERROR that I should enable or allow VBScript.  After hours of trying I found the following solution:

     

    You need to register vbscript.dll and if the running of the dll through the command prompt did not help, try this:

     

    PLEASE READ EVERYTHING BEFORE YOU TAKE ANY STEPS.

     

    You will need to download and install Windows Script 5.6 for Windows XP and Windows 2000.

     

    You can find this download at: 
      http://www.microsoft.com/downloads/details.aspx?FamilyID=c717d943-7e4b-4622-86eb-95a22b832caa&displaylang=en&Hash=XI9enj4vV%2f29Tz8mx3kVhbdMfWYkDHncDOgAq2IxQWfQIo%2fRUq%2f0TjlX0kf4t9ExlTRjV5nzeCF5qtVBU9ctaA%3d%3d

     

    When the installation process starts, note carefully because the system will inform you that a newer version of these files and dll's are currently installed on your computer, simply enforce the install of the older files, BUT ONLY UNTIL YOU SEE the one that is for vbscript.dll.  It is about the 3rd or 4th one.  After that you can simply allow the installer to keep the newer files on your system.

     

    Now run your QuickTime install and restart your system.  The files will update with Microsoft or Windows update and resolve any other issues.  Well at least for me it did.

     

    Good Luck.

    Sunday, June 24, 2007 11:08 AM
  • Thanks, Ming! I have a 32 bit Vista install with the same message and the "run as administrator" did the trick!!!! Much thanks.....I looked everwhere and found nothing. I was ready to bite the bullet and reinstall the OS completely. Now I may not need to.

     

    Keep up the good work.

     

    Saturday, May 17, 2008 8:26 AM