locked
menu list and right click menus disappear RRS feed

  • Question

  • Hi,

    I have Microsoft Office Home and Business 2016 desktop version. I am experiencing the following two problems:

    1. when I right-click in Excel/Word, the menu bar disappears after 2 seconds
    2. when I select any drop-down list from the Excel ribbon, the menu list disappears after about 2 seconds

    I am using Windows 10 64-bit. All windows updates and Office updates are installed.

    I have disabled all add-ons in Excel, and the problem persists. 

    I have opened Excel from the run menu using excel /safe to start in safe mode. The problem persists. 

    I have booted Windows 10 into Safe Mode. However, none of my Office applications will start at all in safe mode. 

    I have tried "quick repair" and "online repair." The "online repair" option solved the problem for one day, but then the problem came back. 

    I have completely uninstalled and reinstalled Microsoft Office, but the problem persists. 

    This is a very frustrating problem and I am unable to use Excel correctly as a result. Any solutions would be highly appreciated. 

    Thanks,

    Qasim

    Saturday, June 18, 2016 9:05 AM

Answers

All replies

  • Hi,

    Have you tried performing a windows clean boot to determine whether background programs are interfering with your Office programs? For your convenience:

    https://support.microsoft.com/en-gb/kb/929135

    In addition, please have a look at the following thread which discussed a similar issue. In the thread, Noel suggested to use a third-party utility to troubleshoot the issue, you may also have a try.

    https://social.technet.microsoft.com/Forums/office/en-US/f9985ba8-e842-4ab8-907f-272139f66448/rightclick-menu-disappears-when-rightclicking-files-on-windows-81?forum=w8itprogeneral

    Hope this helps.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    • Proposed as answer by Steve Fan Thursday, June 30, 2016 9:46 AM
    • Marked as answer by Steve Fan Friday, July 1, 2016 8:58 AM
    Monday, June 20, 2016 8:55 AM
  • Did you ever find an answer to this. I'm having the same issue, with Win 7 and Office 2010. The link that steve provided had to do with the OS. Not with office. 
    Monday, August 21, 2017 2:32 PM
  • I've been working on this for a week or so now and I just found the solution to my problem.  I had been using an old version of SnagIt that was causing the problem. I have updated SnagIt to version 13 (the latest) for $25.  Now, the problem has gone away! If you don't have SnagIt, look for similar apps. For reference, SnagIt has a little app the runs all the time at the top of the screen.  If you put the pointer over it, a menu pops up allowing you to capture the screen. Look for other apps that have screen overlay features like this one.
    Monday, August 28, 2017 4:39 PM
  • Dear friends,

    In my case, it was the last Dropbox update that was causing this problem. I am not a professional, so I don't know how to solve it more properly, but I have terminated the Dropbox processes at the task manager console and Office menus have gone back to normal.

    Hope it helps.

    Monday, September 4, 2017 12:36 PM
  • I concur - DropBox was the problem

    Didn't know the kids had used DropBox, but found it in Windows Task Manager - Processes

    Deleted it from the computer

    No more dropping out of context menus

    Monday, September 4, 2017 10:03 PM
  • After you said this, I killed my dropbox processes and now excel acts correctly.
    Tuesday, September 5, 2017 4:51 PM
  • Paco Vidal,

    Thanks for pointing out Dropbox.  The menu disappearance thing in Excel was driving me around the bend.  Removing Dropbox fixed the problem immediately!  I'll just use the Dropbox web interface.

    Thanks!

    Wednesday, September 6, 2017 5:56 PM
  • That was causing my issue also. Thank you!
    Thursday, September 7, 2017 5:41 PM
  • Thank you, thank you, 1000 times thank you.  It definitely helped.
    Thursday, September 7, 2017 8:38 PM
  • Thanks for the pointer about dropbox!  I managed to keep dropbox running and fix the problem (at least in initial testing) by going to dropbox settings and disabling the dropbox badge ("never show").
    Tuesday, November 7, 2017 3:08 AM
  • Hello,I guess the generic solution for this issue, is to open options ==> Add-Ins, then check active ones and disable the one you suspect is causing this issue and try! 

    Rgds

    Hany

    Tuesday, December 26, 2017 10:29 PM
  • Hello,I guess the generic solution for this issue, is to open options ==> Add-Ins, then check active ones and disable the one you suspect is causing this issue and try! 

    Rgds

    Hany

    Tuesday, December 26, 2017 10:29 PM
  • This solved it for me, thanks! In my case the problematic add-on was Babylon translator.
    Tuesday, October 30, 2018 3:28 PM
  • In my case it was a LogMeIn remote control window that was the culprit. Closing that window caused the context menu issue to end.
    Friday, December 21, 2018 3:01 AM