none
vEthernet Trouble (this time in the right forum)

    Question

  • So I am working on a project fixing up some old 2008 Hyper-V servers for a school district (new HDDs, more RAM, server2012r2, etc).  All 3 boxes are nearly identical, but one is having an issue where it cannot pass internet through to the vEthenet switch.

    Each individual ethernet line works
    When teamed together the team of 4 lines works
    Once the HyperV vswitch is added all network is lost

    Here is some of what I have tried to fix it:
    -Checked and double checked static config and it is right
    -Tried DHCP; I can get an address on the individual and team configs, but not the vEthernet switch
    -Made sure the option was checked to pass the network through to the host
    -Tried pinging devices on network and I get a transmit error, which leads me to believe it is something with the vEthernet Switch itself
    -Tried uninstalling and reinstalling Hyper-V role
    -Tried removing and rejoining the Domain
    -Tried only hooking up 1 line to vEthernet (no teaming), and it still does not work
    -Tried 1 line on the add-on card without teaming, and same result
    -Checked physical switch for any faults or security issues that may be blocking the port, and nothing is set up (though I should perhaps add some port security after this is up and running lol)

    Other possible important info:
    -Before this process the server was running HyperV 2008 on a single line (2 lines were plugged in, but only 1 was plugged into the switch), the other 2 nearly identical servers set up fine with vEthernet on the 2 onboard lines.
    -Server 2012r2 is installed and fully updated
    -OS is on 2 disks in RAID1 (1TB), data is on 6 disks in RAID6 (~3.5TB)
    -Roles installed: file sharing services, and HyperV
    -Features installed (outside of default and required for roles): dotNet 3.x (for RAID controller software)
    -2 lines are onboard (Broadcom 5709), and 2 lines are on an Intel add-on card
    -Server model is IBM x3650 m2 (link: http://www-07.ibm.com/systems/includes/content/x/pdf/prod_guide.pdf )
    -Updated all firmware via IBM's updater tool

    The only difference between this box and the other 2 I have done recently is that this unit has a larger RAID card, and it has that Intel add-in card.  Outside of that they are all the same make/model, so I am at a loss as to why it works on 2 but not on this unit.  If anyone has some pointers I would appreciate it.

    Thanks,
    Caeden


    • Edited by CaedenV Wednesday, February 22, 2017 1:49 PM
    Wednesday, February 22, 2017 1:46 PM

Answers

  • Have you disabled VMQ on the physical NICs?

    . : | : . : | : . tim

    • Marked as answer by CaedenV Wednesday, February 22, 2017 6:48 PM
    Wednesday, February 22, 2017 2:36 PM

All replies

  • Have you disabled VMQ on the physical NICs?

    . : | : . : | : . tim

    • Marked as answer by CaedenV Wednesday, February 22, 2017 6:48 PM
    Wednesday, February 22, 2017 2:36 PM
  • @Tim

    I think you are on to something!  I have not heard of VMQ, but after reading up on it this may be the issue.  Remoting into the servers that are working VMQ is enabled, and on the one having issues it is disabled.

    I am hesitant to mess with network settings remotely, so I will try it out when I show up there this afternoon.

    Thanks for the tip!  hope this works!

    Wednesday, February 22, 2017 4:33 PM
  • OK! we are up and in business!

    So, I am not 100% sure what the root of the issue is, but here is what worked (and is repeatable):

    1) Set up the network teaming ONLY with the onboard Broadcomm interfaces (Netextreme II)
    2) Create the vEthernet Switch
    3) Run powershell as administrator
    4) disable-netadaptervmq -name "connection name here"
    5) enable-netadaptervmq -name "connection name here"

    That got things up and running as it should.

    Sadly, the add-in Intel card appears not to have vmq support (Intel pro 1000 mt dual port server adapter).  It does not show up when doing the get-netadaptervmq command, and I cannot enable VMQ on the team with those 2 adapters.  I think I will simply pull the card for now and find a better home for it in a non-HyperV box.

    Thanks for the help Tim!  I was completely stumped, and now I know a lot more about how vSwitches work in HyperV.  This was a fun one!

    Wednesday, February 22, 2017 6:48 PM