locked
Liteon DVD Burner compatiblity RRS feed

  • Question

  • The device manager sees my dvd burner, but it tells me that i can't use it because "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)". I've tried uninstalling it and have windows automatically configure it, but it always fails. I'm out of ideas here seeing as Liteon doesn't provide drivers for their products.
    Thursday, January 15, 2009 2:53 PM

Answers

All replies

  • There are no drivers required for an optical device other than those included in the OS. Try disconnecting the drive / reboot / shut down / reconnect the drive /  reboot. 
    Thursday, January 15, 2009 11:54 PM
  • Hi there,
    I have the same problem exactly, I even tried two other LG DVD Roms/burners. I still have the same problem!

    Larry
    Friday, January 16, 2009 3:41 AM
  • there's nothing wrong with the drive or its connection. it worked until i upgraded to 7, and it also worked when i booted windows without the unsigned driver protection.
    Friday, January 16, 2009 10:12 PM
  • The 'unsigned drivers' is almost certainly down to the CD/DVD software rather than the drive itself.

     

    What suite are you using?

     

    If it is Roxio, check on the Roxio users' forum where there is a section for Windows 7

    Monday, January 26, 2009 2:27 PM
  • I'm having similar problems with my dual Dell optical drives. Ever since I installed windows 7 the computer can't recognize them (or my 19-in-one media card reader either). This could be a problem for me since I won't be able to install vista again without them.
    Monday, January 26, 2009 3:44 PM
  • Not necessarily - the fact that you have 'lost' the drives in W7 doesn't nean that you can't boot from BIOS.

     

    However, an old trick is to go to device manager and uninstall the IDE connection, reboot and let Windows re-detect it

    Monday, January 26, 2009 3:46 PM
  • I've tried uninstalling and restarting, disconecting and reconecting, enabling, updating, checking for driver changes and it still can't get them to work (Although it does recognize them now)
    Monday, January 26, 2009 4:21 PM
  • Now that Windows sees them - can you not access them (even to read)? 

    If it';s for burning, what software are you using? (some earlier versions might not work)

    Monday, January 26, 2009 5:03 PM
  • Hi Folks;

    I have the same problem with a new LG SATA Rom Drive

    Monday, January 26, 2009 5:59 PM
  • They have exclamation marks next to them in device manager and don't appear in My Computer. No they don't work. I generally use windows (for data) or DVD maker (for movies)
    Monday, January 26, 2009 11:00 PM
  • i've discovered that the problem is related to itunes. (as mentioned in a similar thread). itunes installs some sort of driver that causes a conflict with the cd/dvd drive driver, as posted in this thread: http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/96197089-739f-4e56-9b20-cfc9840d233d/

    it worked for me, it should work for you.
    • Marked as answer by Nikiaf Monday, January 26, 2009 11:06 PM
    Monday, January 26, 2009 11:06 PM