none
Distribution Group Sender Restrictions Not Working

    Question

  • I've created a new distribution list via the ECP and added myself to it.  In the list's details, under delivery management, I have 'Only senders inside my organization' ticked. However, when I send an email from an external gmail address, it goes through.  What am I doing wrong?
    Monday, February 1, 2016 7:22 PM

Answers

  • I've discovered and corrected the issue.  Turns out it was not a configuration problem with exchange but rather our Symantec Messaging Gateway.  A feature called 'distribution list expansion' was enabled, which queried our distribution lists via LDAP and forwarded emails directly to the list members rather than to the list address itself, thus bypassing any exchange distribution list settings we had.  Disabling this resolved our problem.   Sorry to waste your time!
    • Marked as answer by Macelsters Thursday, February 25, 2016 9:22 PM
    Thursday, February 25, 2016 9:22 PM

All replies

  • Check this link https://social.technet.microsoft.com/Forums/office/en-US/2f6dfd6c-6cd2-4c55-96ea-93eb602819e4/only-senders-inside-my-organization-not-working?forum=exchangesvrgeneral
    Monday, February 1, 2016 7:36 PM
  • Thanks.  The receive connector they are coming in on is configured as such:
    Monday, February 1, 2016 8:06 PM
  • Post results of cmdlet: Get-receive connector "your connector" | get-adpermission | select user,extendedrights | where {$_.extendedrights -like "Ms-Exch-SMTP-Accept-Any-Recipient"}
    Tuesday, February 2, 2016 5:20 AM
  • I apologize for the lengthy delay in getting back. There was no output returned from the above query.  We are still having this issue.

    [PS] C:\Windows\system32>Get-receiveconnector "Messaging Gateway Connector" | get-adpermission | select user,extendedrights | where {$_.extendedrights -like "Ms-Exch-SMTP-Accept-Any-Recipient"}

    [PS] C:\Windows\system32>


    Thursday, February 25, 2016 7:15 PM
  • I've discovered and corrected the issue.  Turns out it was not a configuration problem with exchange but rather our Symantec Messaging Gateway.  A feature called 'distribution list expansion' was enabled, which queried our distribution lists via LDAP and forwarded emails directly to the list members rather than to the list address itself, thus bypassing any exchange distribution list settings we had.  Disabling this resolved our problem.   Sorry to waste your time!
    • Marked as answer by Macelsters Thursday, February 25, 2016 9:22 PM
    Thursday, February 25, 2016 9:22 PM