none
ADFS 2016 works with Chrome and Firefox but not IE

    Question

  • Hey guys, I've got ADFS 2016 installed and federated with Office 365, however when I use Internet Explorer to login I get an error page saying "Sorry but we're having trouble signing you in".

    Additional technical information:
    Correlation ID: 646d56c1-a333-4cbd-a8d0-efbaffe2ac7e
    Timestamp: 2017-05-05 04:35:57Z
    AADSTS50107: Requested federation realm object 'http://domain.com/adfs/services/trust/' does not exist.

    The strange thing is, if I use Chrome or Firefox, then it redirects me to my ADFS page where I enter my password and then passes me through to 365.

    In another post someone suggested switching from Windows Authentication to Forms authentication for intranet sites, which does fix the IE problem - however, I dont know what that affects and why enabling windows authentication causes IE to fail.

    Friday, May 5, 2017 11:59 PM

All replies

  • Hi amary96,

    I suggest you check a few things:

    Does your UPN of the user object match the UPN that you are typing into the form based prompt - eg user@domain.com

    Does the federation realm exist for your tenant?

    Log into Office 365 powershell and run this command, look for the IssuerURI value and compare it to the one in your error.

    get-msoldomainfederationsettings -domainname contoso.com

    Good Luck!

    Shane

    Monday, May 8, 2017 8:52 PM
    Moderator
  • Hi

    Did you ever resolve this. I have the same issue.

    Peter

    Tuesday, October 9, 2018 6:55 PM
  • omoht23, what about Shane's remarks? What are your answers to them?

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Tuesday, October 9, 2018 7:11 PM
    Owner
  • All looked fine and as expected.
    Tuesday, October 9, 2018 7:18 PM
  • Sorry I should have said my error is similar, but not the same. Rather than getting

    Requested federation realm object 'http://domain.com/adfs/services/trust/' does not exist

    I am getting

    Requested federation realm object '{EmailHidden}' does not exist.

    Tuesday, October 9, 2018 7:32 PM