none
system error 1290 after register w32time service

    Question

  • Hello all

    I'm getting a system error 1290, when i try to use the command "net start w32time".

    The output from cmd looks like this:

    System error 1290 has occurred.

    The service start failed since one or more services in the same process have an incompatible service SID type setting. A service with restricted service SID type can only coexist in the same process with other services with a restricted SID type. If the service SID type for this service was just configured, the hosting process must be restarted in order to start this service.

     

    How do i recover from this error?

     

    Tuesday, October 19, 2010 7:53 AM

Answers

  • Troubleshooting an unrelated issue, I think I've finally found the solution to this error (sometimes, rebooting also fixes this specific error). See the underlined command below, and mind the required space between = and own. The command puts the w32time service in it's own svchost process, so it doesn't have to share the process with other services which may have been configured with an service SID type incompatible with w32time's.

    Running the following from an elevated command prompt seems to be a pretty surefire way to fix your Windows Time service.

    pushd %SystemRoot%\system32
    .\net stop w32time
    .\w32tm /unregister
    .\w32tm /register
    .\sc config w32time type= own
    .\net start w32time
    .\w32tm /config /update /manualpeerlist:"0.pool.ntp.org,1.pool.ntp.org,2.pool.ntp.org,3.pool.ntp.org",0x8 /syncfromflags:MANUAL /reliable:yes
    .\w32tm /resync
    popd
    • Proposed as answer by VBdP Thursday, November 1, 2012 1:46 PM
    • Marked as answer by Yagmoth555MVP, Moderator Tuesday, February 25, 2014 7:58 PM
    Thursday, November 1, 2012 1:46 PM
  • Hi cliff.ha, I suggest you first try the following steps and see the result:

    1.Click Start , type regedit in the Start Search box, and then click regedit.exe in the Programs list.

    If you are prompted for an administrator password or for a confirmation, type your password, or click Continue .

    2.Locate the following registry subkey, and then click it:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TapiSrv

    3.In the details pane, right-click ImagePath , and then click Modify .
    4.In the Value data box, type the following registry value, and then click OK :

    %SystemRoot%\System32\svchost.exe -k NetworkService

    Note: If NetworkService does not appear in the %SystemRoot%\System32\svchost.exe -k NetworkService registry value, the problem that is described in the "Symptoms" section may occur.

    5.Exit Registry Editor, and then restart the computer.

    Note If you try to start the Telephony service before you restart the computer, you may receive the following error message:
    Error 1290: The service start failed since one or more services in the same process have an incompatible service SID type setting. A service with restricted service SID type can only coexist in the same process with other services with a restricted SID type. If the service SID type for this service was just configured, the hosting process must be restarted in order to start this service.

    Hope this helps!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 21, 2010 7:15 AM
    Moderator

All replies

  • Hi cliff.ha, I suggest you first try the following steps and see the result:

    1.Click Start , type regedit in the Start Search box, and then click regedit.exe in the Programs list.

    If you are prompted for an administrator password or for a confirmation, type your password, or click Continue .

    2.Locate the following registry subkey, and then click it:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TapiSrv

    3.In the details pane, right-click ImagePath , and then click Modify .
    4.In the Value data box, type the following registry value, and then click OK :

    %SystemRoot%\System32\svchost.exe -k NetworkService

    Note: If NetworkService does not appear in the %SystemRoot%\System32\svchost.exe -k NetworkService registry value, the problem that is described in the "Symptoms" section may occur.

    5.Exit Registry Editor, and then restart the computer.

    Note If you try to start the Telephony service before you restart the computer, you may receive the following error message:
    Error 1290: The service start failed since one or more services in the same process have an incompatible service SID type setting. A service with restricted service SID type can only coexist in the same process with other services with a restricted SID type. If the service SID type for this service was just configured, the hosting process must be restarted in order to start this service.

    Hope this helps!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 21, 2010 7:15 AM
    Moderator
  • We are getting the following error message at our end while trying to start the Routing and Remote Access Service.

    ---------------------------
    Services
    ---------------------------
    Could not start the Routing and Remote Access service on Local Computer.  Error 1290: 0x50a
    ---------------------------
    OK  
    ---------------------------

    We are also getting a system event 7000 in the event viewer
    I wanted to know if the above mentioned issue was resolved by any chance??

    Thanks,

    Prashant

    Tuesday, December 28, 2010 6:13 AM
  • I am confused why modifying the TAPI server would affect the Time Server.
    Harold Naparst
    Thursday, March 10, 2011 8:57 AM
  • I have the same problem on a Win2008 R2 server on Amazon EC2.  I keep on seeing this solution wherever I look, but..

    • What has the this RAS service got to do with the time server?
    • I do not have this registry key.  It is Server Core, so does not have this role.
    • It is connected to my LAN using OpenVPN, if that makes a difference.
    • The Amazon Ec2Config service cannot start either, as it depends on the w32time service for some reason.

    What do I do to fix this problem with the time service, as I do nto have this seemingly irrelevant key in the registry.

    This server is a domain controller, and there are only two in total, so it needs to be fixed as soon as possible. 

    Thanks.


    • Edited by jason404 Tuesday, April 10, 2012 2:49 PM
    Tuesday, April 10, 2012 2:48 PM
  • It is really unfortunate that people are allowed to mark their own posts as answers, as this is a completely bogus answer, the TapiSrv has nothing to do  with the time service.  The only reason it might fix the problem is the reboot at the end.
    • Edited by stangm Wednesday, May 2, 2012 7:02 PM
    Wednesday, May 2, 2012 7:02 PM
  • That's true.

    The problem was solved just restarting the server.

    Sunday, September 30, 2012 5:19 AM
  • Troubleshooting an unrelated issue, I think I've finally found the solution to this error (sometimes, rebooting also fixes this specific error). See the underlined command below, and mind the required space between = and own. The command puts the w32time service in it's own svchost process, so it doesn't have to share the process with other services which may have been configured with an service SID type incompatible with w32time's.

    Running the following from an elevated command prompt seems to be a pretty surefire way to fix your Windows Time service.

    pushd %SystemRoot%\system32
    .\net stop w32time
    .\w32tm /unregister
    .\w32tm /register
    .\sc config w32time type= own
    .\net start w32time
    .\w32tm /config /update /manualpeerlist:"0.pool.ntp.org,1.pool.ntp.org,2.pool.ntp.org,3.pool.ntp.org",0x8 /syncfromflags:MANUAL /reliable:yes
    .\w32tm /resync
    popd
    • Proposed as answer by VBdP Thursday, November 1, 2012 1:46 PM
    • Marked as answer by Yagmoth555MVP, Moderator Tuesday, February 25, 2014 7:58 PM
    Thursday, November 1, 2012 1:46 PM
  • Thanks VBdP the sc config command worked Cheers.
    Wednesday, November 28, 2012 10:43 PM
  • Worked like a charm, thanks for your brain time VBdP.
    Friday, December 21, 2012 4:07 PM
  • Hello,

    I did all the first 7 passages (with another NTP sorce) succesfully, but when I put

    .\w32tm /resync

    It results  "Access is denied (0x80070005)

    I tried to change MANUAL with DOMHIER, because I've only a DC (windows 2008) but I obtain the same result.

    The clock retards 5 minutes. What can I do?

    Thank you


    • Edited by Lgalver Thursday, January 10, 2013 10:06 AM
    Thursday, January 10, 2013 1:24 AM
  • Troubleshooting an unrelated issue, I think I've finally found the solution to this error (sometimes, rebooting also fixes this specific error). See the underlined command below, and mind the required space between = and own. The command puts the w32time service in it's own svchost process, so it doesn't have to share the process with other services which may have been configured with an service SID type incompatible with w32time's.

    Running the following from an elevated command prompt seems to be a pretty surefire way to fix your Windows Time service.

    pushd %SystemRoot%\system32
    .\net stop w32time
    .\w32tm /unregister
    .\w32tm /register
    .\sc config w32time type= own
    .\net start w32time
    .\w32tm /config /update /manualpeerlist:"0.pool.ntp.org,1.pool.ntp.org,2.pool.ntp.org,3.pool.ntp.org",0x8 /syncfromflags:MANUAL /reliable:yes
    .\w32tm /resync
    popd

    The problem with your fix is when running a DCDiag it comes up with this..

    Starting test: Services
           Invalid service type: w32time on DCSERVER, current value WIN32_OWN_PROCESS, expected value
           WIN32_SHARE_PROCESS
        ......................... DCSERVER failed test Services


    Thanks, Charlie


    • Edited by CJlindell Friday, May 31, 2013 12:07 AM
    Friday, May 31, 2013 12:06 AM
  • Stop the elevated service and restart it normally again then.
    Monday, June 3, 2013 10:03 PM
  • This isn't even in the same hemisphere as a correct answer.  In fact, this is "wronger" than two boys caught naked in the woods with the chaplain's assistant.
    Monday, July 29, 2013 4:03 PM
  • Careful with that registry change, I just blew my TMG to space.
    Tuesday, February 25, 2014 10:54 AM
  • Hi, I seen there is one abuse report in that thread, I Sean Zhu's answer talk about TAPI, but is it a error he wrote ?, no way to know. As .\sc control w32time type=own from VBdP's script do the same check, but of course flagged for the w32time. I will remove the abuse report and mark VBdP's answer.

    Just a small reference for the issue too; Getting Started with SVCHOST.EXE Troubleshooting


    Regards, Philippe

    Tuesday, February 25, 2014 7:58 PM
    Moderator
  • The:sc config w32time type= own

    trick fixed it for me.


    Chris

    • Proposed as answer by jtibbitts Wednesday, April 16, 2014 10:42 AM
    Monday, March 17, 2014 5:22 PM
  • Fantastic! I have been stuck for days! Trying everything that I could find on the net! Including Microsoft! Brilliant
    Tuesday, July 8, 2014 3:41 PM
  • Yes, Sean, but it can be most clear:

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\TapiSrv\\ImagePath
    Value name: ImagePath
    Value Data:
    %SystemRoot%\System32\svchost.exe -k NetworkService

    A.B. IT PRO (aka Jane Doe)

    Tuesday, September 16, 2014 9:46 PM
  • Windows time service problematic key
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services

    \TapiSrv\\ImagePath
    Value name: ImagePath
    Value Data:
    %SystemRoot%\System32\svchost.exe -k NetworkService

    However, Rebooot is seems inevitably !

    • Proposed as answer by BrianIsHawaiian Saturday, February 21, 2015 6:23 PM
    • Unproposed as answer by BrianIsHawaiian Saturday, February 21, 2015 6:23 PM
    Tuesday, September 16, 2014 10:29 PM
  • Thanks VBdP!
    Monday, July 13, 2015 8:38 PM
  • Hi VBdP,

    I want the above fix to be applied in prod domain controller where I have the same time service issue. I was just testing it in test dc prior applying in production. I have received below message when I ran dcdiag.

     DCTest passed test RidManager
       Starting test: Services
             Invalid service type: w32time on DCTest, current value
             WIN32_OWN_PROCESS, expected value WIN32_SHARE_PROCESS
          ......................... DCTest failed test Services

    What I want to know here is , Is there any side effects of running the command .\sc config w32time type= own  production domain controller ?

    Tuesday, November 3, 2015 9:24 AM
  • You can set the service config to "own" so it uses its own svchost process and this "works", but after doing so typically you cannot use the w32tm /query commands, because you get Access Denied error messages. Not only that, but the dcdiag Domain Controller testing fails because the service is not using a type of "share".

    See https://social.technet.microsoft.com/Forums/windowsserver/en-US/9eeab977-6c94-43d1-8f2f-3cb1eb525744/w32tm-query-status-access-is-denied-0x80070005-from-elevated-prompt?forum=winserverDS for a better answer to this issue.

    The solution is not only perform w32tm /unregister & /register, but in between those commands, ALSO to execute a "regsvr32 /u w32time.dll" command. I'm guessing that the w32tm /unregister (at least in the broken state) does not unregister the DLL or fails trying.

    Do it in this order in an administratively elevated command prompt, reboot as specified - twice! (Copied from other thread above, thanks to the writer!)

    1. net stop w32time
    2. w32tm /unregister
    3. --- REBOOT ---
    4. regsvr32 /u w32time.dll
    5. w32tm /register (this will re-register the DLL, no need to do it separately)
    6. sc query w32time -- you should see that the service is set to shared mode -- if you try to start right now, you'll get the expected 1290 SID-related error
    7. --- REBOOT ---

    Follow the above instructions, and you do not need to do anything with the TapiSrv registry key or service configuration.

    Saturday, December 12, 2015 6:04 AM
  • Thank you so much!

    Using the SC Config command proposed in the marked answer would cause w32tm to start the service but with Access denied errors whenever I tried to do anything with it.

    Following your steps EXACTLY as you proposed fixed my issue 100%.

    I've proposed it as the answer as it 100% works with no side effects.

    Martin

    Thursday, January 7, 2016 1:35 AM
  • Hi all,

    same problem .. I solved this without the reboot, on 2012 r2: 

    sc config w32time type=own and on Log On tab I selected "Local System Account".

    Now the service is working fine.

    Alex

    Monday, January 18, 2016 2:34 PM
  • Hi all,

    same problem .. I solved this without the reboot, on 2012 r2: 

    sc config w32time type=own and on Log On tab I selected "Local System Account".

    Now the service is working fine.

    Alex

    Careful with this method, as initially this also "worked" for me, but I was then unable to run any w32tm commands and kept getting "Access Denied" errors.  Only by following the steps exactly as described did the whole thing get back to a full, proper, working state.
    Wednesday, January 20, 2016 9:54 PM
  • Nice solution as my time was continually changing to 6 hours ahead. After your suggestions I can now start service but when trying to resync it fails for following:

    Sending resync command to local computer
    The following error occurred: Access is denied. (0x80070005)

    Monday, February 20, 2017 3:31 AM
  • When you in-register and re-register the W32Time service, the service is set as a shared service (WIN32_SHARE_PROCESS) - As shared services have a hard time registering themselves outside of the boot process, this shows a lot of the issues that have been pointed out on the thread.  Setting the service to Own (WIN32_OWN_PROCESS) will make it look like the issue has been fixed, but causes the Access is denied issues.  The correct fix it to unregister the service, and the re-register the service and reboot.  If you have set the server to WIN32_OWN_PROCESS, then setting it back to WIN32_SHARE_PROCESS [sc config w32time type= share] and rebooting will resolve the issue.
    Wednesday, April 5, 2017 5:20 PM
  • thank you!!!

    saludos

    Wednesday, April 18, 2018 12:44 PM
  • +1 million to net-bytes, all the other fixes were not helping, your addition of unregistering the DLL is the fix for my problem
    Wednesday, May 16, 2018 5:13 PM