none
Remote Desktop session disconnect RRS feed

  • Question

  • We have a number of thin clients and standard PC's that access a Windows 2012 R2 server using Remote Desktop.  Each of these sessions start a common program so that the client never sees a desktop on the server just the running program.  Our problem is that after a successful logon if the user walks away from the workstation and the connection sits idle for ten minutes (exactly ten minutes) the session disconnects and the user is required to ctrl-alt-delete to restart the session.  The application program is never affected it is still at the same spot when the user re-establishes a connection.
    • Moved by Amy Wang_Moderator Wednesday, September 14, 2016 1:55 AM RDS related from Windows Server 2012 General forum
    Tuesday, September 13, 2016 9:14 PM

All replies

  • I have seen this before and it is configurable on your server.  Use the following article to set the "Idle Session Limit" to increase the time users can be idle and not have the session time out.

    https://blogs.technet.microsoft.com/askperf/2012/10/30/windows-8-windows-server-2012-remote-desktop-management-server/

    Hope this helps,

    -Nathan


    Tuesday, September 13, 2016 9:40 PM
  • Hi,

    In addition, session time limit setting can also be configured via Group Policy setting under

    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits.

    If the setting is not configured within Server Manager -> Collection Properties, try to find out which GPO has the setting configured via GPresult.exe.

    More specifically, you may use /h switch to get an .html view.

    For example:

    GPresult /h C:GPresult1.html

    More information for you:

    Session Time Limits

    https://technet.microsoft.com/en-us/library/ee791741(v=ws.10).aspx

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 14, 2016 8:27 AM
    Moderator
  • Amy,

    We had checked "Session Time Limits" in both Computer Configuration (Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits) and under User Configuration by using gpedit.  In both location they are set to Not Enabled.  By definition that should mean an unlimited connection time. 

    We also checked the Power Settings in Control Panel and Screen Saver Settings.  

    Also since the idle time before disconnect is exactly 10 minutes we searched the registry for any entry with 600 seconds.  But found nothing that applies to this problem. 


    Ed Lovinguth

    Thursday, September 15, 2016 4:18 PM
  • Hi,

    Kindly check subkey entries under registry key below:

    HKEY_Local_Machine\ SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 21, 2016 2:34 PM
    Moderator
  • Hi,

    Would you please provide us with an update on the status of your issue?

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, September 26, 2016 9:31 AM
    Moderator