locked
Windows 10 mobile won't delete text messages RRS feed

  • Question

  • I'm running Windows 10 mobile 10.0.10586.107 on a Lumia 640. I've been trying to purge old text conversations. However if I have "Sync Messages between devices" set in the Message settings window if I delete a text conversation it is just restored onto the phone. I tried disabling the setting and deleting all the conversations I wanted to purge. I then waited a week and turned the setting back on and all the purged conversations came back. How can I possible delete conversations without disabling the sync setting? Also, I only have one mobile device setup with this account.


    Vincent Sprague

    Sunday, February 28, 2016 4:24 AM

All replies

  • Same thing here. I understand all texts are saved in Onedrive, however the folder is hidden.

    AL Rosa

    Wednesday, March 2, 2016 4:49 PM
  • Same thing here. It's annoying. "Sync" makes them reappear. Totally a new phone, so no reasons those ancient texts should show up on a different phone. I turned the "Sync" option off for two months and they went away.  But when I turned it back on the messages reappeared. 
    Tuesday, March 29, 2016 11:02 PM
  • I had to reset my phone last week due to getting a new insider preview release that totally broke a ton of stuff on my phone. After the reset and going back to Version 1511, OS Build: 10.10.10586.164 this issue appears to be resolved. I'm not sure if it was the full reset that resolved the issue or if it was just an issue with the build number I was running.


    Vincent Sprague

    Tuesday, April 12, 2016 2:42 PM
  • I believe I found a reason/resolution. The reason the old text messages keep re-populating to your phone, even after you delete them. It's because your phone is referencing back to the backup file for the information has been stored.

     

    Renaming your phone will not be enough as it does not result in a new back up to be created, but rather replaces the old one with the new using the new phone name. So... you have to delete the backup file, delete the messages and/or conversations you don't want, and then create a new backup. See additional information below for all steps (so they don't come back in as you delete) AND be sure to do this when you have uninterrupted time to finish  so that after deleting the back up there is no reason for anything happen to your phone before creating the new backup... you don't want to lose everything.

     

    Go to settings, go to Backup, turn off backup content, turn off backup settings, click More Options link. Turn off Enable Automatic Backups. Click the link to Go To OneDrive.com and delete the backup file to your phone.

     

    Now, go back to settings, go to Backup, turn on backup content, turn on backup settings, click More Options link. Turn on Enable Automatic Backups. Click the Backup Now button. If it happens to come back as failed just make sure everything is turned back on as noted above and try again.

     

    I'm using a Nokia Lumia 830 running Windows 10 Mobile 10.0.10586.107

    I hope this is found to be helpful.

    Monday, July 25, 2016 12:12 AM
  • After all that, including emptying my OneDrive Recycle Bin, it did not work. So frustrating to have so many old and unneeded messages on my phone. Sorry everyone. I thought this process was a winner as it seemed to stick for a while.
    Saturday, August 27, 2016 8:37 PM