locked
Clean install Windows 10 can not RDP via 2012 RD2 RDG. RRS feed

  • Question

  • I have two systems, both clean installs of Windows 10 Pro.  Both systems used to connect to work via a Windows Server 2012 RD RD Gateway.  We saved the RDP shortcut and they both stopped working now.  We create a new short-cut with same or different creds and still does not work.  Failure seems to be when authentication takes place on the RD Gateway server, not the remote computer.  I know this since I removed all creds and enter each manually and this happens when I am asked for the RD Gateway creds.  Now if I connect from any other system it works fine, if I connect from my phone via MS's RDP client it works fine.  I checked event logs both on the client jumping in and the RDG server and there is nothing when this happens. 

    Error: Your computer can't connect to the remote computer because an error occurred on the remote computer that you want to connect to.  Contact your network administrator for assistance.

    Any thoughts?

    Friday, August 7, 2015 1:21 PM

Answers

  • Got it working, I added this to the client's registry.  (If Microsoft gets a server side solution I'll update this post.)

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client
     Name: RDGClientTransport
     Type: Dword
     Data: 1

    • Marked as answer by Franky_M Wednesday, August 26, 2015 1:52 AM
    Wednesday, August 26, 2015 1:52 AM

All replies

  • Hi Franky,

    I checked event logs both on the client jumping in and the RDG server and there is nothing when this happens. 

    Please also check for events logged on RD Connection Broker and RD Session Hosts, Terminal Services related logs can be found under Event Viewer -> Applications and Services Logs\ Microsoft\ Windows\.

    If there isn’t any related event logged on Terminal Servers, I would suggest you use Network Monitor on the client to find out which device/machine ended the connection.

    More information for you:

    Network Monitor 3 Usage Videos

    http://blogs.technet.com/b/netmon/p/usagevideos.aspx

    Network Monitor 3.4 Downloads

    http://blogs.technet.com/b/netmon/p/downloads.aspx

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Amy Wang_ Wednesday, August 12, 2015 9:37 AM
    • Proposed as answer by Amy Wang_ Tuesday, August 18, 2015 2:41 AM
    • Unproposed as answer by Amy Wang_ Wednesday, August 26, 2015 1:53 AM
    Wednesday, August 12, 2015 9:36 AM
  • All RD roles are on the same server as the Gateway.

    Clients all need to run Hyper-V (using virtual switch) so Network Monitor will not see the adapter.  Will have to wait to build a test machine without Hyper-V to use Network Monitor.  Of course all VM running on these Windows 10 Host are Win 8.1 and they can all RDP in without issue.

    Tuesday, August 18, 2015 3:46 AM
  • Got it working, I added this to the client's registry.  (If Microsoft gets a server side solution I'll update this post.)

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client
     Name: RDGClientTransport
     Type: Dword
     Data: 1

    • Marked as answer by Franky_M Wednesday, August 26, 2015 1:52 AM
    Wednesday, August 26, 2015 1:52 AM
  • Hi Franky,

    Glad to hear that you have found a solution and thank you for sharing with us!

    You solution is very beneficial to others who have similar issues.

    Please feel free to let us know if there are any further requirements.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 26, 2015 1:54 AM
  • Hello Franky,

    A customer of us ran into the error that the client couldn't connect to the RDP gateway server.

    We used the same fix as you mentioned and it worked.

    I would like to thank you for that.

    Besides this I have one question:

    I would like to know what this registery edit actually does in the back ground, so we can correctly fix this issue instead of using a work-arround.

    Kinds regards,

    Ralph

    Monday, September 5, 2016 9:51 AM
  • Hello Ralph

    The registry entry will disable WebProxy connections in the Windows 10 RDP client.

    I found that on msdn.com yet I also found in another thread on this site that it will also change Transport on Gateway from modern HTTP to legacy RPC-HTTP yet I can not find any documentation to confirm that claim.

    Monday, September 5, 2016 1:58 PM
  • Its now 2018, using Server 2016 RDS GW and brokers, and I am finding myself now having to use this same registry hack for my users on latest Windows 10 clients. Is there no update on a formal server side fix for this? From Franky's last post, this seems to neuter some modern HTTP security, which i would rather not be doing as a work around. Official MS response would be appreciated.
    Monday, January 22, 2018 4:20 PM
  • Many thanks Franky_M!!

    My Windows 10 computer stopped working a while back and I finally got around to searching for why. This resolved it instantly.

    John.


    John Salfer

    Friday, April 20, 2018 3:17 PM
  • Still no server side fix for this? Same config as Roland_Sanchez.

    Needing to apply a client side fix to an issue from 3 years ago seems a bit strange
    Thursday, July 19, 2018 10:25 PM
  • We actually fixed it a while back server side, but I can't recall what it was. I believe it had something to do with the way we had our passthrough SSL on the VIP that sat between the internet and gateway server. Allowing the GW server itself to handle SSL was the fix iirc.
    • Proposed as answer by Salah MESTI Monday, February 25, 2019 3:56 PM
    • Unproposed as answer by Salah MESTI Monday, February 25, 2019 3:56 PM
    Thursday, July 19, 2018 11:07 PM
  • Hello!

    I solved this issue on the SERVER SIDE by configuring the SSL Bridging on the RD Gateway 2016 Server(s) Properties:

    1. Open the RD Gateway Manager Console
    2. Right click on your Gateway Server
    3. A "Properties" window will appear
    4. Click on the "SSL Bridging" Tab
    5. Check the "Use SSL Bridging" box
    6. Select one of the 2 choice (HTTP-HTTPS... / HTTPS-HTTP...)
    7. Click on "Apply/OK"
    8. Test again your connection from a client computer

    This issue, like Roland SANCHEZ said, is linked to our non-microsoft LoadBalancer (F5).

    Maybe a modification is needed on the LoadBalancer to get it works.

    I don't have this issue on my RDS2008R2 Infrastructure, but only on my RDS2016 infrastructure which needs this settings above to get it works without any modification on our LoadBalancer.

    Cheers,

    • Proposed as answer by Salah MESTI Tuesday, February 26, 2019 8:35 AM
    • Edited by Salah MESTI Tuesday, February 26, 2019 8:38 AM
    Monday, February 25, 2019 4:02 PM