locked
Unable to redirect attachments over 10MB to support mailbox RRS feed

  • Question

  • I have set a transport rule in exchange 2007 sp3 to redirect all emails over 10mb to support@domain.com, however it doesn't work, and instead generating NDR to the sender:
    #< #5.2.3 smtp;550 5.2.3 RESOLVER.RST.RecipSizeLimit; message too large for this recipient> #SMTP#

    The reason why I need this rule , is because user mailboxes are capped at sending/receiving emails less than 10mb in size/

    send and receive connectors are set for 30MB

    Support mailbox has been set to send and receive at 30720 KB


     

    ClearCategories                  : True
    ConvertDisclaimerWrapperToEml    : False
    DSNConversionMode                : UseExchangeDSNs
    GenerateCopyOfDSNFor             : {5.6.3, 5.6.1, 5.6.0, 5.5.6, 5.5.5, 5.5.4, 5.5.3, 5.5.2
    InternalSMTPServers              : {127.0.0.1}
    JournalingReportNdrTo            : <>
    LegacyJournalingMigrationEnabled : False
    MaxDumpsterSizePerStorageGroup   : 18MB
    MaxDumpsterTime                  : 7.00:00:00
    MaxReceiveSize                   : 30MB
    MaxRecipientEnvelopeLimit        : 25360
    MaxSendSize                      : 30MB
    TLSReceiveDomainSecureList       : {}
    TLSSendDomainSecureList          : {}
    VerifySecureSubmitEnabled        : False
    VoicemailJournalingEnabled       : True
    HeaderPromotionModeSetting       : NoCreate
    WritingBrandingInDSNEnabled      : True
    Xexch50Enabled                   : True
    Transport rule used.
    rule
    Wednesday, March 28, 2012 8:47 AM

Answers

  • Well, since you are capturing emails that are larger than 10MB, why not increase your users max receive size to your default (or set it to unlimited) and allow the Transport rule to redirect the email?  This would be easy to test, on one user, issue set-mailbox <MailboxID> -MaxReceiveSize 30MB.  After that, send a 20 MB attachment and see if it is redirected to your support mailbox and ensure it does not appear in the users mailbox.
    • Marked as answer by uklogistics Tuesday, June 26, 2012 4:13 PM
    Friday, April 6, 2012 1:52 PM
  • Get-Mailbox | Set-Mailbox -MaxReceiveSize

    "The MaxReceiveSize parameter specifies the maximum size of messages that this mailbox can receive. You must specify either an integer or unlimited."

    http://technet.microsoft.com/en-us/library/bb123981.aspx

    That should do it but you might want to exclude certain mailboxes.

    Here's one example (with Get-User and -MaxSendSize) - also shows how the integer would look like (or you could use unlimited): 

    Get-User -Filter "Department -eq 'Customer Service'" | Set-Mailbox -MaxSendSize 2097152


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.



    Saturday, April 7, 2012 5:41 PM

All replies

  • Hi,

    >>message too large for this recipient

    You can check the usable mailbox size of recipient mailbox. Or, you can modify the transport rule to redirect all emails over 10mb to another mailboxA, and then check the result.

    Hope it helps.

    Thanks


    Sophia Xu

    TechNet Community Support

    Monday, April 2, 2012 1:55 AM
  • Hi

    I double checked your recommendations, and this transport rule still doesn't work.

    Does it work on your system? if so please let me know how you did it.

    thanks

    Thursday, April 5, 2012 3:24 PM
  • The categorizer processes the recipient resolution which includes limits checking prior to processing the transport rules. Also you cant apply transport rules to NDRs so you can't create a transport rules to forward ndrs that mention message exceeded.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Thursday, April 5, 2012 3:37 PM
  • Thanks for your reply 

    In this situation where we have implemented  receive size restrictions of 10MB, how can we recover those emails where the total size is over 10MB?

    We cannot allow emails larger than this, otherwise will increase store size considerably.

    Senders will generally not resize and resend the attachments.

    Or can we generate an NDR to the recipient, so they are aware of incoming emails oversize, so they can contact the sender.

    Thursday, April 5, 2012 4:07 PM
  • You can't recover, what typically happens during the SMTP session is the external SMTP server will request to declare the max message size of prior to sending the message. If if it the receiver rejects the message, your external sender's SMTP servers (not your server) sends the NDR back to their user.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Thursday, April 5, 2012 4:15 PM
  • Well, since you are capturing emails that are larger than 10MB, why not increase your users max receive size to your default (or set it to unlimited) and allow the Transport rule to redirect the email?  This would be easy to test, on one user, issue set-mailbox <MailboxID> -MaxReceiveSize 30MB.  After that, send a 20 MB attachment and see if it is redirected to your support mailbox and ensure it does not appear in the users mailbox.
    • Marked as answer by uklogistics Tuesday, June 26, 2012 4:13 PM
    Friday, April 6, 2012 1:52 PM
  • Is support@domain.com an internal mailbox or an external mailbox?


    Jim McBee - Blog - http://mostlyexchange.blogspot.com

    Saturday, April 7, 2012 12:11 AM
  • support@domain.com is an internal mailbox
    Saturday, April 7, 2012 8:45 AM
  • Hi

    Sounds like a good idea,

    Is there a command to adjust all mailboxes with increased receive mail size?

    Saturday, April 7, 2012 8:51 AM
  • Get-Mailbox | Set-Mailbox -MaxReceiveSize

    "The MaxReceiveSize parameter specifies the maximum size of messages that this mailbox can receive. You must specify either an integer or unlimited."

    http://technet.microsoft.com/en-us/library/bb123981.aspx

    That should do it but you might want to exclude certain mailboxes.

    Here's one example (with Get-User and -MaxSendSize) - also shows how the integer would look like (or you could use unlimited): 

    Get-User -Filter "Department -eq 'Customer Service'" | Set-Mailbox -MaxSendSize 2097152


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.



    Saturday, April 7, 2012 5:41 PM
  • Can you send an item larger than 10MB to that mailbox from another mailbox?


    Jim McBee - Blog - http://mostlyexchange.blogspot.com

    Saturday, April 7, 2012 5:48 PM
  • Can you send an item larger than 10MB to that mailbox from another mailbox?


    Jim McBee - Blog - http://mostlyexchange.blogspot.com

    I have sent an email with 15 MB attachment from a gmail account to that account (support) and i get the attachment. this mailbox is set to accept 30mb emails. Haven't tried sending a large email from another internal mailbox to support.

    Monday, April 9, 2012 2:25 PM
  • I had this transport rule working, and ever since we moved our mailboxes over to a blank mailstore ( for reducing physical file size of the store on disk) , this rule has stopped working.

     

    I'm sending 13mb emails from Gmail to mailbox with no restriction on max receive or send size, and the transport rule is not capturing the email, and redirecting.

    MaxSendSize                          : unlimited
    MaxReceiveSize                       : unlimited

    I have enabled pipline tracing , and it doesn't show anything  in particular to why this rule isn't working.Could moving the store have corrupted this rule?

     any ideas?

    thanks

    Tuesday, August 28, 2012 5:10 PM