none
ADFS 4.0 - Windows Integrated only works if Forms based auth is disabled RRS feed

  • Question

  • Hi All -

    I have a brand new build of a 2016 ADFS server which I am having some challenges with. I have worked with other versions of ADFS in the past and have not experienced these issues. The issue I am experiencing is related to Windows Integrated Authentication. When I have both it and Forms based auth enabled, I am forced to use Forms based. If I click on the 'Sign in as current user' link, not once but twice...then it automatically logs me in. If I disable forms based auth then WIA works as expected. I thought that Windows Integrated would take priority over forms based as it has with previous versions of ADFS. 

    I have updated my WIASupportedUserAgentStrings and all IE settings are in place. I also tried changing the order of the auth methods via the Set-AdfsGlobalAuthenticationPolicy. 

    Any other suggestions?

    Thursday, August 22, 2019 11:32 PM

All replies

  • Hi btrfly18420,

    I think you need to check that link?

    https://docs.microsoft.com/en-us/windows-server/identity/ad-fs/operations/configure-intranet-forms-based-authentication-for-devices-that-do-not-support-wia

    cheers

    Friday, August 23, 2019 4:50 PM