none
CipherSuiteOrder error after June 2016 2012R2 Rollup Update | GPMC Error

    Question

  • I'm having trouble viewing the settings of any GPO after i installed KB3161606 and receive the following error:

    If i uninstall the update, the problem disappears.  In looking at the ADMX and ADML files, it looks like after the update is applied, the CipherSuiteOrder.ADML file is updated, but the corresponding ADMX file is not.  Looking through the individual updates contained within KB3161606, it makes the most sense that KB3161639 is the specific update causing this issue.  

    I haven't seen this particular issue reported anywhere, so i thought i'd try here first, then go through MS Support since it appears that a Windows Update is the problem.  

    Additionally, KB3161639 says to go Computer Configuration>Admin Templates>Network>SSL Configuration Settings to configure the suite order, but these settings are not available after the update.  I'm presuming because of the incorrect ADMX files.


    See below for screen clips of various items before and after the update.  It does appear that policy is applying, i just can't see the settings in GPMC and i receive the same error when i open a GPO to edit it.

    Edit [note added]

    The original update was deployed through WSUS.  But I've also manually downloaded the roll-up update from the catalog and installed hoping there was an issue with the download from WSUS.  Unfortunately, the same error persists.   

    Any help resolving this issue would be great.

     

    Before Update KB3161606 Update is installed:

     

    ADML Folder:



     ADMX Folder before Update:


       

    Installed KB3161606 (Containing KB3161639)


    After installing KB3161606 and  Rebooting:


    ADMX Files:


    ADML Files:


    Thanks!




    Friday, July 15, 2016 7:45 PM

Answers

All replies

  • You've done absolutely excellent troubleshooting of this issue and reporting thereof.  The answer that I can offer is that at no cost to you, you may call MS Support and request a hotfix to this issue.  MS provides troubleshooting at no cost to the customer if the problem can be proved to be caused by a KB update.  You can simply forward them a link to this thread once you've opened up the case.  The description you provided here couldn't be more clear.  Excellent job. US-based Microsoft Technical Support:  (800) 642-7676

    https://support.microsoft.com/en-us/gp/customer-service-phone-numbers/en-us?wa=wsignin1.0#u


    Best Regards, Todd Heron | Active Directory Consultant


    • Edited by Todd Heron Saturday, July 16, 2016 9:59 PM
    • Proposed as answer by Jay GuModerator Saturday, July 23, 2016 11:22 AM
    Saturday, July 16, 2016 9:58 PM
  • Hi,

    Thanks for your post.

    I suggest you try to update the admx and adml file for your Administrative Templates.

    Here is a similar thread below for your reference.

    https://social.technet.microsoft.com/Forums/en-US/bac54114-54d7-472b-969d-9b08f28dbba9/error-when-selecting-administrative-template-in-any-gpo?forum=winserverGP

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 18, 2016 2:49 AM
    Moderator