none
Service DPMRA not start

    Question

  • I'm trying to install DPM agent to Windows 2008 SP2.. I've installed manually agent version 3.0.7706.0 but when I try to start DPMRA service I got this error :
    Windows could not start DPMRA on local computer. For more information review the system event log. If this is a non-Microsoft service, contact the
    service vendor and refer to service specific error code 1168 
    Do you have any solution for this problem? I have installed this agent on another Windows 2008 file server without problems.
    Thanks.
    Tuesday, November 15, 2011 11:09 AM

Answers

All replies

  • Hi, please check the Eventlog an post the message here.

     


    Seidl Michael | http://www.mbs.at | http://www.techguy.at
    Tuesday, November 15, 2011 1:15 PM
  • Hello,

    Yes the best place to start on this would be the event logs.


    Thanks

    Shane

    Wednesday, November 16, 2011 9:11 PM
  • Hi, please check the Eventlog an post the message here.

     


    Seidl Michael | http://www.mbs.at | http://www.techguy.at


    The service "DPMRA" is finished because of an internal error 1168 (0x490)

    log file dpmracurr:

    WARNING Failed: Hr: = [0x80070490] : F: lVal : OnServiceStartEvent()
    1064 25D0 11/18 09:43:20.583 03 service.cpp(298) [000000000010F9A0]  ACTIVITY CService::AnnounceServiceStatus
    1064 2880 11/18 09:43:20.583 31 dllmain.cpp(18)   NORMAL VssRequestorDLL: DLL_PROCESS_DETACH

    Friday, November 18, 2011 9:47 AM
  • Hi

    Try run the SetDpmServer -dpmservername [DPMSERVERNAME]

    SetDpmServer is used to configure the DPM Agents communication with an explicit DPM server. The Executable also fix the firewall rules that is needed.

    Run this from an elevated command prompt.

    Please post your progress.  


    Best Regards

    Robert Hedblom

    MVP DPM

     


    Check out my DPM blog @ http://robertanddpm.blogspot.com


    Friday, November 18, 2011 10:39 AM
    Moderator
  • Configuring dpm server settings and firewall settings for dpm server =[dpm.domen.local]
    Configuring dpm server settings and firewall settings for dpm server =[domen.local\dpm]
    SetDpmServer failed with errorcode =0x80070005, error says: Please make sure tha
    t you are a domain user with administrator privileges on this computer
    To further troubleshoot failures with SetDpmServer, go to  http://go.microsoft.com/fwlink/?LinkId=169142
    Friday, November 18, 2011 10:53 AM
  • Try to use an account who is domain admin when you preform this.

    Best Regards

    Robert Hedblom

    MVP DPM

     


    Check out my DPM blog @ http://robertanddpm.blogspot.com


    Sunday, November 20, 2011 8:33 PM
    Moderator
  • I install agent with domain admin rights
    Monday, November 21, 2011 8:34 AM
  • Is this perhaps a domain controller?

    Best Regards

    Robert Hedblom

    MVP DPM


    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Tuesday, November 22, 2011 1:04 PM
    Moderator
  • No. This is application server
    Tuesday, November 22, 2011 8:49 PM
  • Hi,

    maybe the UAC is enabled?

    regards


    Seidl Michael | http://www.mbs.at | http://www.techguy.at
    Monday, November 28, 2011 7:37 AM
  • Hi

    On your production server you will have two security groups (DPMRADCOMTrustedMachines and DPMRADmTrustedMachines). Please verify that your DPM server computer account is a memeber of those local security groups.

     


    Best Regards

    Robert Hedblom

    MVP DPM


    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Monday, November 28, 2011 12:54 PM
    Moderator
  • Hello,

    Do you still have this problem?


    Shane

    Saturday, December 3, 2011 5:31 PM
  • You have to completely stop de Windows Firewall service. Then it will work fine.
    Monday, June 3, 2013 10:28 AM
  • Closing this thread


    Best Regards

    Robert Hedblom

    MVP DPM


    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Monday, June 3, 2013 9:08 PM
    Moderator
  • hi Guys ,

    If this issues on Exchange server means follow the below steps 

    1) Go to services -> DRMRA ( put the Startup type as Automatic )

    2) Stop the MSExchangeServiceHost

    3) Start the DRMRA 

    4) Start the MSExchangeServiceHost

    Issues will get resolved 

    Thanks ( Dhana)

    Saturday, August 25, 2018 6:26 PM
  • Worked in 2019 ! Thanks
    Saturday, January 12, 2019 11:34 AM