locked
database parameter specified with the configdb command is invalid error RRS feed

  • Question

  • Im using:

    Windows server 2008 32 bit. SQL Server 2008 Enterprise. Sharepoint server 2007 Sp2.

    I am trying to runthe fllowing command but getting the error that follows:

    Psconfig -cmd configdb create -server "sername" database DBName user Domain\user password pswd admincontentdatabase SharePoint_AdminContent

    The database parameter specified with the configdb command is invalid.
    The database name located at the specified database server has an incorrect coll
    ation.  Rebuild the database with the Latin1_General_CI_AS_KS_WS collation or cr
    eate a new database using the Latin1_General_CI_AS_KS_WS collation.

    Can anyone tell me how to sort this out?

    Thanks.

    Wednesday, November 3, 2010 1:38 PM

Answers

  • Hi DingleB3rry,

    Please examine the Summary.txt (C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Logs) log file to verify that the rebuilding process completed or not.

    If it completed successfully maybe you could create two empty shell databases called: SharePoint_Config and SharePoint_AdminContent. Then give the appropriate permission to the databases and dbo permissions.

    After that, try to run psconfig -cmd configdb -create -server <SQLSERVERNAME> -database SharePoint_Config -user <Domain\User> -password <Password> -admincontentdatabase SharePoint_AdminContent again.


    Best regards. Emir
    • Marked as answer by Lily Wu Thursday, November 11, 2010 7:56 AM
    Monday, November 8, 2010 12:49 PM

All replies

  • Check your SQL server collation. Looks like SharePoint needs Latin1_General_CI_AS_KS_WS.
    Oleg
    Wednesday, November 3, 2010 2:18 PM
  • I had to reinstall SQL and change it during setup. I tried the following but it didnt work:

    Setup /QUIET /ACTION=REBUILDDATABASE /INSTANCENAME=Iname /SQLSYSADMINACCOUNTS=Dname\SQL /SAPWD= pwd /SQLCOLLATION=Latin1_General_CI_AS_KS_WS

    Thanks.

    Wednesday, November 3, 2010 3:20 PM
  • Hi DingleB3rry,

    Please examine the Summary.txt (C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Logs) log file to verify that the rebuilding process completed or not.

    If it completed successfully maybe you could create two empty shell databases called: SharePoint_Config and SharePoint_AdminContent. Then give the appropriate permission to the databases and dbo permissions.

    After that, try to run psconfig -cmd configdb -create -server <SQLSERVERNAME> -database SharePoint_Config -user <Domain\User> -password <Password> -admincontentdatabase SharePoint_AdminContent again.


    Best regards. Emir
    • Marked as answer by Lily Wu Thursday, November 11, 2010 7:56 AM
    Monday, November 8, 2010 12:49 PM