none
Can't connect securely to the page (This might be beacuse the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website's owner.) RRS feed

  • Question

  • We've often got the following error when we try to access to our internal web site from our workstations with Internet Explorer since a couple weeks ago.

    When we try to access to the same web site with Google Chrome, it can access with no problem.

    I have confirmed Internet Explorer setting on client workstation, and all TLS are enabled by group policy as follows. 

    I have also confirmed TLS configuration on registry keys of the web server, and TLS 1.1 and TLS 1.2 are both enabled. (TLS 1.0 are disabled to follow our security rule.)

    I contacted to the web server administrator, but he said he did not make any configuration change on his web server, and it should be something wrong on Internet Explorer configuration or network issue.

    One thing I found during troubleshooting is whenever I execute command ipconfig /flushdns with PowerShell, it can connect to the web site.

    However that connection error is coming back soon such as 30 mins or a couple of hours later.  This does not fix the cause of the problem.

    I've confirmed to ping and nslookup to the DNS servers, the web server, proxy server, and DHCP server from my client workstation during the connection error, but they are all good without showing any error.

    Please advise me if there is any configuration I should check on this matter. Any advise will be gratefully appreciated.

    Here are information of our environment.

    -------------------------------

    Client

    -------------------------------

    Windows 10 (version 1809)

    Internet Explorer 11 (version 11.9)

    -------------------------------

    Web Server

    -------------------------------

    Windows Server 2012 R2 Standard (version 6.3)

    Internet Information Services (version 8.5)


    • Edited by KELLY_IRVINE Friday, March 6, 2020 1:23 AM adding more screenshots
    Friday, March 6, 2020 1:02 AM

All replies

  • This may address the issue:

    1. Open Internet Options (From Start Menu, or from Gear icon in IE)
    2. Open Security tab
    3. Click Custom
    4. Locate Display Mixed Content (10th item down, under the heading Miscellaneous)
    5. Set to Enable
    Sunday, October 4, 2020 8:27 PM