locked
Microphone level adjusts itself RRS feed

  • Question

  • Greetings,

    Fresh install of Windows 7 Pro, SP1, 64 bit.  On-board RealTek HD audio device, latest drivers.

    Right-click taskbar speakers, select 'Recording Devices', right-click microphone, select 'Properties'.

    Click 'Levels' tab and leave that on screen.

    Now click 'Start', 'Control Panel', and 'Ease of Access'.  Next click 'Set up a microphone'.

    During this process, the microphone level slider will adjust itself.  Eventually, it will adjust itself down to zero.

     

    This makes it virtually unusable.  The computer will catch the first part of a sentence, then adjust the microphone to the point where it thinks you've stopped speaking.

    How can I stop this behaviour?  I have found no settings in either windows or my audio driver to stop it from automatically adjusting the microphone input level.  I have searched and found this problem listed in several places with no reliable solution.  There must be a way, and if you know what it is, let me in on it!

     

    Thank you for your time and assistance.

    Thursday, October 27, 2011 11:45 AM

Answers

  • Please download Windows 7 compatible driver from:

    Software: Drivers & Utilities
    http://www.realtek.com/downloads/downloadsview.aspx?langid=1&pnid=14&pfid=24&level=4&conn=3&downtypeid=3&getdown=false


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Thursday, November 3, 2011 3:37 AM
    Monday, October 31, 2011 7:45 AM
  •  

     

    • Marked as answer by Arthur Xie Thursday, November 3, 2011 3:37 AM
    • Edited by Wednesday, January 4, 2012 4:02 AM
    Monday, October 31, 2011 9:52 PM
  • I wonder if Windows might be trying (too hard) to adjust out hum from an analog mic. 

    I have a USB mic that doesn't pick up electrical noise in the wiring, and offers no Microphone Boost setting at all.  I used to have problems with hum myself before changing to this Logitech unit.  I'm told it made a noticeable audio quality improvement in Skype calls, with this mic described as making voice sound more "crisp".  It appears to be using the Windows generic USB Audio Device driver.

    -Noel



    • Edited by Noel Carboni Tuesday, November 1, 2011 3:58 PM
    • Marked as answer by Arthur Xie Thursday, November 3, 2011 3:37 AM
    Tuesday, November 1, 2011 1:00 PM

All replies

  • Out of interest I attempted to follow your lead to see if the same thing would happen on my system...

    I started the Ease of Access Center but there is no "Set up a microphone" entry right on that screen.  Did you neglect to list a step?  Or is my system showing something different from yours?

    -Noel

     

    Sunday, October 30, 2011 2:05 PM
  • Greetings Noel!  Thanks for the response, and yes, your system is showing something different from mine.

     

    From 'Start - Control Panel', when I click 'Ease of Access' ( the green one ), I get the following screen ...

     

    Monday, October 31, 2011 6:46 AM
  • Please download Windows 7 compatible driver from:

    Software: Drivers & Utilities
    http://www.realtek.com/downloads/downloadsview.aspx?langid=1&pnid=14&pfid=24&level=4&conn=3&downtypeid=3&getdown=false


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Thursday, November 3, 2011 3:37 AM
    Monday, October 31, 2011 7:45 AM
  • Perhaps Windows 7 Ultimate has a different organization here or something.

    I was able to find the "Set up microphone" dialog and go through it.  I was not able to reproduce the problem you described - my Microphone level stayed at 100.

    Arthur's advice is likely right on - you may need a driver update.

    As a side note, this windows speech recognition is pretty cool.

    -Noel

    Monday, October 31, 2011 5:08 PM
  •  

     

    • Marked as answer by Arthur Xie Thursday, November 3, 2011 3:37 AM
    • Edited by Wednesday, January 4, 2012 4:02 AM
    Monday, October 31, 2011 9:52 PM
  • I wonder if Windows might be trying (too hard) to adjust out hum from an analog mic. 

    I have a USB mic that doesn't pick up electrical noise in the wiring, and offers no Microphone Boost setting at all.  I used to have problems with hum myself before changing to this Logitech unit.  I'm told it made a noticeable audio quality improvement in Skype calls, with this mic described as making voice sound more "crisp".  It appears to be using the Windows generic USB Audio Device driver.

    -Noel



    • Edited by Noel Carboni Tuesday, November 1, 2011 3:58 PM
    • Marked as answer by Arthur Xie Thursday, November 3, 2011 3:37 AM
    Tuesday, November 1, 2011 1:00 PM
  • I've tried this with several different microphones and headsets, with the same results.

    My motherboard has the audio on board, so my drivers are from the Intel web site.

     

    Keep tryin' .. and thanks again.

     

    Sunday, November 6, 2011 12:59 AM
  • i can confirm that after following your instructions (downloaing and updating the driver), voice quality heavily improved and people on the other end could hear me very clearly. but still the volume of the mic is being adjusted automatically without my consent no matter what i do
    Saturday, January 25, 2014 3:51 PM
  • Skype will do auto level adjustment (and I believe has a checkbox to disable that if you want). Have you checked for settings in the program you're using to communicate with?

       

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Saturday, January 25, 2014 8:25 PM