locked
How to change Picture file location RRS feed

  • Question

  • Hi All,
     
    I have word 2010 Pro and need to change the default file location for the
    Insert Picture from file selection.  I have tried to find this in the Help
    files and have not been able to find anything that tells how to do this.  I
    have my default file location set to the drive and folder where I keep my
    data files, but, when I click on the insert picture icon on the QAT, or
    Ribbon icon, it goes to the Pictures folder in the User folder.  That is not
    where I keep my pictures and I always have to drill down to the correct
    folder.
     
    Can the default location be changed?
     
    Jan :)
     
     
    Saturday, August 21, 2010 10:02 PM

Answers

  • Hello Jan,

     

    Thanks for reporting the issue, Sally brought me in to review this.  I have submitted the issue to Microsoft developers so they are aware of the issue. 

     

    While this does not guarantee a fix to be created, it will be reviewed by our developers for future versions and sometimes updates.

     

    Adrian


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thanks!
    Adrian
    Microsoft Online Community Support
    • Marked as answer by Sally Tang Friday, September 3, 2010 9:42 AM
    Monday, August 30, 2010 9:01 PM

All replies

  • Hi Jan,

    This is my take based on experiment, not with any theory behind it...

    In Word 2007 and earlier, if you set the "Clipart pictures" item in Word's File Locations dialog, it set a value in the registry, PICTURE-PATH in the key HKEY_CURRENT_USER\Software\Microsoft\Office\<version>\Word\Options, and that's where the Insert Picture dialog would default.

    In Word 2010 running on Windows 7, you can set the dialog or directly set the registry value, and Word will happily IGNORE your wishes. The default appears to always be the Pictures library (not the My Pictures folder in the Users\<your name> location). I haven't been able to convince it that it shouldn't go there.

    The workaround -- definitely a second-rate one -- is to add your preferred location to the Pictures library. That is, in the Computer app, right-click the preferred folder, click Include In Library, and click Pictures. If you're lucky, the preferred location will appear somewhere near the top of the Insert Picture dialog, but you may have to scroll down to get to it.

    I hope I'm wrong, but I fear I'm right. :-(


    Jay Freedman MS Word MVP
    Sunday, August 22, 2010 12:13 AM
  • It doesn't work with 2010 on Windows XP either :(
    There is however an intriguing empty registry key
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Picture Manager
    PICTURE-PATH doesn't work in there either, but the key may provide the key ... as it were :)

    <Jay Freedman [MVP]> wrote in message news:3726f4bc-9903-4cb8-8ac3-46faabfbddc0@communitybridge.codeplex.com...

    Hi Jan,

    This is my take based on experiment, not with any theory behind it...

    In Word 2007 and earlier, if you set the "Clipart pictures" item in Word's File Locations dialog, it set a value in the registry, PICTURE-PATH in the key HKEY_CURRENT_USER\Software\Microsoft\Office\<version>\Word\Options, and that's where the Insert Picture dialog would default.

    In Word 2010 running on Windows 7, you can set the dialog or directly set the registry value, and Word will happily IGNORE your wishes. The default appears to always be the Pictures library (not the My Pictures folder in the Users\<your name> location). I haven't been able to convince it that it shouldn't go there.

    The workaround -- definitely a second-rate one -- is to add your preferred location to the Pictures library. That is, in the Computer app, right-click the preferred folder, click Include In Library, and click Pictures. If you're lucky, the preferred location will appear somewhere near the top of the Insert Picture dialog, but you may have to scroll down to get to it.

    I hope I'm wrong, but I fear I'm right. :-(


    --------------------------------------------------------------------------------
    Jay Freedman MS Word MVP


    Graham Mayor - Word MVP
    www.gmayor.com
    Posted via the Communities Bridge
    http://communitybridge.codeplex.com/
    Sunday, August 22, 2010 5:53 AM
  • Thanks for the feedback, Jay, I'll see how that works here.  I guess that
    previous capability is yet another User option that MS has decided is not
    necessary and should be removed.  I used to be be able to get to the folder
    in one click, and now it takes 5.  More progress, eh?  :-)
     
    Jan :)
     
    "Jay Freedman [MVP]" wrote in message
    news:3726f4bc-9903-4cb8-8ac3-46faabfbddc0@communitybridge.codeplex.com...
    > Hi Jan,
    >
    > This is my take based on experiment, not with any theory behind it...
    >
    > In Word 2007 and earlier, if you set the "Clipart pictures" item in Word's
    > File Locations dialog, it set a value in the registry, PICTURE-PATH in the
    > key HKEY_CURRENT_USER\Software\Microsoft\Office\<version>\Word\Options,
    > and that's where the Insert Picture dialog would default.
    >
    > In Word 2010 running on Windows 7, you can set the dialog or directly set
    > the registry value, and Word will happily IGNORE your wishes. The default
    > appears to always be the Pictures library (not the My Pictures folder in
    > the Users\<your name> location). I haven't been able to convince it that
    > it shouldn't go there.
    >
    > The workaround -- definitely a second-rate one -- is to add your preferred
    > location to the Pictures library. That is, in the Computer app,
    > right-click the preferred folder, click Include In Library, and click
    > Pictures. If you're lucky, the preferred location will appear somewhere
    > near the top of the Insert Picture dialog, but you may have to scroll down
    > to get to it.
    >
    > I hope I'm wrong, but I fear I'm right. :-(
    >
    >
    > --------------------------------------------------------------------------------
    > Jay Freedman MS Word MVP
     
     
    Sunday, August 22, 2010 5:53 AM
  • Well.....I guess all we need to do is figure out what to put in that key and
    we can open our own door.  Sounds challenging. :-))
     
    Jan :)
     
    "Graham Mayor [MVP]" wrote in message
    news:b2557219-a347-4848-b386-8bdd6cf453d9@communitybridge.codeplex.com...
    > It doesn't work with 2010 on Windows XP either :(
    > There is however an intriguing empty registry key
    > HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Picture Manager
    > PICTURE-PATH doesn't work in there either, but the key may provide the key
    > ... as it were :)
    >
    > <Jay Freedman [MVP]> wrote in message
    > news:3726f4bc-9903-4cb8-8ac3-46faabfbddc0@communitybridge.codeplex.com...
    >
    >  Hi Jan,
    >
    >  This is my take based on experiment, not with any theory behind it...
    >
    >  In Word 2007 and earlier, if you set the "Clipart pictures" item in
    > Word's File Locations dialog, it set a value in the registry, PICTURE-PATH
    > in the key
    > HKEY_CURRENT_USER\Software\Microsoft\Office\<version>\Word\Options, and
    > that's where the Insert Picture dialog would default.
    >
    >  In Word 2010 running on Windows 7, you can set the dialog or directly set
    > the registry value, and Word will happily IGNORE your wishes. The default
    > appears to always be the Pictures library (not the My Pictures folder in
    > the Users\<your name> location). I haven't been able to convince it that
    > it shouldn't go there.
    >
    >  The workaround -- definitely a second-rate one -- is to add your
    > preferred location to the Pictures library. That is, in the Computer app,
    > right-click the preferred folder, click Include In Library, and click
    > Pictures. If you're lucky, the preferred location will appear somewhere
    > near the top of the Insert Picture dialog, but you may have to scroll down
    > to get to it.
    >
    >  I hope I'm wrong, but I fear I'm right. :-(
    >
    >
    >  --------------------------------------------------------------------------------
    >  Jay Freedman MS Word MVP
    >
    >
    > --------------------------------------------------------------------------------
    > Graham Mayor - Word MVP
    > www.gmayor.com
    > Posted via the Communities Bridge
    >
     
     
    Sunday, August 22, 2010 6:20 AM
  • Hi,

     

    You can change the default picture location from Tools > Options > File Locations in Word 2003 and previous versions of Word programs. You can refer to this article for details:

    http://word.tips.net/Pages/T001614_Default_Picture_Location.html

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    In Word 2010, the option is here: Click File > Options > Advanced. Under General group, click the File Locations.. button.

     

    Hope it helps.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    Monday, August 23, 2010 6:25 AM
  • The option may be there in Word 2010 but Word ignores it!


    Graham Mayor - Word MVP
    www.gmayor.com
    Posted via the Communities Bridge
    http://communitybridge.codeplex.com/
    Monday, August 23, 2010 6:38 AM
  • Hi Sally, thanks for the information.  However, as Graham has posted, Word
    2010 does not accept or recognize the new location that I entered for the
    default Clipart pictures files, and I see no other option offered for
    pictures. Each time I click on Insert>Pictures icon on the Ribbon it opens
    in the User Pictures folder, not the folder I entered.  I have closed and
    reopened Word 2010 after setting the new location, and even rebooted, but,
    it still will not go to the new file location.
     
    I did make the file location change in the Word 2007, as it is in the same
    Options>Advanced>General>File locations tab area as in 2010, and it does
    recognize the selection and goes to the folder that I chose as the default
    location.
     
    Not sure why Word 2010 won't do the same.
     
    Jan :)
     
    "Sally Tang [MSFT]" wrote in message
    news:7d15d92f-54e7-4ae5-9a10-54ea54188660@communitybridge.codeplex.com...
    > Hi,
    >
    >
    >
    > You can change the default picture location from Tools > Options > File
    > Locations in Word 2003 and previous versions of Word programs. You can
    > refer to this article for details:
    >
    >
    > Please Note: Since the web site is not hosted by Microsoft, the link may
    > change without notice. Microsoft does not guarantee the accuracy of this
    > information.
    >
    >
    >
    > In Word 2010, the option is here: Click File > Options > Advanced. Under
    > General group, click the File Locations.. button.
    >
    >
    >
    > Hope it helps.
    >
    >
    >
    > Best Regards,
    >
    >
    >
    > Sally Tang
    >
    > TechNet Subscriber Support in forum
    >
    > If you have any feedback on our support, please contact
    > tngfb@microsoft.com
    >
     
     
    Monday, August 23, 2010 6:46 PM
  • It does here too, Graham.
     
    Jan :)
     
    "Graham Mayor [MVP]" wrote in message
    news:2b7de246-d789-43ff-967c-7f49f2f848ce@communitybridge.codeplex.com...
    > The option may be there in Word 2010 but Word ignores it!
    >
    >
    > --------------------------------------------------------------------------------
    > Graham Mayor - Word MVP
    > www.gmayor.com
    > Posted via the Communities Bridge
    >
     
     
    Monday, August 23, 2010 6:48 PM
  • Hi,

     

    Sorry, I have tested again:

    Change the path in File > Options > Advanced > General > File Locations.

    Change the path under: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word\Options\PICTURE-PATH

     

    The path can be changed by it does not take effect. I will escalate this thread to a high level engineer to see what happens.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com 

    Tuesday, August 24, 2010 6:39 AM
  • Thanks, Sally.  Will make the change as you suggest and see if it works.
    And thank you for elevating this issue to a higher up to see what is
    happening that the setting in the General is not working as it should.
     
    Jan :)
     
    "Sally Tang [MSFT]" wrote in message
    news:00f5727a-76d1-4d2e-8277-dd2c083dc2c9@communitybridge.codeplex.com...
    > Hi,
    >
    >
    >
    > Sorry, I have tested again:
    >
    > Change the path in File > Options > Advanced > General > File Locations.
    >
    > Change the path under:
    > HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word\Options\PICTURE-PATH
    >
    >
    >
    > The path can be changed by it does not take effect. I will escalate this
    > thread to a high level engineer to see what happens.
    >
    >
    >
    > Best Regards,
    >
    >
    >
    > Sally Tang
    >
    > TechNet Subscriber Support in forum
    >
    > If you have any feedback on our support, please contact
    > tngfb@microsoft.com
    >
     
     
    Tuesday, August 24, 2010 10:19 AM
  • I checked the HKey setting for the PICTURE-PATH and it is showing the new
    path that I changed the default File location to, but, it does not go to
    that folder when I click the Picture icon.  So, something is not working
    properly.
     
    Jan :)
     
    "Sally Tang [MSFT]" wrote in message
    news:00f5727a-76d1-4d2e-8277-dd2c083dc2c9@communitybridge.codeplex.com...
    > Hi,
    >
    >
    >
    > Sorry, I have tested again:
    >
    > Change the path in File > Options > Advanced > General > File Locations.
    >
    > Change the path under:
    > HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word\Options\PICTURE-PATH
    >
    >
    >
    > The path can be changed by it does not take effect. I will escalate this
    > thread to a high level engineer to see what happens.
    >
    >
    >
    > Best Regards,
    >
    >
    >
    > Sally Tang
    >
    > TechNet Subscriber Support in forum
    >
    > If you have any feedback on our support, please contact
    > tngfb@microsoft.com
    >
     
     
    Tuesday, August 24, 2010 10:28 AM
  • Hello Jan,

     

    Thanks for reporting the issue, Sally brought me in to review this.  I have submitted the issue to Microsoft developers so they are aware of the issue. 

     

    While this does not guarantee a fix to be created, it will be reviewed by our developers for future versions and sometimes updates.

     

    Adrian


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thanks!
    Adrian
    Microsoft Online Community Support
    • Marked as answer by Sally Tang Friday, September 3, 2010 9:42 AM
    Monday, August 30, 2010 9:01 PM
  • Hello,

     

    Was there ever a fix for this?  I'm trying to configure this now and having the same issue!

     

    Thanks.

    Thursday, May 5, 2011 2:39 AM
  • Well, it's September 2011.. and no fix for this.. Only an MS Article saying theres no fix and to use a work around:

    http://support.microsoft.com/kb/2582721

     

     

     

    Monday, September 12, 2011 8:26 PM
  • It ignored it for me too, Graham. I have set that several times for the specific folder where I want to keep my pictures and it will still go to the Pictures folder.

    Monday, September 12, 2011 11:34 PM
  • Thanks, Sally. Thanks for your time and help.  I have tried that, but, as Graham has also mentioned, that setting will not hold. It seems that Word somehow does not recognize that setting and does its own thing. That is why I posted my question, as I thought they may be some trick to getting it to work. 
    Monday, September 12, 2011 11:37 PM
  • Hi Adrian, thank you for stepping in for this issue. I am hoping that they can/will fix this problem soon.

    One big reason that I want to use a different folder is that I do a lot of custom graphics using PowerPoint, and have at any given time at the least 1000's of clipart, pictures and custom images, and I keep them stored on a separate external drive and not on my machine. I also back then up to an external backup drive. So I want to use that folder on that specific drive as the File Location for my pictures and images, not the one on my C:\ drive.

    As all the components and configurations appear to be in place, I get the feeling that it is not that they intentionally discontinued this feature, but, that it somehow got changed when something else was changed or removed that might have affected it in some way that it can no longer function properly.  It will let you change it, but, it just will not hold or recognize the change.

    As you can imagine, this function gets a lot of use by me, and having to constantly go through the routine to keep navigating to the correct folder every time I want to insert an image or picture is extremely time consuming, as well as frustrating. When I am being paid by the hour by a client to create a Presentation or custom graphic project, this makes it more time consuming for me and more costly for my client. While I want to use the updated features of Office 2010, I have to do my work in Office 2007 for client work in order to save valuable time and costs to the client.

    So, for me, it is not a simple thing. And it may also be a problem for others but who have just simply gone back to an older version to save time and frustration than speaking up, or just dealing with having everything piled on their C:\ drive. That for me is just not practical file storage or cost effective.

    I am in hopes that the dev team can find a way to address this issue soon. I am sure I would not alone in my appreciation of their efforts to do so.  :-)


    • Edited by Jan Ilacqua Monday, September 12, 2011 11:55 PM
    Monday, September 12, 2011 11:52 PM
  • While the work around does provide for access to the folder with your pictures, it requires that special folder to be located on the C:\drive in the Pictures folder.  It will not work if the folder is located on another drive, which is how I store all my 1000's of pictures and clipart.  As long as you have your pictures folder located on the C:\ drive in the Pictures folder it may be a workable workaround. But, in my case, I have all my data and pictures/images in folders on other storage drives, so that workaround is not going to resolve the problem for me. 

    It just seems like there is a short circuit someplace in that function.

    Tuesday, September 13, 2011 3:37 AM
  • I tried the same and this seems to work for me. I created another folder (I called mine Screenshots) where I had all my pictures. I then created a library and added that folder as the location for that library. I then went to properties for the pictures library and added the screenshots folder and Set save location.

    Then when you click on Insert Picture from Word 2010 it will show you two locations by default, the original pictures folder location and the new one I added. As I only want to see the screenshots folder I made by default I went back to the properties for Picture library and removed the default pictures library location folder from the list of folders, it then only showed the contents of my screenshot folder whenever I clicked on insert picture in word 2010.

    This is probably the closest you will get, I agree each library needs a set default save location settings in word options.

    Monday, September 10, 2012 5:52 AM
  • This is probably the closest you will get, I agree each library needs a set default save location settings in word options.

    Thank you aredubbya, I will give this a try and see if it will work here. It has been some time since I first posted this issue, and still no fix. :)  I had hoped that maybe it would have gotten fixed in Office 2013, but, so far as I have been able to find out it hasn't. So, I gather that they are not going to fix it. It would truly be nice if they would stop and think of those who have to use their software and not just the 'cloud' stuff they seem to feel is all the users care about. But, most of us Users live in the real world, not the 'cloud' world, and there are things that are far more important to us who use the software every day in the real world.

    Thank you again for your time to assist with the issue, and I will post back if your solution works here.

    Jan :)

    Monday, September 10, 2012 7:32 AM
  • Hi Jan,

    I'm using Office 2013 Release Preview, and the old method -- setting the Images value in the File Locations option dialog, or setting the value of the PICTURE-PATH entry in the HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Word\Options key -- works correctly. I can set the location to a folder on my K: drive, and the Insert Picture dialog goes there by default.


    Jay Freedman
    MS Word MVP  FAQ: http://word.mvps.org

    Friday, September 14, 2012 2:43 PM
  • Thanks for the update on the new version, Jay. Glad to hear that it will work as it always has in the 2013. I truly appreciate your time and help.  :-)
    Saturday, September 15, 2012 12:13 AM
  • Thank you!  That worked and worked well.
    Wednesday, October 3, 2012 3:05 PM
  • I know it has been some time since this post and I can concur that Word 2010 now uses the PICTURE-PATH variable when Insert Picture is used.  

    However I have another add-on for this problem.  Word 2010 has an option when one right clicks on a picture that says "Change Picture".  This is used to update a picture or replace the picture with a different one.  I can say that Word 2010 does not seem to recognize the PICTURE-PATH variable in this operation and defaults to the user's Library Pictures directory.  

    Can the same people (developers?) who sorted the last issue please work on this one too?

    Many Thanks

    Tuesday, January 28, 2014 3:53 AM
  • Hi Laurie,

    While some of the suggestions here might be workable for some of the more advanced users, the average user would not likely be able to work through them. And even then, only to find that they don't even work.

    MS really does need to do a fix for this. Not every user can afford the upgrade, and some companies can't as well. So the responsibility is on MS to fix their product so that it behaves as it should for the User, not only how MS wants it. I am really surprised that, after all this time, someone has not yet found a fix for this that works. I can't believe that it is rocket science, and there is no means to fix it. But, MS really should step up and take the responsibility to fix their own software. I am still using Office 2010 and there has been no known fix for it yet. And at year 2014, I'd say it is about time they did.

    Tuesday, January 28, 2014 4:23 AM