locked
Cannot start Windows Firewall RRS feed

  • Question

  • I've been scouring this forum and every other one I can find to try to figure out why Windows Firewall will not start on my machine. I recently realized it wasn't on when I went to set up a shared printer and couldn't do it. I have no idea when it turned off or if it was ever even on.

    When I open Control Panel\System and Security\Windows Firewall it says:

    Update your Firewall settings.
    Windows Firewall is not using the recommended settings to protect your computer.

    The obvious attempt to click Use Recommended settings button results in a big, fat nothing. The cursor responds by displaying the rotating blue circle, but nothing else ever occurs. If I try clicking on Turn Windows Firewall on or off, I am directed to the same page as described above.

    Again, clicking Use recommended settings results in the same nothing.

    If I attempt to open Windows Firewall with Advanced Security (running as administrator) I get the following error messages:

    There was an error opening the Windows Firewall with Advanced Security snap-in
    Windows could not start the Windows Firewall on Local Computer. For More information, review the System Event Log.

    When I attempt to "Start" Windows Firewall from the properties menu in Services.msc, I get this error message:

    The Windows Firewall with Advanced Security snap-in failed to load. Restart the Windows Firewall service on the computer that you are managing. Error code; 0x6D9.

    I have verified that the log on account is set to Local Service.

    I have reset the security on the service to what it should be after building the OS.

    I have tried using command lines to start the service. (Netsh firewall set opmode enable)

    I have reset the server using elevated command prompt (netsh winsock reset), including restarting my machine.

    I have tried disabling my antivirus software (Avast), but I still get the same error messages.

    I have run the following programs in both regular and Safe mode:

    MicrosoftFixit.WindowsFirewall.RNP.21285263321247188.2.1.Run
    MicrosoftFixit50884
    msert
    mssstool64
    I have also run sfc /scannow

    None of these can find ANY malware or any other issues.

    Anyone else have any idea what might be going on?

    Thursday, February 28, 2013 12:29 AM

Answers