locked
Problems deploying image to HP Elitebook 820 w/Dual HD/Raid Mini SSD RRS feed

  • Question

  • I am attempting to image a machine that has a standard 500 GB drive as well as a 32GB Mini SSD drive.  By default it's set to RAID in the BIOS which doesn't work for me, it crashes out event before the MDT toolkit stage....I can get it to go further in the task sequence by switching it to AHCI.  i performed a diskpart setting the main SATA drive as the primary partition then select image.  it gets all the way to the point in the TS when it begins to apply the image then it crashes out with error 80070032.  I triple checked and made sure that I have all necessary drivers imported into sccm.  Any ideas on how to get this working properly?  If I physically remove the mini ssd it images, applies drivers (so it says) then crashes then dumps out an incomplete image with missing drivers, software and such.  Thanks in advance
    Thursday, February 20, 2014 2:57 PM

All replies

  • How about installing the OS you're trying to deploy by hand and then use this tool:

    http://gallery.technet.microsoft.com/ConfigMgr-Driver-Injector-aae7d17d

    And then create a driver package out of those and use it with your deployment.

    Thursday, February 20, 2014 3:05 PM
  • Is it Windows 7 or Windows 8/8.1 that you are trying to image it with?

    We have the same in our environment, 8/8.1 no issue. Windows 7 I have to use a different boot image with the HP Win PE 4 drivers in it to make it work.


    Steve O'Connor

    MCP MCITP MCSA

    My Blog

    Thursday, February 20, 2014 3:09 PM
  • Windows 7 deployment sorry
    Thursday, February 20, 2014 3:15 PM
  • It's a bit of a nightmare with windows 7 and HP SSD raid setup.

    Here's what I did - created a new boot image. Downloaded the win PE 4 drivers, injected them. I also downloaded the driver pack for the model from HP, injected them into the boot image as well. Your looking for the IntelDesktop/Workstation/Server Express Chipset SATA RAID controller.

    That worked for me. I then imported a machine manually and deployed a Win 7 TS to it. The Raid setup worked fine.


    Steve O'Connor

    MCP MCITP MCSA

    My Blog

    Thursday, February 20, 2014 3:21 PM
  • Only the Win PE 3 drivers are avail for my setup and I'd already tried importing those in as well as the the full driver pack and am still running into issues.
    Thursday, February 20, 2014 4:37 PM
  • Try the method I mentioned... install the full os (according to PE version you're using, W7 = WPE31, W8 = WPE4, W81 = WPE5), install the needed drivers and use the tool I mentioned and grab the needed drivers.
    Thursday, February 20, 2014 5:52 PM
  • Don't forget, the drivers you are injecting into your WinPE disk need to match the WinPE environment that the boot image was built from, not the image you are trying to lay onto the machine. So for instance you may be pushing Win7 but the WinPE image is built from Win8. You need to inject Win8 compatible drivers into it so that while in the PE environment it can communicate with the hardware. During the WinPE part of the imaging it should push the Win7 drivers to the machine and install those. That way, when the machine reboots into the OS, Win7 can resume communication and Task Sequence execution.

    Dustin Estes - MCP | www.dustinestes.com

    Thursday, February 20, 2014 6:56 PM
  • Thanks.  The boot image and Win PE are both Win 7 32bit but my image is Win 7 64bit.  
    Thursday, February 20, 2014 7:05 PM
  • What does your Task Sequence look like, specifically the steps below:

    • Is it the BIOS or UEFI based "Partition Disk 0" step?
    • Are you stating that the drive to image should be the "Disk Number 0"? If so, have you tried to move it up to 1 and see if it grabs the right drive?

    Dustin Estes - MCP | www.dustinestes.com

    Thursday, February 20, 2014 8:48 PM
  • That's a point are you trying to build it in UEFI mode with windows 7?

    I haven't been able to build new HP's in UEFI mode (with CSM selected in BIOS), the build TS still partitions the drives for BIOS not UEFI no matter what I did. You may have the same issue. 


    Steve O'Connor

    MCP MCITP MCSA

    My Blog

    Friday, February 21, 2014 9:13 AM
  • Thanks for the responses.  I am certain at this point that it is NOT the boot image.  I think it is not a driver issue since all the drivers for the machine are in fact in the driver database.  The BIOS is set for Legacy boot mode (not UEFI w or w/o CSM).  I am not sure where/how to toggle this in the TS but the partition step is set for disk 0.  I tried setting it to disk 1 and got the same result.  Keep in mind that this is all when I have the BIOS set to AHCI mode.  When I set BIOS to RAID it crashes out immediately at apply image.  Right now the drives arent raided
    Friday, February 21, 2014 3:32 PM
  • Did you try my method?

    1. Configure your HW like you would when doing the deployments
    2. Install the OS that matches your WinPE version (by hand)
    3. Install the needed drivers
    4. Grab the drivers of the installation
    5. Inject the SCSI drivers to your WinPE
    6. Test

    Friday, February 21, 2014 3:56 PM
  • I tried that using the driver injector but the SCSI driver would error out when importing into the boot image.  Have drives raided now and as soon as I select image to apply when trying to image it errors out with error 0x80070032
    Monday, February 24, 2014 4:48 PM
  • How about this:

    • Create a standard package that contains the SCSI driver (and all its associated files, .sys etc.)
    • Use the prestart method for your boot image to load the driver from the package you created: "drvload yourdriver.inf"


    • Edited by Narcoticoo Monday, February 24, 2014 5:46 PM
    Monday, February 24, 2014 5:46 PM
  • Thanks for the response but when I try that I get the same result.  A blank drvload cmd window pops up briefly when I initiate a policy search, disappears then when I select my image it errors out after trying the loading windows preinstallation environment
    Monday, February 24, 2014 6:32 PM
  • Have you tried loading the driver by yourself (enable cmd support f8 in your boot image)?

    Monday, February 24, 2014 6:42 PM
  • Yep tried it manually and we are still getting the same result
    Monday, February 24, 2014 7:24 PM
  • ...And if you install the OS by hand, you can get this working out of the box?

    Monday, February 24, 2014 7:29 PM
  • With the drives raided, when I attempt to put a fresh copy of windows the setup doesn't see any drives until I load my raid driver which is to be expected.  However, it wont let me install windows on the disk because it states that the computer's hardware may not support booting to the disk.  Only when I go into the BIOS and switch to AHCI can I do any fresh installing/imaging but that defeats the point.  
    Monday, February 24, 2014 7:43 PM
  • Says setup is unable to create a new partition or locate an existing system partition...perhaps thats my problem?  Oh and this is after I have used diskpart to partition the raid volume
    • Edited by krdell Monday, February 24, 2014 7:48 PM
    Monday, February 24, 2014 7:45 PM
  • In your original post you mention that there is a drive with 500gb and one with 32gb. Are you actually intending to RAID together two drives with this different of a size?

    If you get to the part of the manual install where you are supposed to choose your partition/drive and you can load your drivers successfully you should see a drive choice list. Do you see this? Can you format the partition? Create new partitions?


    Dustin Estes - MCP | www.dustinestes.com

    Monday, February 24, 2014 8:19 PM
  • I'm actually attempting to install the image onto the larger 500 gb disk using the 32 SSD as a flash cache using Intel Rapid Storage technology...this is how the machines arrive and I'd like to be able to image it keeping this config intact.  I believe the large hd is accelerated with the 32 being used for flash using a raid config.  

    yes, Once i load the driver i just see the one partition there and can format it but cannot add new partition or install windows to it.

    Monday, February 24, 2014 8:32 PM
  • You really should check the configuration of the delivered machine... How the BIOS settings are, how the disk is configured, how the boot settings are configured and so on...

    Tuesday, February 25, 2014 6:38 AM
  • I'm actually attempting to install the image onto the larger 500 gb disk using the 32 SSD as a flash cache using Intel Rapid Storage technology... 


    I've never attempted something like this. However, we did just receive our demos for the HP hardware including these new 820s. Have you seen HPs driver packs? They are handy trimmed down packages targeted at delivering drivers for G1 models, G2 models etc... They are pretty good. I was able to add a pack for all our demos, target all the models with the same pack in the TS and they all installed everything just fine. Including validity drivers, 3D Storage and touchpad as well without having to run the EXEs. Maybe give this pack idea a shot. It could be that you are missing some on the initial install and communication can't occur properly with the drives and the raid card. http://www8.hp.com/us/en/ads/clientmanagement/drivers-pack.html

    Dustin Estes - MCP | www.dustinestes.com

    Tuesday, February 25, 2014 12:42 PM
  • Yeah getting the associated driver packs and such imported into my driver DB was something I did even before unboxing the machine.  Your 820s have the standard and 32GB SSD flash cache drives in them?

    Considering I cannot even get a manual install of WIN 7 on the 500 GB but only the 32GB SSD tells me that there is something specific to the way that the drives are configured whether that be in the BIOS or other.  Going to call HP on this I guess.   


    Tuesday, February 25, 2014 1:20 PM
  • Your 820s have the standard and 32GB SSD flash cache drives in them?

    No sorry, ours do not. I was only trying to suggest the driver packs were far more complete and targeted than they used to be. There may be some "optional" drivers you need to find from the actual models page instead of just the driver pack as the pack may only contain drivers for "standard" builds. It's a long shot but couldn't hurt to look I guess.

    Considering I cannot even get a manual install of WIN 7 on the 500 GB but only the 32GB SSD tells me that there is something specific to the way that the drives are configured whether that be in the BIOS or other.  Going to call HP on this I guess.  

    My next suggestion was going to be that. Sometimes HP puts out whitepapers on the models and how to perform certain tasks like this. That may be an option.

    Also, a quick search brought to this link. It may be of some use. It mentions not only installing the raid drivers (im assuming LSI) but also installing additional SAS/SATA drivers. I think this is because not only does it communicate with the RAID controller but also the drives. Worth a shot I guess.

    EDIT: I meant install these drivers into the BOOT as well as add them to the Driver install step in the TS. Also, try updating both your 32-bit and 64-bit BOOT WIMs. Seeing as you're laying down a 64-bit OS you would really be using the 64-bit BOOT as well.

    If you do come across the answer please don't forget to update this post. I know most will find it helpful and seeing as I don't know where my current client is going with this hardware after the demo, it may even help save me some time too :-)


    Dustin Estes - MCP | www.dustinestes.com



    • Edited by Dustin Estes Wednesday, February 26, 2014 2:59 AM clarity
    Wednesday, February 26, 2014 2:55 AM
  • Thanks.  HP hasn't been much help.  I'm also gonna submit a ticket with MS. I'll update this thread with any real developments.  Any further ideas are welcome also.
    Thursday, February 27, 2014 6:01 PM
  • Good morning,

    Any news on this? Same configuration and same problems as you were reporting here.

    Thanks for keeping us updated.

    Tuesday, May 20, 2014 2:58 PM
  • Nope, was never able to get this working properly so we stopped trying and stopped trying and used standard imaging rather than the hybrid/RAID configuration
    Tuesday, May 20, 2014 3:34 PM
  • Still not further information on this issue ?

    It seems i ran into the same problem and want to solve it.

    When creating a bootimage from SCCM 2012 it works from PXE but not from USB (same image as PXE although put on USB stick).

    Tuesday, August 5, 2014 2:15 PM