none
RDS Farm unable to login

    Question

  • I created another collection in my RDS Farm and added a single RDS Host. The idea here is that users will use the desktop of this machine not published apps.

    I created the collection using a single security group which I created just for this collection

    I then added one user to the security group (they are a member of no other groups except domain users)

    I then attempted to remote login through the connection broker and get the following error. 

    "The connection was denied because the user account is not authorized for remote login"

    It appears that the connection broker is not passing the login through to the session host, but instead treating it as if it wants to login to the connection broker itself. Not sure what I have done wrong here. It clearly says on server manger "Remote Desktop is published for the users of the collection."

    Note the user can remote directly to the RDS host and login, but the point is to have it go through the broker as it's IP is the only one available outside the LAN. 



    Lee

    Thursday, July 12, 2018 12:31 PM

Answers

  • Launch the tsclient app and placing the computer url in the connection box.

    Lee

    Please try using RD Web Access or Remote Resources (Mac, iOS, Android, UWP) or RemoteApp and Desktop Connections (in Control Panel or configure via GPO).  These are the intended methods for launching connections to RDS deployments.  By using one of this techniques a .rdp file with proper settings will be used for each connection.  One of the settings in the .rdp file is a hint (loadbalanceinfo) for the target collection which will be sent to the broker during the connection so that the broker can determine which RDSH to redirect the user to.

    Thanks.

    -TP

    • Marked as answer by Lee Taylor Monday, July 16, 2018 12:04 PM
    Thursday, July 12, 2018 2:36 PM
    Moderator

All replies

  • Hi,

    How precisely are you attempting to launch the connection to the collection?  Are you using the icon published for the new collection in RD Web Access, or Remote Resources, or RemoteApp and Desktop Connections?  These are the intended methods.  You could also manually download the .rdp file for the collection by using non-IE browser and save it to desktop.

    -TP

    Thursday, July 12, 2018 2:28 PM
    Moderator
  • Launch the tsclient app and placing the computer url in the connection box.

    Lee

    Thursday, July 12, 2018 2:30 PM
  • Launch the tsclient app and placing the computer url in the connection box.

    Lee

    Please try using RD Web Access or Remote Resources (Mac, iOS, Android, UWP) or RemoteApp and Desktop Connections (in Control Panel or configure via GPO).  These are the intended methods for launching connections to RDS deployments.  By using one of this techniques a .rdp file with proper settings will be used for each connection.  One of the settings in the .rdp file is a hint (loadbalanceinfo) for the target collection which will be sent to the broker during the connection so that the broker can determine which RDSH to redirect the user to.

    Thanks.

    -TP

    • Marked as answer by Lee Taylor Monday, July 16, 2018 12:04 PM
    Thursday, July 12, 2018 2:36 PM
    Moderator
  • Hi,

    How things are going there on this issue?

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 16, 2018 3:06 AM
    Moderator