locked
WSUS Console Connection Problem RRS feed

  • Question

  • I'm having a problem getting the WSUS console to connect to the server.  The server is running Windows Server 2008 SP2.  When I try to connect, I get the error message "Cannot connect to 'servername'.  The server may be using another port or different Secure Sockets Layer settings."  I have installed numerous time and then noticed on your forum that WSUS is a role with Server 2008 SP2.  I was having this problem with WSUS 3.0 SP1 and Server 2008 SP1.  This is one reason why I upgraded to Server 2008 SP2.  I thought it may fix this problem.  My last install I kept it very simple by not using SSL and using Port 80.   I have gotten this error message on every installation try..."An unexpected error occurrred, and this wizard must be closed.  You may restart the WSUS Server Configuration Wizard from the Options page in the WSUS 3.0 console."  I get this error message right at the very end of install.  The install seems go well.  When I check the Server Manager, it reads 2 of 18 rolls installed listing Web Server (IIS) and Windows Server Update Services.  IIS looks good, but WSUS has the red "x".  It gives a 7053 error message with this text...
    Application Source:        Windows Server Update Services
    Date:          6/8/2009 3:12:49 PM
    Event ID:      7053
    Description: The WSUS administration console has encountered an unexpected error. This may be a transient error; try restarting the administration console. If this error persists, Try removing the persisted preferences for the console by deleting the wsus file under %appdata%\Microsoft\MMC\.
    System.InvalidOperationException -- Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.
    The request failed with the error message:
    ---
    I have deleted the file mentioned in the error message, but no luck.  The Server Manage also shows 6 services Running, 1 Stopped.  The services that are running are...
    Application Host Helper Service
    Background Intelligent Transfer Service (BITS)
    IIS Admin Service
    SQL Server (MSSQL$DARIT_SQLServer)
    Update Services
    World Wide Web Publishing Service (W3SVC)
    The stopped service is...
    WSusCert Server

    I have worked on this for over a week.  I'm not sure where to go.  If I need to uninstall and start over, what is the best way to remove WSUS since it is a built in role with Server 2008 SP2?  Any help is greatly appreciated.

    Joe

    Monday, June 8, 2009 8:35 PM

Answers

  • Hi Joe,

    Yes, if your server is Windows Server 2008 SP2, you can remove it as role just like DNS DHCP.

    If your server is Windows Server 2008 SP1, you need to un-install WSUS from "Programs and Features"
    • Marked as answer by DARITC Friday, July 10, 2009 8:48 PM
    Thursday, July 9, 2009 10:35 AM

All replies

  • Hi,

         I am not sure but check Terminal Server setting to accept client license.What setting you have..?


    Regards,
    Sachin
    Wednesday, June 10, 2009 7:50 AM
  • Hi,

    Which account did you use to run the remote console?

    Also, I'd like to confirm whether the remote console is in the same domain with the WSUS server
    Wednesday, June 10, 2009 10:33 AM
  • Hi,

    Is the problem resolved?

    Also, please check the WSUS website setting in IIS and make sure the port setting is correct
    Monday, June 15, 2009 10:51 AM
  • Sorry for the delay.  I was out of the office. I did not have the Terminal Services role added.  It is now, and the General Settings reads...
    Delete temporary folders on exit: Yes
    Use temporary folders per session: Yes
    Ristricted each user to a single session: Yes
    User logon mode: Allow all connections.

    I still get the same error message.
    Tuesday, June 16, 2009 7:05 PM
  • It's a user account with administrator rights.  They are in the same domain.  Thanks. - Joe
    Tuesday, June 16, 2009 7:06 PM
  • No.  I checked and it's set for port 80.  Thanks. - Joe
    Tuesday, June 16, 2009 7:07 PM
  • Hi Joe,

    On your WSUS server, please givie "network service" the write access to c:\WINDOWS\Microsoft C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files folder.

    Also, could you please install WSUS remote consoel on another computer, and check whether it can connect to WSUS server
    Wednesday, June 17, 2009 10:52 AM
  • Eric, I applied the rights as you suggest. These rights were missing.  To make sure I had both bases covered, I applied this rights change on both the Framework and Framework64 folders and below.  Unfortunately, I still can not connect.  I get the same message.  (One note, we have a server currently running WSUS.  This server in question is going to replace the current WSUS server.  This should not be a problem...should it?  We have the group policy pointing clients to the current WSUS server.  I have a 32-bit virtual Server 2008 running WSUS whose console connects just fine. Just thought I'd mention it.)  Thanks for the help. -  Joe
    Thursday, June 18, 2009 6:37 PM
  • Hi Joe,

    Please check the following folder permission:

    1. The root folder of the local content directory must have at least Read
    permissions for the Users security group and the NT Authority\Network Service
    account. In other words, if the WSUS content directory is C:\Updates\WSUSContent,
    the Updates directory must have the correct permissions. The BITS service will fail
    if these permissions are not set.

    2. The content directory itself (in the above example, the WSUSContent directory)
    must have Full Control permissions for the NT Authority\Network Service account.

    3. The %TEMP% directory (usually %windir%\TEMP) must have Full Control permissions
    for the NT Authority\Network Service account.
    Wednesday, June 24, 2009 10:39 AM
  • Eric, I did need to make these rights changes.  I made them yesterday and double checked my work today.  I still can't get the console to work.  I tried it from another computer's console too.  I have the WSUSContent folder residing on the D: data drive.  Is this a problem?  I just don't understand it.  I have it simplified to port 80 and the firewall is completely off.  Do you have any other ideas?  I do appreciate the help.  -  Joe
    Friday, June 26, 2009 6:50 PM
  • Hi Joe,

    I found this error in your original post:

    Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'


    This error will occur on a Windows Server 2008 system if dynamic or static compression is enabled for the WSUS web site.

    To correct this error, use the following steps:

    1. Open the Intenret Services Manager MMC
    2. Click on the server name node at the top of the left-hand tree and choose
    "Modules"
    3. Right-click on DynamicCompressionModule and choose "Unlock"
    4. Right-click on StaticCompressionModule and choose "Unlock"
    5. Click on WSUS Administration to select it and choose Modules
    6. Right-click on DynamicCompressionModule and choose "Remove"
    7. Right-click on StaticCompressionModule and choose "Remove"
    8. Run IISReset and re-open the WSUS Administration console
    Wednesday, July 1, 2009 10:35 AM
  • Hey Eric,  I was able to do steps 1 thru 4, but I do not have a "WSUS Administration" listed in the Internet Information Services Manager.  I do not see it in the left or right pane.  The only WSUS item I see is "Selfupdate" under the Default Web Site.  I tried it after making these partial changes and it still will not work locally or from a remote W/S.  Thanks.  -  Joe
    Wednesday, July 1, 2009 5:26 PM
  • Hi Joe,

    When you installing WSUS, if you choose use default website, then WSUS administration website will not created.

    So the step 5 should be click on "Default Web Site"
    Thursday, July 2, 2009 3:44 AM
  • Eric, I made these changes with unfortunately no luck.  In the Server Manager, the WSUS role has a red "x".  May be if I share more of the log it will help.  Here is how it reads...
    1.) Yellow Warning: Log Name: No client computers have ever contacted the server.
    2.) Red "!": The Report Web Service is not working.
    3.) Red "!": The API Remoting Web Service is not working.
    4.) Red "!": The Server Synchronization Web Service is not working.
    5.) Red "!": The Clent Web Service is not working.
    6.) Red "!": The SimpleAuth Web Service is not working.
    7.) Red "!": The DSS Authentication Web Service is not working.
    8.) Red "!": (I then get the large message that is in first entry above.)

    The event log cycles through these messages.  All messages have a time stamp of 2:16PM.  The last is time stamped at 2:43PM.  I'm not sure how much this helps, but thought I'd send it to you just in case.  Sorry this is such a pain.  I orginally had this problem when I installed WSUS 3.0 SP1 on Server 2008 SP1.  I then upgrade to SP2 hoping that would fix the problem.  I don't know if this has complicated the issue.  Thanks for all your help.  -  Joe
    Thursday, July 2, 2009 8:07 PM
  • Hi Joe,

    The following reason may cause these symptoms:


    1. The permissions are set incorrectly on the Default Web Site, and the WSUS
    Health Monitoring service cannot communicate with the web services.


    2. The server was originally installed on port 8530, but then manually moved to port 80, and the WSUS Health Monitoring service is still looking for the services on the port 8530 virtual server.

    In either of these two cases, the first place to start is with the registry values in the keyHKLM\Software\Microsoft\Update Services\Server and verify that all registry values are configured with the correct URL(s).

    3. Windows Sharepoint Services was installed on the WSUS Server, and is now blocking access to the WSUS resources -- however, in this instance you would also have the concurrent symptoms that none of the clients are updating either. (Have you determined whether the clients are successfully detecting and updating?)

    If the above steps didn't work, then my next suggestion is uninstalling WSUS (keeping the database and content), and then reinstalling
    WSUS, to ensure the installation and setup are correct.
    Friday, July 3, 2009 10:55 AM
  • Hi Eric, Number 2 is the issue.  I did move between these two ports, but it was more to fix the problem.  May be I made it worse.  A couple of notes: I checked under the registry key and could not find any URLs.  I compared this with our current WSUS server running on Server 2003, and I do not see any URLs there.  I also checked a test virtual Server 2008.  Again I didn't see any URLs.  The other note is I don't have a WSUS Health Monitoring service.  Would this be listed in the Administrative Tools Services or is this a different type of service?  To uninstall WSUS on Server 2008, I take it that it's simply removing the WSUS role, restarting the server, and reapplying the role.  True?  Thanks. - Joe
    Tuesday, July 7, 2009 6:48 PM
  • Hi Joe,

    Yes, if your server is Windows Server 2008 SP2, you can remove it as role just like DNS DHCP.

    If your server is Windows Server 2008 SP1, you need to un-install WSUS from "Programs and Features"
    • Marked as answer by DARITC Friday, July 10, 2009 8:48 PM
    Thursday, July 9, 2009 10:35 AM