none
DPMSync failed to load RRS feed

  • Question

  • We use MABS v2 build 12.0.332.0 with MS SQL 2016 and SMSS 16.5.1

    It appear we cannot run DPMSync, see the error below:

    "DpmSync 2.0 - DPM database synchronization command-line tool
    Copyright (c) 2013 Microsoft Corporation. All rights reserved.

    Error ID: 50503
    SQL Server Management 2014 tools not installed on this machine.
    1) Please install SQL Tools from installation media.
    2) For more details about SQL Server tools go to http://msdn.microsoft.com/en-us
    /data/hh297027."

    The problem is that the error message is not clear so I tried to install:

    1. SQL Server Data Tools (SSDT) for Visual Studio 2017.

    2. SSMS 18.02 (latest).

    3. SSDT for VS2015 17.4.

    Nothing helped and I still see the same error. Any ideas will be appreciated.

    Thank you.

    Wednesday, July 31, 2019 6:51 PM

Answers

  • Leon, thank you for the message. I tried both cmd and MABS Mgmt Shell, and I was tried run as administrator as well: didn't change match.

    So I opened a support ticket with MS and during remote session technician installed MS Mgmt Studio for MS SQL 2014 Express (https://www.microsoft.com/en-US/download/details.aspx?id=42299, see MgmtStudio 64BIT\SQLManagementStudio_x64_ENU.exe) and was able to run DPMSync. It appear that DPMSync itself uses SQL 2014 Mgmt runtimes.

    • Proposed as answer by Leon Laude Monday, August 5, 2019 2:55 PM
    • Marked as answer by bokashovv Monday, August 5, 2019 3:16 PM
    Monday, August 5, 2019 2:51 PM

All replies