none
This advertised application will not be installed because it might be unsafe. Contact your administrator to change the installation user interface option of the package to basic. RRS feed

  • Question

  • Hi there,

    I was wondering whether anyone could tell me which feature in Windows 7 produces this message "This advertised application will not be installed because it might be unsafe. Contact your administrator to change the installation user interface option of the package to basic." and whether it can be turned off in Windows to prevent this message from appearing when installing certain programs that aren't WHQL certified. At first I thought it was the UAC control that generated this message but found out that it wasn't and then thought it was the DEP control and found out that it wasn't this either. I'm only seem to be getting this message when installing FileDirector Component Service Version 3 on a few of our workstations which is an add-on that allows file integration with Office and is part of FileDirector WinClient Version 3.

    Your help would be much appreciated.

    Many thanks,

    RocknRollTim

    P.S. I know of a way to bypass this message but would ideally not like to have the feature turned on and for the message not to be appear for non WHQL certified program installations in order to make non WHQL certified program installations in the future much easier, more simpler and straightforward to carry out. I was redirected by a moderator off the Microsoft Community Forum.
    Saturday, October 4, 2014 3:49 PM

Answers

All replies

  • Hi,

    You can try following options to disable this prompt, but we don't recommend you to do so since this feature helps you to protect your computer.

    Option 1: Run command as admin:

    bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
    bcdedit -set TESTSIGNING ON

    Restart your computer to apply changes.

    Option 2: Disable in GPO:

    1.Type gpedit.msc in the Run dialog and press Enter.

    2.In the Group Policy Editor, navigate to User Configuration → Administrative Templates → System → Driver Installation.

    3.Double-click on Code signing for device drivers in the right-side pane as shown above.
    4.In the windows that opens, choose Enabled. In the Options, choose Ignore as shown. Then click on the OK button to save the settings.

    Restart your computer to apply changes.


    Kate Li
    TechNet Community Support

    Monday, October 6, 2014 9:54 AM
    Owner
  • Hi Kate Li,

    Thank you for responding to my thread and for posting this info, I'll refer to this as a reference and thank you for all your help.

    Many thanks,

    RocknRollTim

    Tuesday, October 7, 2014 7:00 AM
  • Hi,

    You can try following options to disable this prompt, but we don't recommend you to do so since this feature helps you to protect your computer.

    Option 1: Run command as admin:

    bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
    bcdedit -set TESTSIGNING ON

    Restart your computer to apply changes.

    Option 2: Disable in GPO:

    1.Type gpedit.msc in the Run dialog and press Enter.

    2.In the Group Policy Editor, navigate to User Configuration → Administrative Templates → System → Driver Installation.

    3.Double-click on Code signing for device drivers in the right-side pane as shown above.
    4.In the windows that opens, choose Enabled. In the Options, choose Ignore as shown. Then click on the OK button to save the settings.

    Restart your computer to apply changes.


    Kate Li
    TechNet Community Support

    Hi Kate Li,

    I hate to inform you but the commands didn't get rid of the message, any other suggestions?

    Kind regards,

    RocknRollTim

    Tuesday, October 7, 2014 6:48 PM
  • Hi,

    You can try following options to disable this prompt, but we don't recommend you to do so since this feature helps you to protect your computer.

    Option 1: Run command as admin:

    bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
    bcdedit -set TESTSIGNING ON

    Restart your computer to apply changes.

    Option 2: Disable in GPO:

    1.Type gpedit.msc in the Run dialog and press Enter.

    2.In the Group Policy Editor, navigate to User Configuration → Administrative Templates → System → Driver Installation.

    3.Double-click on Code signing for device drivers in the right-side pane as shown above.
    4.In the windows that opens, choose Enabled. In the Options, choose Ignore as shown. Then click on the OK button to save the settings.

    Restart your computer to apply changes.


    Kate Li
    TechNet Community Support

    Unmarked as Answer based on OP's request. 

    https://social.technet.microsoft.com/Forums/en-US/35ab1279-c3a1-46be-9f7d-45e8606c1410/this-advertised-application-will-not-be-installed-because-it-might-be-unsafe-contact-your?forum=w7itproappcompat


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, October 14, 2014 10:23 PM
    Moderator
  • Thanks arnavsharma
    Sunday, November 16, 2014 3:24 PM
  • Case closed, sorted issue.
    • Marked as answer by RocknRollTim Wednesday, March 29, 2017 11:09 AM
    Wednesday, March 29, 2017 11:09 AM