none
Microsoft VM is not visible in Internet Explorer 11 Advanced Settings. RRS feed

  • Question

  • Hello all,

    I am having a website that requires changing the Microsoft VM (Java Permissions) settings to be "Low safety".

    This options by default will be there in IE settings if there is Java installed on the PC which is running on Windows 7. My current problem is that I cannot find these options in IE settings if it is a 64-bits architecture! They are exactly the same PCs with all the same software and Java versions but these options are only visible in the 32-bits architecture. Is there any way to create them in the 64 bits PCs? That website I talked about earlier will only work if I change the safety to Low which is not available at all in the 64 bits architecture.

    Thank you.

    Wednesday, September 6, 2017 9:50 AM

Answers

  • Hi,

    .... you do realize that Java applets are depreciated? you should only continue to support/develop with them on legacy intranet websites where replacing them with html5 replacements (canvas, svg, scripting)is not feasible.

    If you are maintaining a legacy intranet site that is using Java applets, make sure that your developer profile and IE security zone settings are mapping your development website to the Intranet zone.

    If you are developing for a public access website... I highly recommend that you remove the Java JRT dependencies (Java JRT is an ActiveX control in MSIE browsers) and replace the functionality with canvas, svg and scripting....

    Java JRT (from Oracle) has its own control settings...

    Start>Control Panel>Java JRT.

    Where you can adjust its security settings or link to their support and documentation.

    you should ensure that you have the latest version of Java JRT installed from java.com.

    For testing and production purposes you should ensure that you are accepting your company's default IE security zone settings... Internet Options>Security tab, click "Reset all zones to default".

    see the links provided for "blocking out of date activex controls"

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^


    Thursday, September 7, 2017 10:17 PM

All replies

  • Hi Mina,

    assuming you are using an intranet site which you cannot give the address of, otherwise please include links to the website that you are having problems with your questions.

    Please use the File>Properties menu in IE to list the properties of your web site and confirm that it is mapped to the IE INTRANET zone....

    By default sites that map to the IE Intranet zone, use only a 32bit tab versions of activeX controls (like Java JRT)....

    If your un-named website is mapped to the Internet security zone, then it will by default run only x64 extensions (activex) on x64 CPU's and x86 extensions on x86 CPUs.

    Problems can also occur with Java JRT because of blocked content (ActiveX filtering and blocking of out of date ActiveX controls)

    Please also post back with

    1. the IE security zone that the site maps to (expected Intranet)

    2. Details of any error messages or warnings you are seeing.

    Please see also

    https://docs.microsoft.com/en-au/internet-explorer/ie11-deploy-guide/troubleshoot-ie11

    https://docs.microsoft.com/en-au/internet-explorer/ie11-deploy-guide/out-of-date-activex-control-blocking

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    Wednesday, September 6, 2017 9:37 PM
  • Hi Rob,

    I have already prepared some screenshots to post along but I couldn't because my account needs to be verified.

    Anyway, you can find the link as below:

    https://adcbtest.uat.fx.com/admin.html

    The error that I get normally is "An add on for this site failed to run".

    The change that I made was in the Internet zone, I selected "Low Safety" under Microsoft VM (Java permissions).

    My problem focuses on the missing of Microsoft VM (Java permissions) in the IE settings, I really cannot find it on any 64bits PC. If you have a 32 bits PC and try to access that website, it will display the page properly but after few seconds another Java window has to open to put in your credentials. If you have 32 bits and you change the Microsoft VM (Java permissions) settings as I said earlier, that java window will come. If you have 64 bits PC, you will not find these settings to change, therefore the Java window will never be displayed.

    Thanks




    • Edited by Mina Wadiee Thursday, September 7, 2017 5:29 AM
    Thursday, September 7, 2017 4:23 AM
  • Hi,

    .... you do realize that Java applets are depreciated? you should only continue to support/develop with them on legacy intranet websites where replacing them with html5 replacements (canvas, svg, scripting)is not feasible.

    If you are maintaining a legacy intranet site that is using Java applets, make sure that your developer profile and IE security zone settings are mapping your development website to the Intranet zone.

    If you are developing for a public access website... I highly recommend that you remove the Java JRT dependencies (Java JRT is an ActiveX control in MSIE browsers) and replace the functionality with canvas, svg and scripting....

    Java JRT (from Oracle) has its own control settings...

    Start>Control Panel>Java JRT.

    Where you can adjust its security settings or link to their support and documentation.

    you should ensure that you have the latest version of Java JRT installed from java.com.

    For testing and production purposes you should ensure that you are accepting your company's default IE security zone settings... Internet Options>Security tab, click "Reset all zones to default".

    see the links provided for "blocking out of date activex controls"

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^


    Thursday, September 7, 2017 10:17 PM