Windows 8.1 pro update from 8 pro error message 0xc0000017


  • Creating a dedicated thread:

    I'm having a problem trying to install windows 8.1 pro from windows 8 pro with an ssd and separate drive.  8 gigs of ram and 19GB free space on the SSD. Here is the error message I get upon reboot from app store installer:

    your pc needs to be repaired there isn’t enough memory available to create a ramdisk device error code: 0xc0000017

    Thursday, October 17, 2013 10:59 PM

All replies

  • Same issue here though I have more disk space and less RAM.  That doesn't seem to be the real issue.  It seems to be a conditional boot to continue the 8.1 install.  Hitting F9 seems to remove the condition and allow 8.0 to boot normally, as does simply turning off power at the error message and restarting.  So the good news is it doesn't seem to be in danger of bricking your computer or device, but the installation stops.

    You can restart the installation, but progress seems to be lost and it loops right back to the reboot and error message (4 times now on my machine).  You can tell because the progress bar on the Windows store install is set back to around 60% when you restart the installation, but it is closer to 80% (just subjective of course) when the reboot is requested by the install.

    Friday, October 18, 2013 12:33 AM
  • I'm getting the exact same thing. Right after the reboot it blue screens. I have 4GB of ram and the bios detects it all fine.
    Friday, October 18, 2013 3:48 AM
  • Same issue, 8gbs of ram, and tons of HDD space...
    Friday, October 18, 2013 3:58 AM
  • Same issue, 4GB of RAM

    Could someone at MS please answer??

    • Proposed as answer by EzzyBlack Friday, October 18, 2013 5:56 AM
    • Unproposed as answer by EzzyBlack Friday, October 18, 2013 5:56 AM
    Friday, October 18, 2013 5:29 AM
  • OK I have some hope here now.  I'll explain how I got it to work, but I can't pin down why it works exactly.

    The installation is doing a few things.  Obviously downloading the install files, then it collects data on your system and (I think) stores it in a configuration file somewhere for the actual installation.  Finally it issues a reboot call to reboot into the install program as if it were a new operating system.

    I tried several times to restart the install from the App store.  At one point I also tried to auto-repair Windows, when that didn't work it offered to boot another operating system.  When I did this, it showed 5 instances of the Win 8.1 install boot.  Luckily, they all pointed to the same place, but once this is all done, a clean up of your boot.cfg may be in order to remove the extra entries.

    Seeing that I decided to go for a long shot, I re-imaged my system from a backup, once again restarted the install from the Windows Store (this time it had to download it again, obviously).  After that the install went without a hitch.

    There are only two ideas I have on why this worked.

    1. Between the time the image was created and the system state when I tried to install 8.1 I installed an unsigned driver.  Note that installing an unsigned driver in Win 8 is not an easy thing to do, you can't accidentally do it, you have to jump through some hoops to make it happen.  So if you are scratching your head, this isn't your problem (it may not have been mine, I'm not sure).  One must do a special reboot in Windows 8 and specifically turn off driver signing pre-boot to install an unsigned driver, you would definitely know if you did it.  But, perhaps, as much as 8 hates unsigned drivers, it really throws the 8.1 install for a loop.  If you have installed unsigned drivers, removing them might be your ticket.

    2. I've seen this error before.  It happened during some hardware issues I had (tracked down to a bad memory module now removed.)  In the troubleshooting process that day I quite literally took my PC apart and put it back together.  Still I got the insufficient memory error when I tried to boot the system after removing the failed DIMM (note this error did not occur with the bad DIMM installed, the system wouldn't even POST).  Again, that day it was solved by re-imaging the system.  My thoughts on this were that I actually had issues with the hard drive.  Re-imaging the drive formats it, re-writes bad sectors, and finally does a bit-for-bit rewrite.  The latter can have the effect of refreshing the drive somewhat in sectors that haven't been written to in a long time.  Perhaps there was more to it, but I honestly couldn't, at the time, come up with any changes I'd made to the system as a whole that would cause a failure to boot, and trying various system restore points didn't work, even restore points previous to the date of the drive image.  Something in the imaging process itself repaired the drive it seemed.  Note everything in (2) happened with just 8 a few months back.

    So I have 8.1 installed now, I know how I got there, I'm just not sure just why the solution worked.  If you have a backup image, go for it, if not I'd suspect something HDD related if you haven't experimented with unapproved drivers (mine was a PAX driver for a Soundblaster X-Fi that has less than stellar Win 8 support).

    Hope this helps guys!

    Friday, October 18, 2013 6:19 AM
  • similar here (I had to retirn to 8.0):

    You cannot vote on your own post

    I have this problem too, Lenovo Thinkpad X220 (4287-2SG,I5-2520M,8GB RAM, mSATA SSD RENICE X3 120GB , second harddrive: ST320L)

    WIndows 8 system is on mSata SSD 57,4GB is free on SSD.

    Laptop probably freezed during upgrade to 8.1 (from MS store today) after asking if I want to store photos on Skydrive, screen was clear I waited one hour and manually switched laptop off.

    Jiri Cvrk

    Friday, October 18, 2013 6:52 AM
  • I am also experiencing this error. I have plenty of RAM and no reason to suspect any aspect of my computer would be insufficient to run 8.1. Also, unlike some of the posters here I do not have an SSD.
    • Edited by Harelin Friday, October 18, 2013 7:15 AM
    Friday, October 18, 2013 7:11 AM
  • Same problem on a system with 12 GB of RAM and a 512 GB SSD with tons of space and 2 other 1 TB SATA hard drives. There's absolutely no way the system doesn't have enough memory!
    Friday, October 18, 2013 7:15 AM
  • Hi, 

    Thanks for your sharing and efforts put on this issue. 

    This will definitely benefit others who encounter the similar issue as yours. 


    Kate Li

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Friday, October 18, 2013 11:38 AM
  • Didn't work for me
    Friday, October 18, 2013 3:54 PM
  • I have also run into this problem. I have 4GB RAM with a SSD system drive and a RAID 0 drive, both with plenty of room. I can only use the F9 option on the blue screen, which reboots back to Win8 and aborts the 8.1 install. I tried it twice before giving up and am now waiting for a solution or workaround.
    Friday, October 18, 2013 4:54 PM
  • for anyone wondering, updating the bios and uninstalling the "classic shell" start button did not work as I continue troubleshooting.
    Friday, October 18, 2013 5:48 PM
  • Same problem here. Have 16 Gb RAM and 1 TB hdd. Tried at least 5 times but failed.
    Friday, October 18, 2013 6:24 PM
  • 4 GB de RAM and 50 of 118 free GB on SSD.

    Install from Store, the progress is ok, but when reboot :

    "0xc0000017 No hay memoria suficiente para crear el..."

    Friday, October 18, 2013 6:28 PM
  • I  have the same problem too. Memory check is OK.

    C-drive: windows 7

    G-drive: Windows 8

    Boot menu with Windows 8 as standard.

    Upgrade succeeded on virtual machines but not on the machine above.

    Sunday, October 20, 2013 9:15 AM
  • I found out that maybe my nvidia motherboard chipset and/or memory controller driver might be causing it.  Several other people with nvidia chipsets have the same problem:

    I also tried to install from usb and it got further but failed:

    Sunday, October 20, 2013 10:29 PM
  • Same issue with Nvidia Nforce 780i SLI MO, with 16G of Ram, and 2TB C drive with more than 1.6TB free space
    Monday, October 21, 2013 4:23 PM
  • Hello,

    Can someone post the logs under those two folders for download?

    C:\$Windows.~BT\Sources\Panther and C:\$Windows.~BT\Sources\Rollback

    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, October 23, 2013 4:36 PM
  • you want a copy of both logs from those two folders?
    Thursday, October 24, 2013 6:10 PM
  • heres a link to all of the log files in those two folders. i hope this is what you were looking for:!143&authkey=!AOh7vjA3ZJIKevw

    Thursday, October 24, 2013 9:42 PM
  • The above post is a link to the logs of the failed response. It is not an answer.

    I'm having the same issue with a Asus Striker motherboard with a NVIDIA nForce 680i SLI chipset. It does seem to be connected to the nforce chipsets as can be seen here.... (apologies for not posting it as a link but apparently it wont let me as it needs to verify me but offers no guidance in here or my profile on how to do that)

    Did you have a chance to review the log files Darrel Gorter?

    Saturday, November 02, 2013 12:22 PM
  • I agree. I have exactly the same installation issue (code: 0xc0000017) with an Asus PC 4GB mem.

    Is this thread closed?

    Saturday, November 09, 2013 4:45 PM
  • I tried EzzyBlack's approach and made a system image (using 'windows 7 file recovery' from the configuration screen). I also made a system recovery disk using a USB-drive.

    However, when trying to re-image my system using the mentioned backup, I couldn't get it to work.
    First I tried to do this using the usb-drive as boot device. I could select the system image I wanted to restore, but when it initialized I got the error message 'This image was created on a system with BIOS firmware. You are now running EFI'. After that the recovery couldn't continue. The message is strange, because I made the backup 1 day ago with the exact same hardware that is available now (my mobo runs UEFI, but it did that when I made the backup as well). 

    On my second attempt, I used Windows 8 advanced boot options (clicking 'reboot' while holding shift). Ironically, this time I couldn't even select the desired backup to restore and got the error message: 'Not enough space to create a RAM-disk. Error code 0xC0000017'. This is the same message I get when I try to install Windows 8.1...

    Windows 8 is installed on an SSD (Samsung EVO 830) (I'm starting to believe the SSD is the problem), with parts of the backup on a normal HDD in a different partition.

    Is there any way to be able to restore backups and/or install 8.1 while avoiding the mentioned problems?

    Tuesday, December 17, 2013 5:55 PM
  • I have same problem in a fresh installation booting from usb flash
    Tuesday, March 11, 2014 11:58 AM