none
WebAnalyzer RRS feed

  • Question

  • Hi

    I have installed FAST with 1 admin server and 2 non-admin servers. In my event log on the admin server as well as the syslog - all.log file I am getting the following error repeatedly:

    [2010-09-27 14:44:13] WARNING   : configserver@servername:13250: systemmsg: Module (WebAnalyzer) at servername.FQDN:13300 is not responding

    the nctrl status shows:


    Module Name                     Process Name               PID  Status
    ------------------------------  --------------------  --------  --------------

    Config Server                   configserver              2428  Running
    Content Distributor             contentdistributor        2692  Running
    FDMWorker                       fdmworker                 3592  Running
    Indexing Dispatcher             indexingdispatcher        2108  Running
    Name Service                    nameservice               1388  Running
    Document Processor              procserver_1              3984  Running
    Document Processor              procserver_2              4008  Running
    SAM Admin                       samadmin                        Running
    SAM Worker                      samworker                       Running
    Automatic spellcheck tuning     spelltuner                3916  Running
    SPRel                           sprel                     3864  Running
    WALinkStorerReceiver            walinkstorerreceiver      3772  Running
    WALookupDB                      walookupdb0               3684  Running
    WebAnalyzer                     webanalyzer               3816  Running

    Everything seems to check out. Any ideas as to what could be causing this?

     

    Thanks

     

    Monday, September 27, 2010 10:26 PM

All replies

  • Hi,

    This beasicallu means that Web Analyzer is not responding to Config server calls. Do you still see this error. If so,

    1. Can you restart all FAST servers and see if you still get this error

    2. Use Waadmin command(showstatus option) and let s know what you see.

    3. Is WA installed on single server or distributed on two servers. Look for any errors in the Web analyzer log file on the servers

    4. Can you also paste the deployment.xml here?

    Thanks

    Monday, March 28, 2011 2:49 AM
    Moderator
  • I have the same error.  i try restarting the server, restarting the webanalyzer process but doesnt work...

     

    • this is the Waadmin showsatus:

    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\>Waadmin showsatus
    Traceback (most recent call last):
      File "C:\d\cruise\builds\active\common\webanalyzer\src\waadmin.py", line 907,
    in ?
      File "C:\d\cruise\builds\active\common\webanalyzer\src\waadmin.py", line 898,
    in main
      File "C:\d\cruise\builds\active\common\webanalyzer\src\waadmin.py", line 550,
    in __init__
      File "C:\d\cruise\builds\active\common\webanalyzer\src\waadmin.py", line 68, i
    n make_wa_connection
    NameError: global name 'StringUtils' is not defined


     

    • WA is installed on single server

     

    Any idea to solve this?

     

     

    Thanks!

     

     

     



    Thursday, May 12, 2011 7:20 PM
  • I'm having a similar error.  

    Event log has Event 1000 and WebAnalyzer not responding.

    WAADMIN showconfig or showrun but get:

    Error: Could not connect to WebAnalyzer

    Here is my deployment file:

    <?xml version="1.0" encoding="utf-8" ?> 
    <deployment comment="2 node FAST Search farm configuration" xmlns="http://www.microsoft.com/enterprisesearch">
     <instanceid>FASTSearch</instanceid> 
     <connector-databaseconnectionstring /> 
     <host name="Fast01.deltaeducation.local">
      <admin /> 
      <indexing-dispatcher /> 
      <content-distributor /> 
      <webanalyzer server="true" link-processing="true" lookup-db="true" /> 
      <document-processor processes="2" /> 
     </host>
     <host name="Fast02.deltaeducation.local">
      <searchengine row="0" column="0" />
      <query /> 
     </host>
     <searchcluster>
      <row id="0" index="primary" search="true" /> 
     </searchcluster>
    </deployment>

    I'm able to feed documents into my configuration and find them, however the crawls don't appear to be adding any documents.

    Tuesday, May 17, 2011 9:43 PM