locked
Cant Connect to Cube - Moved my workspace and cube to another server RRS feed

  • Question

  •  

    Hi there. I backed up my analysis services cube and restored it on another server.  I can connect easily to this cube on the new server with Excel 2007.

     

    I edited the server URL and can connect to the pmService sucessfullly on the new server.  Next I edited the data source for the cube I am using in this workspace (i just reference one cube) and once I put the correct server in the "server" textbox, I was able to choose my cube from the database dropdown menu.  However, when I test the connection I get...

    "

    The PerformancePoint Server could not connect to the specified data source. Verify that either the current user or application pool user has Read permissions to the data source, depending on your security configuration. Also verify that all required connection information is provided and correct.

    "

     

    I checked my application pool user and its my Administrator account (not network service right now).  This is the account which I am logged into and from which I connected to this same cube with Excel.  I also tried using the same connection string from my Excel 2007 connection to this cube - still no luck.

     

    Any ideas why I cant connect?  What have I missed?

     

    Thanks,

    Friday, February 15, 2008 1:39 AM

All replies

  • Hi TimW,

     

    Have you traced your SSAS server to double-check which user is trying to make the connection? I realise that you have confirmed the administrator account is configured in the app pool but please try tracing just to be absolutely sure.

     

    By the looks of your post you may well have read this post which details some troubleshooting tips, but I just wanted to include it, just in case.

     

    Cheers,

    Nick

     

    Friday, February 15, 2008 3:10 AM
  • Hi Nick, thanks for the link - I read your post.  It was really helpful for general understanding.  I ran SQL Server Profiler (my first time though) and limited the events to security and then clicked the "test connection" link.  I got results for a Audit Login, 2 Discover End, Session Initialize, 2 more Discover End and an Audit Logout.  The NTUserName associated with these profiler trace entries was alway Administrator.  

     

    Still no luck connecting.  Is there anything from the Trace that could give more clues...there lots of other data from the trace but it doesn't look too useful.

     

    Friday, February 15, 2008 3:31 AM
  • Tim,

     

    Did the trace show that the account returned an error when trying to connect?

     

    If you have moved your workspace and cube to another server you need to be sure that you set the Server URL (DD Options) within the workspace file to point towards the new monitoring server too.

     

    Another thing to think about if your OLAP and DB servers are on different machines is to use a domain account in the App Pool identity. Simply using Network Service or Administrator won't cut it when you're trying to communicate across different machines.

     

    Cheers,

    Nick

     

    Friday, February 15, 2008 3:59 AM
  • I am not good at reading Traces but I didn't see any errors in the XML associated with the trace records generated in SQL Server Profiler. 

     

    The good but confusing news is that I can get the connection string to work - it would have worked before too had I remembered to choose the cube to connect to in the drop down below the connection string.

     

    Still no luck with the "Use Standard Connection" connection setting.  I agree that a domain account is what will be better in the long run.  Right now we are setting up a standalone dev machine. 

     

     

     

    Friday, February 15, 2008 4:07 AM
  • It sounds like the App Pool account has the right access otherwise you would have seen an Error EventClass in the trace that says something along the lines of:

     

    Either the user, <AppPoolIdentityAccount>, does not have access to the <YourOLAPDB> database, or the database does not exist.

     

    You said that your connection string worked. Can you please post that so that I can have a look. Have you got any roles defined on the cube?

     

    Cheers,

    Nick

    Friday, February 15, 2008 5:03 AM
  • Absolutely.   Here's the connection string..

     

    Provider=MSOLAP.3;Persist Security Info=True;User ID=Administrator;Initial Catalog=gasdemo3;Data Source=ONLINE-99C3D89A;MDX Compatibility=1;Safety Options=2;MDX Missing Member Mode=Error

    You can see I am using the Administrator account here as I and I am logged on to ONLINE-99C3D89A as Administrator.   The cube has two roles.  One is "Admin" with both Administrator and Network Service as members.  The other is called "Role" with everyone as members.  When I traced using the connection string I would get  "*, role, admin" in the TextData trace attribute.  I tried "admin", "role" (and blank) using the standard connection but no luck there.

     

    Friday, February 15, 2008 5:15 AM
  • Okay, we're missing something here. Let's go back to the beginning.

     

    You had a solution that was working. You "moved my workspace and cube to another server". Can you detail exactly what you did. Did you move the monitoring server too? You also mentioned that this was a standalone install; does that mean the working configuration was based on a standalone installation on one server which you then moved lock-stock-and-barrel to another server with a new standalone install?

     

    I'm sure the answer to this is right in front of us but really can't get a handle on it until we know precisely what changed from the working configuration to the broken one. I would say it's certainly a permissions issue, we just have to find out where.

     

    Cheers,

    Nick

    Friday, February 15, 2008 9:56 PM
  • Sure.  I have a VPC image with a sql server cube  and a PPS workspace that is standalone.  I moved the workspace file ( .bswx) to and cube to another server (its actually a virtual server...).   I did not move anything else over to the new virtual server.  The new Server has a new install of sql server 2005, PPS and Sharepoint.

     

    1. I backed up the cube on the VPC image.  I copied the backup to the new Virtual Server and restored the cube on the new Server.  I then tested my ability to connect to the cube with Excel - all on the new server.  The connection worked fine.
    2. I copied the .bswx to the new virtual server.  I opened it up, and followed directions here http://support.microsoft.com/kb/942560 to edit the workspace that I copied to the new Virtual Server.  Those edits were essentially changing the server URL and changing data source connection information  so it was pointing to the right server and cube. 
    3. I tested the connection and it didn't work using the standard connection...
    4. Next I copied the connection string that was used for the Excel connection to the cube and put used that for connectivity to the cube.  This works fine.

    Because Excel connects to the cube using the Administrator account, and this same administrator account is my identity for the monitoring web service, I thought things should be fine.  I appreciate all your help.

     

    ps. I am reading your "Rational" MnA book right now - its well written and very helpful. 

     

     

    Friday, February 15, 2008 10:21 PM
  • OK, thanks for that.

     

    I think you may have tried this already, but let's do it again.

     

    1. Start a trace against the SSAS server

    2. Try to configure the SSAS data source against the server using the UI.. and if you get that far, hit Test Connection

     

    I think when you tried this last time you said that you didn't see any errors on the trace. That would suggest that the access to the cube is good and the connection was successful. Nonetheless you still were getting the "The PerformancePoint Server could not connect to the specified data source..." error. Is that right?

     

    For some more fun, try this:

     

    1. Launch a new instance of Dashboard Designer, however this time but be sure to launch it from the Monitoring Central web site (http://<YourNewServer>:40000/Central) that is located on the new Monitoring server you set up. Do not launch from your Start menu; make sure you go to the site and hit the Run button. This will guarantee that we are connected to the right web service when DD fires up and gives us a clean slate.

    2. Create a brand new workspace and then try to create a brand new data source connection to the cube in question using the UI method, not the connection string.

    3. Ensure you trace the SSAS events and make note of what errors come up both in the trace and Dashboard Designer.

    4. Let me know the outcome.

     

    BTW, glad you hear you're enjoying the book - thanks for the feedback.

     

    Cheers.

    Nick

     

    Saturday, February 16, 2008 3:06 AM
  • When you say configure the data source against the server using the UI I am assuming you mean the DD UI?  I did that and hit test connection...The XML from the Trace from this test is below but I am pretty sure it did not show any errors.  The XML that results from a trace using a connection string (which works for me) is the same. 

     

    One interesing thing it that when I run DD from the monintoring central is does not "install" on in my start menu for PPS.  Its on my machine because I can double click a bsdw file and DD fires up.

     

    I tried launching DD from monitoring central and opened up the workspace and tried creating a new connection (and using the old one) using the DD "UI" (without connecxtion string) and still no luck.  It seems a wee bit silly now.  The trace seems OK - what could be wrong. 

     

    I am going to try and create an entirely new workspace and test a cube connection there jus in case my workspace from the other server has some hangover spec's from its original machine. 

     

    </Header>
      <Events>
        <Event id="1" name="Audit Login">
          <Column id="3" name="StartTime">2008-02-16T01:46:22-07:00</Column>
          <Column id="25" name="ConnectionID">125</Column>
          <Column id="33" name="NTDomainName">ONLINE-99C3D89A</Column>
          <Column id="2" name="CurrentTime">2008-02-16T01:46:22-07:00</Column>
          <Column id="24" name="Error">0</Column>
          <Column id="32" name="NTUserName">Administrator</Column>
        </Event>
        <Event id="43" name="Session Initialize">
          <Column id="3" name="StartTime">2008-02-16T01:46:22-07:00</Column>
          <Column id="2" name="CurrentTime">2008-02-16T01:46:22-07:00</Column>
          <Column id="28" name="DatabaseName">gasdemo3</Column>
          <Column id="32" name="NTUserName">Administrator</Column>
          <Column id="42" name="TextData">admin</Column>
          <Column id="25" name="ConnectionID">125</Column>
          <Column id="33" name="NTDomainName">ONLINE-99C3D89A</Column>
          <Column id="41" name="SPID">28953</Column>
          <Column id="45" name="RequestProperties">&lt;PropertyList&gt;&lt;Catalog&gt;gasdemo3&lt;/Catalog&gt;&lt;Content&gt;SchemaData&lt;/Content&gt;&lt;Format&gt;Tabular&lt;/Format&gt;&lt;AxisFormat&gt;TupleFormat&lt;/AxisFormat&gt;&lt;BeginRange&gt;-1&lt;/BeginRange&gt;&lt;EndRange&gt;-1&lt;/EndRange&gt;&lt;ShowHiddenCubes&gt;false&lt;/ShowHiddenCubes&gt;&lt;VisualMode&gt;0&lt;/VisualMode&gt;&lt;DbpropMsmdFlattened2&gt;false&lt;/DbpropMsmdFlattened2&gt;&lt;SecuredCellValue&gt;0&lt;/SecuredCellValue&gt;&lt;ImpactAnalysis&gt;false&lt;/ImpactAnalysis&gt;&lt;SQLQueryMode&gt;Calculated&lt;/SQLQueryMode&gt;&lt;ReturnCellProperties&gt;false&lt;/ReturnCellProperties&gt;&lt;CommitTimeout&gt;0&lt;/CommitTimeout&gt;&lt;ForceCommitTimeout&gt;0&lt;/ForceCommitTimeout&gt;&lt;ExecutionMode&gt;Execute&lt;/ExecutionMode&gt;&lt;RealTimeOlap&gt;false&lt;/RealTimeOlap&gt;&lt;MdxMissingMemberMode&gt;Default&lt;/MdxMissingMemberMode&gt;&lt;DisablePrefetchFacts&gt;false&lt;/DisablePrefetchFacts&gt;&lt;LocaleIdentifier&gt;1033&lt;/LocaleIdentifier&gt;&lt;Roles&gt;admin&lt;/Roles&gt;&lt;DbpropMsmdMDXCompatibility&gt;2&lt;/DbpropMsmdMDXCompatibility&gt;&lt;/PropertyList&gt;</Column>
        </Event>
        <Event id="1" name="Audit Login">
          <Column id="3" name="StartTime">2008-02-16T01:46:42-07:00</Column>
          <Column id="25" name="ConnectionID">126</Column>
          <Column id="33" name="NTDomainName">ONLINE-99C3D89A</Column>
          <Column id="2" name="CurrentTime">2008-02-16T01:46:42-07:00</Column>
          <Column id="24" name="Error">0</Column>
          <Column id="32" name="NTUserName">Administrator</Column>
        </Event>
        <Event id="43" name="Session Initialize">
          <Column id="3" name="StartTime">2008-02-16T01:46:42-07:00</Column>
          <Column id="2" name="CurrentTime">2008-02-16T01:46:43-07:00</Column>
          <Column id="28" name="DatabaseName">gasdemo3</Column>
          <Column id="32" name="NTUserName">Administrator</Column>
          <Column id="42" name="TextData">*,role,admin</Column>
          <Column id="25" name="ConnectionID">126</Column>
          <Column id="33" name="NTDomainName">ONLINE-99C3D89A</Column>
          <Column id="41" name="SPID">28962</Column>
          <Column id="45" name="RequestProperties">&lt;PropertyList&gt;&lt;Catalog&gt;gasdemo3&lt;/Catalog&gt;&lt;Content&gt;SchemaData&lt;/Content&gt;&lt;Format&gt;Tabular&lt;/Format&gt;&lt;AxisFormat&gt;TupleFormat&lt;/AxisFormat&gt;&lt;BeginRange&gt;-1&lt;/BeginRange&gt;&lt;EndRange&gt;-1&lt;/EndRange&gt;&lt;ShowHiddenCubes&gt;false&lt;/ShowHiddenCubes&gt;&lt;VisualMode&gt;0&lt;/VisualMode&gt;&lt;DbpropMsmdFlattened2&gt;false&lt;/DbpropMsmdFlattened2&gt;&lt;SecuredCellValue&gt;0&lt;/SecuredCellValue&gt;&lt;ImpactAnalysis&gt;false&lt;/ImpactAnalysis&gt;&lt;SQLQueryMode&gt;Calculated&lt;/SQLQueryMode&gt;&lt;ReturnCellProperties&gt;false&lt;/ReturnCellProperties&gt;&lt;CommitTimeout&gt;0&lt;/CommitTimeout&gt;&lt;ForceCommitTimeout&gt;0&lt;/ForceCommitTimeout&gt;&lt;ExecutionMode&gt;Execute&lt;/ExecutionMode&gt;&lt;RealTimeOlap&gt;false&lt;/RealTimeOlap&gt;&lt;MdxMissingMemberMode&gt;Default&lt;/MdxMissingMemberMode&gt;&lt;DisablePrefetchFacts&gt;false&lt;/DisablePrefetchFacts&gt;&lt;LocaleIdentifier&gt;1033&lt;/LocaleIdentifier&gt;&lt;DbpropMsmdMDXCompatibility&gt;2&lt;/DbpropMsmdMDXCompatibility&gt;&lt;/PropertyList&gt;</Column>
        </Event>
        <Event id="2" name="Audit Logout">
          <Column id="5" name="Duration">69390</Column>
          <Column id="25" name="ConnectionID">125</Column>
          <Column id="33" name="NTDomainName">ONLINE-99C3D89A</Column>
          <Column id="2" name="CurrentTime">2008-02-16T01:47:31-07:00</Column>
          <Column id="6" name="CPUTime">40</Column>
          <Column id="32" name="NTUserName">Administrator</Column>
        </Event>
      </Events>
    Saturday, February 16, 2008 9:12 AM
  • I tried an entirely new workspace and created a new connection to the cube - no luck!  Could any of the other IIS application pool identities affect a request from DD for a connection?  ie other than the PPSMonitoringWebService?

     

    Saturday, February 16, 2008 9:20 AM
  • Tim, please detail what error message you got and when while you were creating the new workspace. Were you able to 'see' the SSAS database and cube listing in the appropriate dropdowns in the UI? When do you get the error, what is the error message?

     

    Cheers,

    Nick

     

    Saturday, February 16, 2008 9:49 AM
  • Tim, where is the relational database server that the PPSMonitoring database is located on? When you say "standalone" install I am assuming that all the components needed to run the Monitoring server are on the same single machine. In an earlier post you said that you only moved the workspace and the cube. Is there a fresh relational DB instance on the new server too?

     

    When you configured the Monitoring server on the new machine what was the service account you stipulated in the set up wizard? Did you use Network Service and then change it to Administrator later on?

    Saturday, February 16, 2008 10:04 AM
  • I didn't get an error while creating the new workspace.  I was able to create a new connection using the UI.  Next I entered the server and the dropdown did show my cube.   I selected that cube.  Next I clicked "test connection" and that is when I get the original error message.

     

    The relational DB that contains PPSMonitoring database is located on the same server as PPS and Sharepoint - the whole BI stack is located together.  My workspace and cube are now on a Server with a fresh relational DB instance (fresh install of PPS and Sharepoint too).

     

    I initially setup the service account to be Admnistrator.

    Saturday, February 16, 2008 4:24 PM
  • Tim, I still think this is a simple permissions thing and I reckon the Administrator account being used set up in the configuration is muddying the waters in trying to find the cause.

     

    Can you try either of the following and then retest:

     

    1. Reconfigure the App Pool identity account in the PPSMonitoringCentral, PPSMonitoringPreview, PPSMonitoringWebService to use a specific domain account. Do not to use your own account. Create a specific, low provileged account. Ensure the account has been granted membership to the BpmDeveloper role in the PPSMonitoring database and has also been granted read access to your source cube.

     

    2. Do a reinstall of the Monitoring Server on your new machine. Actually this is a reconfigure, use the configuration manager to remove the components and then manually delete the PPSMonitoring database. Then rerun the monitoring configuration manager and when you set up the Monitoring server this time please use either NT AUTHORITY/NETWORK SERVICE or (preferably) a domain account. Ensure that the account you use has been granted read access to the cube in question. Please do not simply provide admin access to the SSAS server.

     

    Cheers,

    Nick

    Saturday, February 16, 2008 7:35 PM
  • Sounds good.  I'll post my results soon Smile.

    Saturday, February 16, 2008 8:49 PM
  • Hi Nick,

     

    I have tried both suggestions - changing the identity to a domain account called PPS.  That didn't work.  Next I removevd all PPS Monitoring components using Monitoring Server Configuration Manager and re-installed everything using PPS as the domain account. 

     

    With my new install I can connect to the Monitoring Service (under ...options -> server ).  Using the domain account and I can configure my connection and see the cube in the drop down using "The Standard Connection".  If I click "test connecxtion", I get the same error,

     

    "The PerformancePoint Server could not connect to the specified data source. Verify that either the current user or application pool user has Read permissions to the data source, depending on your security configuration. Also verify that all required connection information is provided and correct."

     

    Similar to before, if I use a connection string with my domain account instead, test connection works!

     

    Here's the conn. string

     

    "Provider=MSOLAP.3;Persist Security Info=True;User ID=PPS;Initial Catalog=gasdemo3;Data Source=ONLINE-99C3D89A;MDX Compatibility=1;Safety Options=2;MDX Missing Member Mode=Error "

     

    Its truly puzzling, really I have exactly the same problem as before but I am now using a much safer, low privalege domain account. 

    Monday, February 18, 2008 8:03 PM
  • Tim, what was the result of the trace when the SSAS server for the connection error?

    Are you sure you granted the domain account read access to the cube via an SSAS role?

     

    To my knowledge the User ID property you're passing in your connection string should have no no effect on the account that is used to connect to the data source. Therefore passing your own user account details in that switch should make no difference at all. Have a closer look at the trace, as long as you're using default Application security the connections should be made as the app pool account.

     

    Cheers,

    Nick

    Monday, February 18, 2008 8:58 PM
  • What do you mean by "default Application Security". 

     

    The trace I just ran had no errors.   I granted my domain account read access to the cube - the role that allow my domain account uses for access shows up in a trace event called "session initialize" under the "TextData" atribute (the role is called PPSAccess). 

     

    I checked this by putting in a incorrect role in the DD connection designer UI text box for "Roles" (using Standard Connection) and ran the trace again with this incorrect specification - I get an error in the Trace.

     

    I tested the connection string User ID property by chainging it from my domain account (PPS) to an incorrect user id.  test connection still worked so it would appear this parameter has no effect as you advise. 

     

    I have a hunch this is not an permission problem (albeit a hunch from a person with little experience with PPS).  I am using PPS domain account as my PPSMonitoringService Identity and I can connect to the cube using a connection string.  What is the difference  between using a connection string and using the "Standard Connection" ?   

     

    Monday, February 18, 2008 10:18 PM
  •  TimW wrote:

    What do you mean by "default Application Security". 

    This is detailed in the blog post - the application pool account is used to connect to the data source

     

     TimW wrote:

    The trace I just ran had no errors.   I granted my domain account read access to the cube - the role that allow my domain account uses for access shows up in a trace event called "session initialize" under the "TextData" atribute (the role is called PPSAccess). 

    So you had no SSAS errors show up in the trace when you used the UI to configure the connection, and tried "Test Connection"?

     

     TimW wrote:

    I have a hunch this is not an permission problem (albeit a hunch from a person with little experience with PPS).  I am using PPS domain account as my PPSMonitoringService Identity and I can connect to the cube using a connection string.  What is the difference  between using a connection string and using the "Standard Connection" ?   

    Not much, as far as I'm aware. Try removing parts of the conn string that are not needed and see if it changes the connection success behaviour.

     

    I wonder whether the hypen in the server name may be causing some sort of problem? Did the original SSAS server (where the connection worked) have a hyphen in its name?

    Tuesday, February 19, 2008 12:11 AM
  • Tim, when you do a "Test Connection" you should be seeing a "Discover Begin" and "Discover End" EventClass instances. Are you getting these for either Connection String or UI methods?

     

    The TextData should look something like this:

     

    <RestrictionList xmlns="urnTongue Tiedchemas-microsoft-com:xml-analysis">
              <CATALOG_NAME>AdventureWorksPPS</CATALOG_NAME>
            </RestrictionList>

    <PropertyList xmlns="urnTongue Tiedchemas-microsoft-com:xml-analysis">
              <DbpropMsmdMDXCompatibility>2</DbpropMsmdMDXCompatibility>
              <Catalog>AdventureWorksPPS</Catalog>
              <LocaleIdentifier>3081</LocaleIdentifier>
              <Content>SchemaData</Content>
              <Format>Tabular</Format>
            </PropertyList>

     

    Tuesday, February 19, 2008 12:19 AM
  • Thanks.  No there were no SSAS errors when I used the UI to configure the connection and teseted it.  I did try adding a non-existant role in the roles textbox in the UI to see what wouild happen.  I did get an SSAS error when I added a non-existant role which makes sense. 

     

    The original SSAS Server did not have a hyphen in its name.  I just tried chaning that name to the IP for the server and no luck (just in case the IP worked)

     

    Tuesday, February 19, 2008 12:43 AM
  • Yes - i get both eventclass instances irregardless of whether I use either the UI or connection string.  Here's the textdata for discover begin

     

    <RestrictionList xmlns="urnTongue Tiedchemas-microsoft-com:xml-analysis">
              <CATALOG_NAME>gasdemo3</CATALOG_NAME>
            </RestrictionList>

    <PropertyList xmlns="urnTongue Tiedchemas-microsoft-com:xml-analysis">
              <DbpropMsmdMDXCompatibility>2</DbpropMsmdMDXCompatibility>
              <Catalog>gasdemo3</Catalog>
              <LocaleIdentifier>1033</LocaleIdentifier>
              <Content>SchemaData</Content>
              <Format>Tabular</Format>
            </PropertyList>

     

    Here's the textdata for discover end

     

    <RestrictionList xmlns="urnTongue Tiedchemas-microsoft-com:xml-analysis">
              <CATALOG_NAME>gasdemo3</CATALOG_NAME>
            </RestrictionList>

    <PropertyList xmlns="urnTongue Tiedchemas-microsoft-com:xml-analysis">
              <DbpropMsmdMDXCompatibility>2</DbpropMsmdMDXCompatibility>
              <Catalog>gasdemo3</Catalog>
              <LocaleIdentifier>1033</LocaleIdentifier>
              <Content>SchemaData</Content>
              <Format>Tabular</Format>
            </PropertyList>

    Tuesday, February 19, 2008 12:59 AM
  • Just to cover all bases... is the new server up to date with the latest SSAS SPs & hotfixes?

    Tuesday, February 19, 2008 1:05 AM
  • There must be some difference between using the UI versus connection string in the way PPS sends the requests off to SSAS otherwise I the results should be the same no matter which method used. 

     

    I am going to try and move the relational data over to this new server and rebuild the cube - this cube was backed up on the other server and restored on the new one.  Maybe there is some left-over metadata in the restored cube that references the old server - metadata that is accessed when using the UI method but not accessed when using the connection string method.  Just a hunch.  Cant hurt to try.

     

     

    Tuesday, February 19, 2008 1:07 AM
  • Have you tried removing parts of the connection string to see if you can force a failure that way as suggested earlier.

     

    The next step would be to try a cube other than yours. Can you create a pristine instance of the AdventureWorks cube on your new server and attempt to connect to it. don't forget to add the App Pool account to a role so that it can read the cube.

     

    Tuesday, February 19, 2008 1:11 AM
  • Indeed, I'll try this next.  Just have to download the adventureworks DW and the visual studio metadata and build it out.

     

    Tuesday, February 19, 2008 3:56 AM
  • I downloaded all the Adventureworks BI data and built the cubes on the new machine.  The Visual Studio project deployed successfully.  I added in a role for my domain account.

     

    The UI built standard connection does not work and the connection string does work - exactly the same issue as with my other cube that was restored onto the new server SSAS instance.  At this url

    http://picasaweb.google.ca/72911e/Issues/photo#5168568099739667474

    you can see that the connection string is very abbreviated  - down to the data source and catalog parameters and it still works fine. 

     

    Get rid of anything thats left in the connection string and it will fail to connect. Nick, I appreciate all your help.  I am going to continue to troubleshoot this issue.  When I figure out the problem, I'll post my findings here.  For now, I assume I am safe using a connection string as an alternative to the UI until I find out differently. 

     

     

    Tuesday, February 19, 2008 6:15 AM
  • No worries, Tim. Look forward to hearing what you find out. Good hunting.

     

    Cheers,

    Nick

     

    Tuesday, February 19, 2008 8:27 AM
  • Just a follow-up to my original problem.  I am still using connection strings with PPS but there is another wrinkle / problem.  I have just implemented per user connections (already edited all the web.config files) and am now using cube "Dimension Data" security.  Using excel I can connect to the cube using an account related to the specific role in SSAS that has the aforementioned "Dimension Data" security and I get the specific results I would expect.  However, when

    using this same account to access a sharepoint dashboard the site starts to render the dashboard and then I get...

     

    "

    The PerformancePoint Server could not connect to the specified data source. Verify that either the current user or application pool user has Read permissions to the data source, depending on your security configuration. Also verify that all required connection information is provided and correct.
    Contact the administrator for more details.
    "
     
    I am suspicious it's a related problem.  Also, I can check the specified "Role" in SSAS that is used for this "Dimension Data" security using the SSAS cube browser's "change user" function.  I set the user to the "Role" and the results are what I expect here too.
     
    Now I really have to figure out what is causing the seemingly related problem because I dont have a work around for this one.  I suspect my server name "online-99c3d89a" with the hyphen has helped uncover a bug in some connection string parsing routine used by both the "use Standard Connection" data source specification text boxes in PPS and the routine passing the per user account name .  I'll check this by creating another machine with a hyphened name at some point...
     
     
     
     


    Sunday, March 9, 2008 3:04 AM