none
Disable Read Receipts but allow Out of Office replies

    Question

  • I have a single 2013 Exchange server setup.  I had a request to prevent internal users from being prompted to send read receipts on emails that originated from outside our organization.  After researching, I created a rule in Exchange that strips 'Disposition-Notification-To' from the message header if the email is received from outside the organization.  

    I tested and confirmed with this rule in place, internal users are not prompted to send a read receive to an email they received from outside our organization.

    However, what I just learned is this rule also prevents the outbound deliver of Out of Office replies.  So, if an internal user sets Out of Office in Outlook and receives an email from outside the organization, the sender never receives the Out of Office reply.  I can disable the Exchange rule and now Out of Office emails work correct.

    I compared the message header line by line with the rule enabled and with the rule disabled and there is not a single instance of 'Disposition-Notification-To' on emails that do not request a read receipt, so why is the Exchange rule blocking outbound Out of Office reply messages?

    Any help would be greatly appreciated.

    Thanks,

    Friday, September 2, 2016 4:29 PM

Answers

  • Hi,

    How do you configure the transport rule?

    Please refer to the following picture to set the rule to disable Read Receipt:

    Regards,


    David Wang_
    TechNet Community Support


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by David Wang_Moderator Monday, September 26, 2016 8:34 AM
    • Marked as answer by jwhit922 Monday, September 26, 2016 1:17 PM
    Monday, September 5, 2016 2:48 AM
    Moderator
  • David,

    I finally found the options you specified and this rule appears to be working as I needed.  With this rule in place, users are not prompted to send read receipts when requested and out of the office automatic notifications are returned to the senders.

    Here are the steps I used to create the rule (in case anyone else has this issue): 

    - Go to Mail Flow and then Rules.  Click the + symbol and select Apply rights protection to messages...

    - On the "Apply this rule if..." drop down list select "The Sender..." select "is external/internal" select Outside the organization.  Click Add Condition, and select "The message properties..."  select "include the message type", select Read Receipt.

    - On the "Do the following..." drop down list, select "Block the message..." and select "Delete the message without notifying anyone"

    Thanks for your help.

    • Marked as answer by jwhit922 Monday, September 26, 2016 1:17 PM
    Monday, September 12, 2016 4:33 PM

All replies

  • They're completely separate options.

    You can configure Outlook to ignore read receipts.  That's what I do.  But that'll block internal read receipts too, but IMO that's no loss since a read receipt doesn't prove that the recipient read it.

    In Outlook 2016 it's File > Options > Tracking > For any message received that includes a read receipt: Never send a receipt.  You might be able to configure group policy to set that for everyone.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Saturday, September 3, 2016 4:08 AM
    Moderator
  • Hi,

    How do you configure the transport rule?

    Please refer to the following picture to set the rule to disable Read Receipt:

    Regards,


    David Wang_
    TechNet Community Support


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by David Wang_Moderator Monday, September 26, 2016 8:34 AM
    • Marked as answer by jwhit922 Monday, September 26, 2016 1:17 PM
    Monday, September 5, 2016 2:48 AM
    Moderator
  • Ed,

    Thanks for your reply.  

    I understand these should be completely separate configuration areas, but I assure you, the single transport rule I have in place on my 2013 Exchange server blocks both read receipts AND Out of Office notifications from being delivered to external recipients.

    I know this because I can simply disable the transport rule in EAC and now Out of Office messages are delivered to the sender. 

    I can then re-enable the rule and now Out of the Office messages are not delivered to the sender.

    Tuesday, September 6, 2016 1:24 PM
  • David,

    Below is a screenshot of the transport rule I configured.  I can also provide the configuration from the Exchange Shell if needed.

    Thanks


    

    Tuesday, September 6, 2016 1:26 PM
  • Hi,

    I understand the rule also block outbound Out of Office reply messages.

    Have you referred to above picture to create a new rule for test?

    Regards,


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 9, 2016 2:10 AM
    Moderator
  • David,

    I attempted to create the rule in the picture you supplied but do not have the same options.

    I went to Mail Flow, Rules, and clicked on the + symbol.  I then when through each of the 11 different options to create rules and none have the option of "Read Receipt".  

    Can you please send me information on how you created the rule in the picture?

    Thanks,

    Monday, September 12, 2016 4:03 PM
  • David,

    I finally found the options you specified and this rule appears to be working as I needed.  With this rule in place, users are not prompted to send read receipts when requested and out of the office automatic notifications are returned to the senders.

    Here are the steps I used to create the rule (in case anyone else has this issue): 

    - Go to Mail Flow and then Rules.  Click the + symbol and select Apply rights protection to messages...

    - On the "Apply this rule if..." drop down list select "The Sender..." select "is external/internal" select Outside the organization.  Click Add Condition, and select "The message properties..."  select "include the message type", select Read Receipt.

    - On the "Do the following..." drop down list, select "Block the message..." and select "Delete the message without notifying anyone"

    Thanks for your help.

    • Marked as answer by jwhit922 Monday, September 26, 2016 1:17 PM
    Monday, September 12, 2016 4:33 PM
  • David,

    Sorry, but I just tested one last time and the newly configured rule is not blocking the sending of read receipts.

    I configured the rule as noted in my previous rely.

    Any other suggestions?

    Monday, September 12, 2016 4:39 PM