locked
How to add Personalize This Page under menu item on Welcom Page RRS feed

  • Question

  • I need help on where I need to go to add this under the welcome on the menu item. All I have now is MySettings, Sign In as different user, Sign Out.
    Wednesday, February 9, 2011 7:14 PM

All replies

  • It's a permissions setting, which (I think) is only set by default for SharePoint groups that have "Contribute" privileges and above (e.g. I don't think site "Visitors" have this permission).

    If you have the rights to tweak group permissions, you can add/remove the right from any group.  Go to People and Groups | Site Permissions then Settings | Permission Levels.  From there, click Add a Permission Level.  I can't remember which of these actually controls that setting, but I'm pretty sure it's one of these: "Add and Customize Pages" and/or "Add/Remove Personal Web Parts".

     

    Thursday, February 10, 2011 8:48 PM
  • I created a Permission level called 'Personalize Page' to the group and I still don't see it. Do I need to sign off and back on. I still don't see Personalize This Page. I didn't see Add/Remove Personal Web Parts but I did see Add and Customize Page btw and added it to the permission level.
    Friday, February 11, 2011 3:37 PM
  • Hi,

    It sounds like only permission problem. As you said you have created custom permission level so You have to make sure that below permissions should be checked.

    Just try to modify contributor permission and check below permissions.

    "Add/Remove Personal Web Parts  -  Add or remove personal Web Parts on a Web Part Page. "

    and

    "Update Personal Web Parts  -  Update Web Parts to display personalized information"

    Let us know your result


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    Monday, February 14, 2011 5:00 AM
    Moderator
  • It sounds like only permission problem. As you said you have created custom permission level so You have to make sure that below permissions should be checked.
    As I explained previously I don't see either o the permissions to check. I have every permission selected for 'Personalize Page'. All is selected under List, Site, Personal Permissions and don't see either permission you have listed.  Also now that I have selected all I still don't get personalize this page under 'Welcome my name'. Any ideas on what is happening? Is this a particular web part that i need to add?
    • Edited by Mike Walsh FIN Monday, February 14, 2011 3:22 PM Never use full quote. It wastes screen space for no gain
    Monday, February 14, 2011 3:18 PM
  • What SharePoint group are you in?

     

    Try putting yourself (or asked to be placed) in the Administrators group.  Once you're in that group, log in and see if you see the option.

    Monday, February 14, 2011 4:10 PM