none
Installing hotfix rollup package (build 4.3.2064.0) over MIM which has been upgraded from FIM RRS feed

  • Question

  • Hi,

    I installed hotfix rollup package (build 4.3.2064.0) on the synchronization server (it went fine).

    Right now I'm trying to install it over 2 Portal/service servers and it fails. Both servers are MIM (4.3.1935) upgraded some time ago from FIM 2010 R2 - if that has some meaning.

    I've been looking thru the install log and there was something like that:

    DEBUG: Error 2746:  Transform EVAL.1 invalid for package C:\Windows\Installer\bae8e246.msi. Expected product {AB9663A3-2B61-44C7-8A64-358EC72934E6}, found product {0782FB14-023A-430F-B0D5-4AE1D1CCFCAA}.

    Anyone seen something like this?

    EDIT: It appears that real reason of failing hotfix installation is non default FIMService database name (customer uses FIMServiceV2, but the old one FIMService still exist on the server and is set to offline). Hotfix seems to have database name hardcoded. Or maybe there is some switch to use non default name?


    Borys Majewski, Identity Management Solutions Architect (Blog: IDArchitect.NET)


    • Edited by Borys Majewski Monday, December 14, 2015 10:02 AM New info
    Sunday, December 13, 2015 4:20 PM

All replies

  • Haave you tried adding parameters with msiexec to specify the database? Parameters can be fond here https://technet.microsoft.com/en-us/library/hh322863(v=ws.10).aspx Although, I'm not sure do they work with .msp installations, worth a try still.
    Friday, January 1, 2016 10:24 AM