locked
Cannot Remove WSUS Role in Server 2012 R2 0x80070490 RRS feed

  • Question

  • Hi There,

    WSUS seems to have failed on my Server 2012 R2 server and I can't remove it. Any manual removal technique that I can use?  See the below image.

    Thursday, July 7, 2016 6:32 PM

Answers

  • Hi a88fingerslukee,

    It seems your system is crashed.

    Have you run sfc/scannow to check the health of system files?

    If your computer is really in a mess, I would recommend re-installing the OS for a quick fix rather than troubleshooting.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Friday, July 15, 2016 9:00 AM

All replies

  • Hi a88fingerslukee,

    Since after some search, I didn't find any useful information to solve this issue directly. So, let me ask some other related questions:

    1. Why do you want to uninstall the WSUS role, do you want to reinstall it to repair the WSUS?

    2. If the answer to Q1 is yes, then, what's wrong with your original WSUS server?

    3. Since there is a famous KB3159706 recently, if your original WSUS server is affected by this KB, then have you done the manual steps to finish the installation?

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, July 8, 2016 6:26 AM
  • Hi Anne,

    Answers:

    1.) Yes

    2.) I can't access it using the management console. The DB might be corrupted?  Is there any method to recreate the WID database?

    3.) I searched for that update on the server but I couldn't find it, so I don't think that's an issue for me.

    Friday, July 8, 2016 5:36 PM
  • Okay, so I looked again for KB3159706 and I found that it HAD been installed. I have gone through the postinstall steps but I can't install the HTTP Activation feature with the exact same error as above. What has happened to my server?

    Friday, July 8, 2016 7:05 PM
  • Hi a88fingerslukee,

    If so, please try to following method:

    1. Uninstall KB 3159706;

    2. Then check if you can add the "HTTP activation" feature, if yes, then add it and install the KB again and do manual steps;

    3. If not, please run System Update Readiness tool, and check  the result:

    Fix Windows Update errors by using the DISM or System Update Readiness tool

    https://support.microsoft.com/en-sg/kb/947821

    4. Also run sfc/scannow to check if there are corrupted system files.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, July 11, 2016 8:19 AM
  • It's not letting me uninstall KB3159706.  Is there a manual removal process for that?

    Monday, July 11, 2016 4:07 PM
  • Hi a88fingerslukee,

    It seems your system is crashed.

    Have you run sfc/scannow to check the health of system files?

    If your computer is really in a mess, I would recommend re-installing the OS for a quick fix rather than troubleshooting.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Friday, July 15, 2016 9:00 AM