locked
SPWebServerSequence failed error message while running PSConfig wizard after installing Service Pack 2 on SharePoint Server 2010. RRS feed

  • Question

  • I have one WFE SharePoint Server 2010 and one SQL 2008 Database server FARM in the backend. I was trying to update my farm after 3 years with Service pack- 2 on top of patch KB2475878 which was installed on FEB 2011.

    My current Configuration Database Version : 14.0.5136.5002

    SP2 Setup installation completed succesfully but PSConfig is failing with the following error

    Error: 

    \Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\config\web.config
    [PSCONFIG] [SPWebServerSequence] [ERROR] [2/14/2014 1:48:22 PM]: Action 4.0.10.0 of Microsoft.SharePoint.Upgrade.SPWebServerSequence failed.

    Please help me. Thanks in advance

    Tuesday, February 18, 2014 2:27 PM

Answers

All replies

  • did you reboot the server after the SP2 installation, if not try it.

    Alos share the complete error log from PSConfig.

    check similar issue over here.

    http://social.msdn.microsoft.com/Forums/sharepoint/en-US/bed2badb-dbe9-40fa-84e7-d16c8b3da441/cant-get-through-psconfig-with-wss-sp2?forum=sharepointadminlegacy

    http://www.spsdemo.com/blog/Lists/Posts/Post.aspx?List=c67861cd-a0d9-4ed8-9d9d-9b29652a516f&ID=5&Web=f74569c2-ae3f-42c6-a3fa-9f099dfaeb7f


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog

    Tuesday, February 18, 2014 7:12 PM
  • Try starting the timer service after launching the upgrade.  I know that sounds counter intuitive but it has helped me get sp2 on the last two customers I've updated to sp2.

    MCITP-EA | "Never test how deep the water is with both feet"

    Wednesday, February 19, 2014 3:48 AM
  • Yes, I rebooted the server twice and ran the PSConfig command. Below is the complete error information.

    [ERROR] [2/14/2014 11:19:37 AM]: Action 4.0.10.0 of Microsoft.SharePoint.Upgrade.SPWebServerSequence failed.
    [ERROR] [2/14/2014 11:19:37 AM]: Exception: '<', hexadecimal value 0x3C, is an invalid attribute character. Line 582, position 13.
    [ERROR] [2/14/2014 11:19:37 AM]:    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
    [ERROR] [2/14/2014 11:19:37 AM]: Exception: Action 4.0.10.0 of Microsoft.SharePoint.Upgrade.SPWebServerSequence failed.
    [ERROR] [2/14/2014 11:19:37 AM]:    at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [ERROR] [2/14/2014 11:19:37 AM]: Upgrade Timer job is exiting due to exception: Microsoft.SharePoint.Upgrade.SPUpgradeException: Action 4.0.10.0 of Microsoft.SharePoint.Upgrade.SPWebServerSequence failed. ---> System.Xml.XmlException: '<', hexadecimal value 0x3C, is an invalid attribute character. Line 582, position 13.


    Venkat Yedida

    Thursday, February 20, 2014 11:22 AM
  • I know that sometimes we need to start the timer service manually after launching the wizard. I started the service and tried. still same error...

    Venkat Yedida

    Thursday, February 20, 2014 1:45 PM
  • according to the below post, may be something from the Config DB causing this issue and have some bad refrence. So you need to clear the config Cache.

    http://social.technet.microsoft.com/Forums/sharepoint/en-US/b6e98dc9-8e75-47f4-b59b-edb9090b436b/-hexadecimal-value-0x3c-is-an-invalid-attribute-character-line-1-position-19355?forum=sharepointadminprevious

    Config Cache:


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog

    • Marked as answer by JasonGuo Monday, March 3, 2014 1:14 AM
    Thursday, February 20, 2014 4:08 PM
  • Hi,

    I followed your recommendations and ran PSConfig on my test server by clearing the Config cache. Still same issue.

    Any other suggestions ??

    PS: PSConfig failed but in CA under Manage Servers in the Farm section showing the Config database version as SP2 version.

    Error logs information is as below

    #####Upgrade Error Log information############################

    [PSCONFIG] [SPWebServerSequence] [INFO] [3/28/2014 1:05:32 PM]: SPWebServiceInstance
    [PSCONFIG] [SPWebServerSequence] [ERROR] [3/28/2014 1:05:32 PM]: Action 4.0.10.0 of Microsoft.SharePoint.Upgrade.SPWebServerSequence failed.
    [PSCONFIG] [SPWebServerSequence] [INFO] [3/28/2014 1:05:32 PM]: SPWebServiceInstance
    [PSCONFIG] [SPWebServerSequence] [ERROR] [3/28/2014 1:05:32 PM]: Exception: '<', hexadecimal value 0x3C, is an invalid attribute character. Line 582, position 13.
    [PSCONFIG] [SPWebServerSequence] [INFO] [3/28/2014 1:05:32 PM]: SPWebServiceInstance
    [PSCONFIG] [SPWebServerSequence] [ERROR] [3/28/2014 1:05:32 PM]:    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
       at System.Xml.XmlTextReaderImpl.ParseAttributeValueSlow(Int32 curPos, Char quoteChar, NodeData attr)
       at System.Xml.XmlTextReaderImpl.ParseAttributes()
       at System.Xml.XmlTextReaderImpl.ParseElement()
       at System.Xml.XmlTextReaderImpl.ParseElementContent()
       at System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace)
       at System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc)
       at System.Xml.XmlDocument.Load(XmlReader reader)
       at System.Xml.XmlDocument.Load(String filename)
       at Microsoft.SharePoint.Upgrade.SPWebConfigWebServerAction.get_ConfigWebConfig()
       at Microsoft.SharePoint.Upgrade.UpdateWorkflowAuthorizedTypes.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [PSCONFIG] [SPUpgradeSession] [INFO] [3/28/2014 1:05:32 PM]: SPWebServiceInstance
    [PSCONFIG] [SPUpgradeSession] [ERROR] [3/28/2014 1:05:32 PM]: Upgrade [SPWebServiceInstance] failed.
    [PSCONFIG] [SPUpgradeSession] [INFO] [3/28/2014 1:05:32 PM]: SPWebServiceInstance
    [PSCONFIG] [SPUpgradeSession] [ERROR] [3/28/2014 1:05:32 PM]: Inner Exception: '<', hexadecimal value 0x3C, is an invalid attribute character. Line 582, position 13.
    [PSCONFIG] [SPUpgradeSession] [INFO] [3/28/2014 1:05:32 PM]: SPWebServiceInstance
    [PSCONFIG] [SPUpgradeSession] [ERROR] [3/28/2014 1:05:32 PM]:    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
       at System.Xml.XmlTextReaderImpl.ParseAttributeValueSlow(Int32 curPos, Char quoteChar, NodeData attr)
       at System.Xml.XmlTextReaderImpl.ParseAttributes()
       at System.Xml.XmlTextReaderImpl.ParseElement()
       at System.Xml.XmlTextReaderImpl.ParseElementContent()
       at System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace)
       at System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc)
       at System.Xml.XmlDocument.Load(XmlReader reader)
       at System.Xml.XmlDocument.Load(String filename)
       at Microsoft.SharePoint.Upgrade.SPWebConfigWebServerAction.get_ConfigWebConfig()
       at Microsoft.SharePoint.Upgrade.UpdateWorkflowAuthorizedTypes.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [PSCONFIG] [SPUpgradeSession] [INFO] [3/28/2014 1:05:32 PM]: SPWebServiceInstance
    [PSCONFIG] [SPUpgradeSession] [ERROR] [3/28/2014 1:05:32 PM]: Exception: Action 4.0.10.0 of Microsoft.SharePoint.Upgrade.SPWebServerSequence failed.
    [PSCONFIG] [SPUpgradeSession] [INFO] [3/28/2014 1:05:32 PM]: SPWebServiceInstance
    [PSCONFIG] [SPUpgradeSession] [ERROR] [3/28/2014 1:05:32 PM]:    at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPUpgradeSession.Upgrade(Object o, Boolean bRecurse) 

    #####################################################

    #####PSCDiagnostics Error log #############

    One or more configuration tasks has failed to execute
    03/28/2014 13:05:45  1  INF        Entering function TaskDriver.Stop
    03/28/2014 13:05:45  1  INF          Entering function StringResourceManager.GetResourceString
    03/28/2014 13:05:45  1  INF            Resource id to be retrieved is PostSetupConfigurationFailedEventLog for language English (United States)
    03/28/2014 13:05:45  1  INF            Resource retrieved id PostSetupConfigurationFailedEventLog is Configuration of SharePoint Products failed.  Configuration must be performed in order for this product to operate properly.  To diagnose the problem, review the extended error information located at {0}, fix the problem, and run this configuration wizard again.
    03/28/2014 13:05:45  1  INF          Leaving function StringResourceManager.GetResourceString
    03/28/2014 13:05:45  1  ERR          Configuration of SharePoint Products failed.  Configuration must be performed in order for this product to operate properly.  To diagnose the problem, review the extended error information located at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS\PSCDiagnostics_3_28_2014_13_1_47_937_1138994659.log, fix the problem, and run this configuration wizard again.
    03/28/2014 13:05:45  1  INF          Entering function StringResourceManager.GetResourceString
    03/28/2014 13:05:45  1  INF            Resource id to be retrieved is PostSetupConfigurationFailedUserMessage for language English (United States)
    03/28/2014 13:05:45  1  INF            Resource retrieved id PostSetupConfigurationFailedUserMessage is Configuration of SharePoint Products failed.  Configuration must be performed before you use SharePoint Products.  For further details, see the diagnostic log located at {0} and the application event log.
    03/28/2014 13:05:45  1  INF          Leaving function StringResourceManager.GetResourceString
    03/28/2014 13:05:45  1  INF          Entering function TaskDriver.OnTaskDriverStop
    03/28/2014 13:05:45  1  INF            Sending a task driver stop event: TaskDriverEventArgs.EventCriticalityType error, TaskDriverEventArgs.EventType.stop, Configuration of SharePoint Products failed.  Configuration must be performed before you use SharePoint Products.  For further details, see the diagnostic log located at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS\PSCDiagnostics_3_28_2014_13_1_47_937_1138994659.log and the application event log.
    03/28/2014 13:05:45  1  INF            Entering function TaskDriverStateChange.Enter
    03/28/2014 13:05:45  1  INF              Acquiring the writer lock to change the state
    03/28/2014 13:05:45  1  INF              Current state of the task driver is neverrun.  You want to change it to stoppedrunning
    03/28/2014 13:05:45  1  INF              Changed state of the task driver to neverrun
    03/28/2014 13:05:45  1  INF              Released the writer lock to change the state
    03/28/2014 13:05:45  1  INF            Leaving function TaskDriverStateChange.Enter
    03/28/2014 13:05:45  1  INF            Entering function TaskDriver.FireOnTaskDriverEvent
    03/28/2014 13:05:45  1  INF              Entering function CommandLine.TaskDriverEventHandler
    03/28/2014 13:05:45  1  INF                Received a TaskDriverEventHandler: TaskDriverEventArgs.EventCriticalityType error, TaskDriverEventArgs.EventType stop, message Configuration of SharePoint Products failed.  Configuration must be performed before you use SharePoint Products.  For further details, see the diagnostic log located at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS\PSCDiagnostics_3_28_2014_13_1_47_937_1138994659.log and the application event log.
    03/28/2014 13:05:45  1  INF              Leaving function CommandLine.TaskDriverEventHandler
    03/28/2014 13:05:45  1  INF            Leaving function TaskDriver.FireOnTaskDriverEvent
    03/28/2014 13:05:45  1  INF          Leaving function TaskDriver.OnTaskDriverStop
    03/28/2014 13:05:45  1  INF        Leaving function TaskDriver.Stop
    03/28/2014 13:05:45  1  INF        UnLocking the task driver for exclusive use while we ran tasks
    03/28/2014 13:05:45  1  INF      Leaving function TaskDriver.Run
    03/28/2014 13:05:45  1  ERR      Post setup configuration was not run successfully when using the command line task driver module
    03/28/2014 13:05:45  1  INF    Leaving function PsconfigCommandLineMain.Main

    #################################################

     


    Venkat Yedida

    Friday, March 28, 2014 2:58 PM
  • check this web.config file \Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\config\web.config and go to the Line 582, position 13 and look for the charater  '<'.

    what's your farm topology?


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog

    Friday, March 28, 2014 7:55 PM