none
Cannot use FS4SP to search MOSS 2007 sharepoint sites after grant full read permission RRS feed

  • Question

  • Hi,

     

    I have 2 farms. The first one is Sharepoint 2010 and the other one is MOSS 2007.

    I want to use FS4SP to crawl the content in MOSS 2007. Unfortunately, it returns the following error:

    "Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled. ( Error from SharePoint site: HttpStatusCode Unauthorized The request failed with HTTP status 401: Unauthorized. )"


    However, I have made sure that I have grant the full read permission for the FAST Default Content Access for the MOSS2007 web application that I want to crawl.

     

    Do you have any clues to fix this problem?

    Thanks and Regards,

    Andy

    Monday, June 27, 2011 8:44 AM

All replies

  • Andy, are you crawling via http or https? And, can you check the logs on the MOSS 2007 side as well, and see what it says when the crawler tries to connect.

    Regards,
    Mikael Svenson 


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/
    Monday, June 27, 2011 6:21 PM
  • Hi Mikael,

     

    I did found the solution but did not totally understand why it's working.

    What I have done is... I set the crawl rules for FS4SP to crawl the web application on MOSS 2007.

    I don't know why I need to set up the crawl rules to make it works.

     

    It's strange. Do you know the cause?

    Thanks

    Andy

    Monday, June 27, 2011 6:53 PM
  • So you created a crawl rule with credentials for the MOSS farm, was that it? And I have no idea why you had to do this as your default crawl account was used. Weird.

    Could be that you are using Kerberos on the 2010 farm and NTLM on the 2007?

    Glad you got it working though :)

    -m


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/
    Monday, June 27, 2011 7:21 PM
  • I am trying to crawl the sharepoint 2007 sites from FS4SP farm. the sharepoint items are crawled successfully. but its not honoring the security settings for documents. what i observed is, basically it crawls as http pages instead of sharepoint sites.

    sharepoint sites are configured with hostheaders and customer customized through sharepoint designer. any idea how to solve this?


    Sriram S
    Friday, December 9, 2011 8:15 AM