locked
Cannot deploy operating system with SCCM 2012 RRS feed

  • Question

  • To whom it may concern:

    I have deployed both an x86 and x64 boot image to my SCCM 2012 distribution point. I added an operating system installer and deployed that to the DP, and created a task sequence to deploy the OS cature an image and put the image in the operating images container in SCCM. I have DHCP scope option 66 (10.20.1.45) and 67 (smsboot/x86/wdsnbp.com) defined. when I try to boot to the SCCM WDS PXE server it downloads the WDSNBP file and displays the following:

    Architecture: x64

    WDSNBP started using DHCP referal

    Contacting license server: 10.20.1.45 (Gateway: 0.0.0.0)

    No response from Windows deployment Services server

    Launching pxeboot.com....

    TFTP download failed

    I looked at the SCCM DP log file on the server, smspxe.log, here are the results:

    <![LOG[In SSL, but with no client cert]LOG]!><time="15:25:42.732+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:8557">
    <![LOG[reply has no message header marker]LOG]!><time="15:25:42.744+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="libsmsmessaging.cpp:1967">
    <![LOG[Failed to send status message (80004005)]LOG]!><time="15:25:42.744+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="libsmsmessaging.cpp:4050">
    <![LOG[Failed to send the status message]LOG]!><time="15:25:42.744+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="database.cpp:444">
    <![LOG[PXE::DB_ReportStatus failed; 0x80004005]LOG]!><time="15:25:42.744+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="database.cpp:448">
    <![LOG[PXE Provider failed to process message.
    Unspecified error (Error: 80004005; Source: Windows)]LOG]!><time="15:25:42.744+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="pxehandler.cpp:1395">
    <![LOG[Set enterpirse certificate in transport]LOG]!><time="15:25:44.649+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:9207">
    <![LOG[Set media certificate in transport]LOG]!><time="15:25:44.674+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:9220">
    <![LOG[Set authenticator in transport]LOG]!><time="15:25:44.674+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:7592">
    <![LOG[In SSL, but with no client cert]LOG]!><time="15:25:44.674+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:8557">
    <![LOG[Set authenticator in transport]LOG]!><time="15:25:44.702+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:7592">
    <![LOG[In SSL, but with no client cert]LOG]!><time="15:25:44.708+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:8557">
    <![LOG[reply has no message header marker]LOG]!><time="15:25:44.719+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="libsmsmessaging.cpp:1967">
    <![LOG[PXE::DB_LookupDevice failed; 0x80004005]LOG]!><time="15:25:44.719+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="database.cpp:236">
    <![LOG[Set enterpirse certificate in transport]LOG]!><time="15:25:44.736+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:9207">
    <![LOG[Set media certificate in transport]LOG]!><time="15:25:44.750+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:9220">
    <![LOG[Set authenticator in transport]LOG]!><time="15:25:44.750+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:7592">
    <![LOG[In SSL, but with no client cert]LOG]!><time="15:25:44.750+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:8557">
    <![LOG[Set authenticator in transport]LOG]!><time="15:25:44.777+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:7592">
    <![LOG[In SSL, but with no client cert]LOG]!><time="15:25:44.782+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:8557">
    <![LOG[reply has no message header marker]LOG]!><time="15:25:44.794+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="libsmsmessaging.cpp:1967">
    <![LOG[Failed to send status message (80004005)]LOG]!><time="15:25:44.794+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="libsmsmessaging.cpp:4050">
    <![LOG[Failed to send the status message]LOG]!><time="15:25:44.794+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="database.cpp:444">
    <![LOG[PXE::DB_ReportStatus failed; 0x80004005]LOG]!><time="15:25:44.794+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="database.cpp:448">
    <![LOG[PXE Provider failed to process message.
    Unspecified error (Error: 80004005; Source: Windows)]LOG]!><time="15:25:44.794+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="pxehandler.cpp:1395">
    <![LOG[Set enterpirse certificate in transport]LOG]!><time="15:25:51.715+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:9207">
    <![LOG[Set media certificate in transport]LOG]!><time="15:25:51.731+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:9220">
    <![LOG[Set authenticator in transport]LOG]!><time="15:25:51.731+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:7592">
    <![LOG[In SSL, but with no client cert]LOG]!><time="15:25:51.731+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:8557">
    <![LOG[Set authenticator in transport]LOG]!><time="15:25:51.759+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:7592">
    <![LOG[In SSL, but with no client cert]LOG]!><time="15:25:51.765+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:8557">
    <![LOG[reply has no message header marker]LOG]!><time="15:25:51.776+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="libsmsmessaging.cpp:1967">
    <![LOG[PXE::DB_LookupDevice failed; 0x80004005]LOG]!><time="15:25:51.776+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="database.cpp:236">
    <![LOG[Set enterpirse certificate in transport]LOG]!><time="15:25:51.792+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:9207">
    <![LOG[Set media certificate in transport]LOG]!><time="15:25:51.806+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:9220">
    <![LOG[Set authenticator in transport]LOG]!><time="15:25:51.806+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:7592">
    <![LOG[In SSL, but with no client cert]LOG]!><time="15:25:51.806+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:8557">
    <![LOG[Set authenticator in transport]LOG]!><time="15:25:51.833+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:7592">
    <![LOG[In SSL, but with no client cert]LOG]!><time="15:25:51.839+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:8557">
    <![LOG[reply has no message header marker]LOG]!><time="15:25:51.849+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="libsmsmessaging.cpp:1967">
    <![LOG[Failed to send status message (80004005)]LOG]!><time="15:25:51.849+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="libsmsmessaging.cpp:4050">
    <![LOG[Failed to send the status message]LOG]!><time="15:25:51.849+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="database.cpp:444">
    <![LOG[PXE::DB_ReportStatus failed; 0x80004005]LOG]!><time="15:25:51.849+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="database.cpp:448">
    <![LOG[PXE Provider failed to process message.
    Unspecified error (Error: 80004005; Source: Windows)]LOG]!><time="15:25:51.849+420" date="06-05-2012" component="SMSPXE" context="" type="3" thread="4092" file="pxehandler.cpp:1395">

    Tuesday, June 5, 2012 11:25 PM

All replies

  • I made a typo sorry.

    when I try to boot to the SCCM WDS PXE server it downloads the WDSNBP file and displays the following:

    Architecture: x64

    WDSNBP started using DHCP referal

    Contacting server: 10.20.1.45 (Gateway: 0.0.0.0)

    No response from Windows deployment Services server

    Launching pxeboot.com....

    Thanks in advance!

    Tuesday, June 5, 2012 11:28 PM
  • 67 (smsboot/x86/wdsnbp.com) 
    [...]
    <![LOG[In SSL, but with no client cert]LOG]!><time="15:25:42.732+420" date="06-05-2012" component="SMSPXE" context="" type="1" thread="4092" file="libsmsmessaging.cpp:8557">
    [...]
    Contacting server: 10.20.1.45 (Gateway: 0.0.0.0)

    Option 67 should be set to smsboot\x86\wdsnbp.com on Microsoft DHCP servers.
    Are you using https mode? Any chance that there's a cert missing?
    Is 10.20.1.45 in the same subnet as the client? Can it be reached with a default gateway?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, June 6, 2012 7:11 AM
  • Thanks for your reply!

    I have option 67 set to smsboot/x86/wdsbp.com

    The site properties are set to use http or https and PKI certificate is not required

    It is on the same subnet as the DP server

    Looks like all the certs are valid and there

    Wednesday, June 6, 2012 3:02 PM
  • Is it possible to switch to http only for a while to test, is the PKI the issue here, or the rest of confmgr configuration?

    I noticed, that if you want to make the things to work with PXE, you must apply PXE in the proper order.

    1. Do not install WDS from Windows Server Management.

    2. Enable PXE support in DP role and let it install WDS role.

    3. Enable PXE support in boot images and redistribute them to DP.

    I fought with some PXE issues for a while before realizing this order issue. I also transformed my site server from http to https support and I had no issues with PXE during the transformation. Did you publish cert in DP?

    Wednesday, June 6, 2012 8:17 PM
  • Thanks for your help. I decided to rebuild and things are working now.
    Friday, June 8, 2012 6:01 PM