none
Cluster Disks not Moving from Server-1 to Server-2 & Disk Showing unknown and unreadable in Disk Management in Server-2

    Question

  • Hi ,

    We   have  Windows 2003 R2 Service Pack SP2, Microsoft Cluster with MS SQL 2000 Database.

    We are facing  Cluster  Fail-over  issue to one of our Server . Cluster Disks not Moving from  Server-1 to Server-2  & Showing unknown  and  unreadable in Disk Management in  Server-2.

     

     a> Problem History and action by our Support Partner  with sequence:

    • 1>     Problem start with Blue dump error.
    • 2>     Start Server with Last Good Configuration.
    • 3>     SAN storage battery by Support partner.
    • 4>     O/S repaired by Support partner.
    • 5>     Memory  changed by Support Partner
    • 6>    Evicted Node-2 from cluster, Unmapped LUN from Node-2 & uninstalled 

                Multi-path driver.

    • 7>    Remapped LUN & installed Multipath driver.
    • 8>    Reconfigured clustered on Node -2& try to failure it’s happening successfully  but after restart the server same problem persist unable to failure.
    • 9>    Cluster Disk Showing unknown  and  unreadable in Disk Management on  Server-2

           when we move cluster group.

    • 10> SAN Storage LUNs are showing in Storage Manager  Software with working Status.


    • 11> After repetitive remove and re-installed of Storage and Multi Path Driver  , Only  one Cluster  (Quorum Disk)  moving from Server-1 to Server-2,  Other Disk remain at Server-1.

    B> Event ID :

                  Following are main  error  showing after Cluster Group movement in Event Viewer   :

                  1>     (Delayed Write Failed} Windows was unable to save all the data for the file – Event ID :  50

                   2>     Cluster resource 'Disk Q:' in Resource Group 'Cluster Group' failed.  –        Event ID : 1069

                  3>     The system failed to flush data to the transaction log. Corruption may occur. -       Evend  ID :  57

                   4>     Cluster service was halted to prevent an inconsistency within the server cluster. The error code was 5027.

                          Event ID :  1073

     

    C > Details of Server :


    •     Operating System          :  Windows 2003 R2 32 Bit
    •    Cluster Type                    :  Microsoft Cluster  - Active – Passive .
    •    Server Hardware              :  IBM X3850
    •    Storage                            :  IBM DS43000    

    Now our support Partner give option of Re-installation of Operating System but we want to avoid re-installation.

    We are looking for  proper solution for Server Cluster issue without re-installation of Server.

     Bharat.



    • Edited by Bharat PG Sunday, September 15, 2013 11:20 AM
    Saturday, September 14, 2013 7:19 AM

Answers

  • Hi,

    It seems to be a big problem so maybe reinstall is a quicker way to get it back to work.

    Before that you could have a check on Cluster Service on both nodes and see if they are running with same account. 


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, September 16, 2013 1:57 PM
    Moderator