locked
Lync Edge fails to route message from internal to external NIC on Edge Logger Tool RRS feed

  • Question

  • I have a Lync Front end server and have enabled Federation with couple of external XMPP domains. My Lync FE is on a private network 10.0.0.x. My Edge internal NIC is also 10.0.0.x and my Edge external is 192.168.x.x. When I add a federated user to my Lync client contact list , the FE fwd it to Edge internal to be sent out. But nothing goes out of Edge External. From the Logging I can see 'Unable to route message' with description here. 

    TL_WARN(TF_DIAG) [0]0328.0D68::10/18/2012-23:04:46.826.000000f9 (SIPStack,SIPAdminLog::TraceDiagRecord:SIPAdminLog.cpp(145))$$begin_record
    LogType: diagnostic
    Severity: warning
    Text: Unable to route the request
    Result-Code: 0xc3e93d70 SIPPROXY_E_EPROUTING_MSG_ALLOWED_DOMAIN_NO_SRV_MATCH
    SIP-Start-Line: INVITE sip:jparker@external.domain SIP/2.0
    SIP-Call-ID: 2b83a09ea141445e993a5ad5b9b67df0
    SIP-CSeq: 1 INVITE
    Data: domain="external.domain";fqdn1="xmppgw.lync.comtrue5061";reason="The domain of the message resolved by DNS SRV but none of the FQDNs is in the same domain"
    $$end_record

    Note that my Edge and Xmpp gateway are workgroup server and not part of Lync domain (this is how the deployment is asked to be configured), now it is complaining that xmppgw is not in the same domain. 

    Please help me

    Friday, October 19, 2012 2:29 PM

Answers

  • It sounds like the domains have an XMPP SRV record, but the DNS A record returned does not match the SRV record domain suffix. You may need to define the A record in your federation settings if this is so. Just enter the SIP domain, then enter the DNS A record for their gateway. Lync as a rule will not trust the returned record if the SRV and DNs A record domain suffixes do not match.

    Cheers,

    Jeff

    • Proposed as answer by Kent-Huang Monday, October 22, 2012 8:17 AM
    • Marked as answer by Kent-Huang Monday, October 29, 2012 3:03 AM
    Sunday, October 21, 2012 5:50 AM
  • Hi,

    Although the Edge and xmpp gateway are workgroup server and not part of Lync domain, you need to add domain name as DNS suffix of the XMPP and Edge Server.

    For more info just for your reference:

    http://ocsguy.com/2010/11/29/deploying-lync-for-xmpp/


    Regards,

    Kent Huang

    TechNet Community Support ************************************************************************************************************************ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.


    • Edited by Kent-Huang Monday, October 22, 2012 8:17 AM
    • Marked as answer by Kent-Huang Monday, October 29, 2012 3:03 AM
    Monday, October 22, 2012 8:17 AM

All replies

  • Please note that I consider my 192.18.x.x to be my external and my federated external domains reside in the 192.168.x.x. So for Lync 192.168.x.x is the external. Basically my external federated domains are on the DMZ network (kind of). Since this is only a lab setup and not truly public yet.

    Thanks in advance.

    Friday, October 19, 2012 2:34 PM
  • Did you setup correctly routes and NICs on the Edge server?  Check this blog and take a look at the setup for the NICs and how to do "route add......."

    http://ocsguy.com/2010/11/21/deploying-an-edge-server-with-lync/

    Thank you.



    Please “Vote As Helpful” and/or “Mark As Answer” if this post helped you.

    Friday, October 19, 2012 3:02 PM
  • Did you define a domain suffix on the XMPP and Edge servers? It's on the same screen as the domain join process, but allows you to create an FQDN for the machine.
    Friday, October 19, 2012 3:22 PM
  • Is your default route set to the access edge nic? Same error to everyone?  Try me at brblackburnatcorelogicdotcom.  Post the results if different.


    BBB

    Friday, October 19, 2012 5:18 PM
  • It sounds like the domains have an XMPP SRV record, but the DNS A record returned does not match the SRV record domain suffix. You may need to define the A record in your federation settings if this is so. Just enter the SIP domain, then enter the DNS A record for their gateway. Lync as a rule will not trust the returned record if the SRV and DNs A record domain suffixes do not match.

    Cheers,

    Jeff

    • Proposed as answer by Kent-Huang Monday, October 22, 2012 8:17 AM
    • Marked as answer by Kent-Huang Monday, October 29, 2012 3:03 AM
    Sunday, October 21, 2012 5:50 AM
  • Hi,

    Although the Edge and xmpp gateway are workgroup server and not part of Lync domain, you need to add domain name as DNS suffix of the XMPP and Edge Server.

    For more info just for your reference:

    http://ocsguy.com/2010/11/29/deploying-lync-for-xmpp/


    Regards,

    Kent Huang

    TechNet Community Support ************************************************************************************************************************ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.


    • Edited by Kent-Huang Monday, October 22, 2012 8:17 AM
    • Marked as answer by Kent-Huang Monday, October 29, 2012 3:03 AM
    Monday, October 22, 2012 8:17 AM